FAQ  •  Register  •  Login

No srt external subtitles on samsung ue55ju6440w

<<

CyberTod

Serviio newbie

Posts: 6

Joined: Sun Oct 18, 2015 8:42 pm

Post Mon Oct 26, 2015 6:09 pm

Re: No srt external subtitles on samsung ue55ju6440w

Can you confirm it works without transcoding ?
I am using Plex for now. I may try this as well, but still hope Serviio will come up with a solution for this. I don't want to abandon it.
<<

Aaru Bui

Serviio newbie

Posts: 6

Joined: Fri Jun 12, 2015 1:37 am

Post Wed Oct 28, 2015 10:10 pm

Re: No srt external subtitles on samsung ue55ju6440w

There is one DLNA server I can guarantee has external SRT subtitles working with the J series and that is the build-in DLNA server on my Samsung Galaxy SII (Settings, Wireless and networks, Nearby devices, File sharing)

I've run Shark for Root and tweaked Serviio to return almost exactly the same data and still couldn't make Serviio show subs. If anyone wants a crack at this, I can provide the pcap file.
<<

flaksy

Streaming enthusiast

Posts: 25

Joined: Sat Oct 17, 2015 12:48 pm

Post Mon Nov 02, 2015 8:00 pm

Re: No srt external subtitles on samsung ue55ju6440w

CyberTod wrote:Can you confirm it works without transcoding ?
I am using Plex for now. I may try this as well, but still hope Serviio will come up with a solution for this. I don't want to abandon it.

I can confirm Universal Media Server shows works. It can show external subtitles without transcoding. I downloaded a custom J series profile from some UMS user on their forum and it works. Sadly it does not allow resuming play, it always starts from the beginning, virtual file that is supposed to enable resume does not load, so I am using UMS till Serviio comes up with a J profile. Also I miss directory structure customization and integration with movie databases from serviio. I still have serviio installed, but since most my movies and tv series are with external subs I cant play it anymore ... well i can, all files work, just subtitles won't show.

I can´t use plex since I have like 98% mkv's and Plex is transcoding them and I don't want to use transcoding at all.
<<

CyberTod

Serviio newbie

Posts: 6

Joined: Sun Oct 18, 2015 8:42 pm

Post Tue Nov 03, 2015 6:40 am

Re: No srt external subtitles on samsung ue55ju6440w

Can you link the profile here.

I am also using Plex, so far only on my E series, but it plays everything without transcoding.
<<

flaksy

Streaming enthusiast

Posts: 25

Joined: Sat Oct 17, 2015 12:48 pm

Post Fri Nov 06, 2015 3:44 pm

Re: No srt external subtitles on samsung ue55ju6440w

I use this one, although new UMS has already 2 build in profiles. But still I use this made by a UMS user:
http://www.universalmediaserver.com/for ... 87666ab092
<<

bastardonline

Serviio newbie

Posts: 1

Joined: Fri Nov 13, 2015 7:14 pm

Post Fri Nov 13, 2015 7:20 pm

Re: No srt external subtitles on samsung ue55ju6440w

I am reading this post regarding subtitles. I recently bought UE40J6200. I am using profile for H series. It is very strange that in some mkv files I do see subtitles and then in some not. I did not yet find a pattern which files are working and which are not. I tried many other DLNA servers but non of them work. I anyone is interested I can paste here torrent link for mkv files that do show subtitles.
<<

pikasino

Serviio newbie

Posts: 1

Joined: Sun Nov 15, 2015 5:26 pm

Post Sun Nov 15, 2015 5:35 pm

Re: No srt external subtitles on samsung ue55ju6440w

Hello everyone,
I have the exact same problem I have been searching all day about some solution but nothing.

"When I select the movie file in my Samsung TV it says *.mkv.mkv so somehow it gives double extension.
01.mkv and 01.srt in the same folder, to be sure I also created a 01.mkv.srt but that doesn't help."

Did you find any solution about it? :cry:
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16475

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Nov 16, 2015 2:09 pm

Re: No srt external subtitles on samsung ue55ju6440w

What if you remove this block from the sam_h profile

  Code:
 <ResourceTransportProtocolHandler>org.serviio.upnp.protocol.http.transport.SamsungWiseLinkProtocolHandler</ResourceTransportProtocolHandler>


If it doesn't help, try to also change this

  Code:
<MediaFormatProfile mime-type="video/x-mkv">MATROSKA</MediaFormatProfile>

to

  Code:
<MediaFormatProfile mime-type="video/x-matroska">MATROSKA</MediaFormatProfile>


in the same profile. Then try to play a mkv with external subs (don't forget to restart Serviio / PC for the changes to take effect)
<<

flaksy

Streaming enthusiast

Posts: 25

Joined: Sat Oct 17, 2015 12:48 pm

Post Mon Nov 16, 2015 10:40 pm

Re: No srt external subtitles on samsung ue55ju6440w

I made a copy of the H-series profile and updated according to your guidelines, but still it does not load external srt. Internal work as a charm. I stopped/started the service and console many times, rebooted PC. But still I can´t see the external subs on Samsung UE48J6272 :/ Below is the profile code:
  Code:
<Profile id="sam_j" name="Samsung TV / player (J-series)" extendsProfileId="1">
      <ContentDirectoryMessageBuilder>org.serviio.upnp.service.contentdirectory.SamsungDLNAMessageBuilder</ContentDirectoryMessageBuilder>
      <Detection>
         <UPnPSearch>
            <FriendlyName>(^\[TV\][A-Z]{2}\d{2}H[A-Z]?\d{3,4}.*)</FriendlyName>
            <ModelNumber>(1\.0)|(AllShare1\.0)</ModelNumber>
         </UPnPSearch>
         <HttpHeaders>
            <!-- for BD players -->
            <User-Agent>(.*SEC_HHP_BD-H.*)|(.*SEC_HHP_\[(HT|BD)\]H.*)|(\[BD\]H.*)</User-Agent>
         </HttpHeaders>
      </Detection>
      <DeviceDescription>
           <ExtraElements>
              &lt;sec:ProductCap&gt;smi,DCM10,getMediaInfo.sec,getCaptionInfo.sec&lt;/sec:ProductCap&gt;
            &lt;sec:X_ProductCap&gt;smi,DCM10,getMediaInfo.sec,getCaptionInfo.sec&lt;/sec:X_ProductCap&gt;
           </ExtraElements>
        </DeviceDescription>
        <MediaFormatProfiles>
       <MediaFormatProfile mime-type="video/x-matroska">MATROSKA</MediaFormatProfile>
            <MediaFormatProfile mime-type="video/x-msvideo" name="">AVI</MediaFormatProfile>
            <MediaFormatProfile mime-type="audio/x-flac">FLAC</MediaFormatProfile>
        </MediaFormatProfiles>
      <ContentDirectoryDefinitionFilter>org.serviio.upnp.service.contentdirectory.definition.SamsungContentDirectoryDefinitionFilter</ContentDirectoryDefinitionFilter>   
      <H264LevelCheck>FILE_ATTRIBUTES</H264LevelCheck>
      <Transcoding>         
         <!-- Transcode all h264 video with HIGH/MAIN > Level 4.1 on MPEG-TS stream with MPEG2VIDEO and ac3 audio transcoding -->
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" aBitrate="192" forceInheritance="true">
            <Matches container="*" vCodec="h264" profile="high_10" />
            <Matches container="*" vCodec="h264" profile="high" levelGreaterThan="4.2" />
            <Matches container="*" vCodec="h264" profile="main" levelGreaterThan="4.2" />
            <Matches container="*" vCodec="h265" />
                <Matches container="mp4" vCodec="mpeg4" aCodec="lpcm" />
                <Matches container="mp4" vCodec="dvvideo" />
                <Matches container="mp4" vCodec="mjpeg" />
         </Video>
         <Video targetContainer="mpegts" targetACodec="ac3" forceInheritance="true">
            <Matches container="wtv" vCodec="h264"/> 
         </Video>   
         <Video targetContainer="mpegts" forceInheritance="true">
            <Matches container="wtv" />
         </Video>
         <!-- transcode wmv2-wmav2, not: wmv3-wmapro it works ok on E series-->
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" forceInheritance="true">
            <Matches container="asf" vCodec="wmv2" />
         </Video>
         <Audio targetContainer="lpcm" forceInheritance="true">
            <Matches container="mp4" />
            <Matches container="ogg" />
            <Matches container="adts" />
            <Matches container="mp2" />
            <Matches container="wavpack" />
            <Matches container="mpc" />
                <Matches container="ape" />
                <Matches container="asf" />
         </Audio>
      </Transcoding>
      <OnlineTranscoding>
         <Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384">
            <Matches container="applehttp" vCodec="h264"/>
         </Video>      
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" aBitrate="384">
            <Matches container="asf" /> <!-- mms -->
            <Matches container="flv" /> <!-- transcoding all flv streams, even h264, to avoild premature disconnects, to avoid this, use Samsung C/D profile -->
         </Video>
      </OnlineTranscoding>
      <HardSubsTranscoding>
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" aBitrate="192"/>
      </HardSubsTranscoding>
      <AutomaticImageRotation>true</AutomaticImageRotation>
        <LimitImageResolution>false</LimitImageResolution>
        <Subtitles>
         <SoftSubs mime-type="smi/caption" />
      </Subtitles>
      <AllowChunkedTransfer>false</AllowChunkedTransfer>
   </Profile>
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16475

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Nov 17, 2015 8:45 am

Re: No srt external subtitles on samsung ue55ju6440w

Is anyone here able to install Universal Media Server with this profile: http://www.universalmediaserver.com/for ... 87666ab092

and use Wireshark to capture the packets sent between the server and the TV, when loading a file with subtitles?
<<

flaksy

Streaming enthusiast

Posts: 25

Joined: Sat Oct 17, 2015 12:48 pm

Post Thu Nov 19, 2015 6:44 am

Re: No srt external subtitles on samsung ue55ju6440w

You have a new PM with the trace file from wireshark. I hope it helps. If you need more traces, let me know.
<<

dayrepz

Serviio newbie

Posts: 1

Joined: Thu Nov 19, 2015 6:46 am

Post Thu Nov 19, 2015 7:09 am

Re: No srt external subtitles on samsung ue55ju6440w

Why not hardcode srt external subtitle into video? It works for me and though it may seem a bit tedious.
<<

flaksy

Streaming enthusiast

Posts: 25

Joined: Sat Oct 17, 2015 12:48 pm

Post Sat Nov 21, 2015 8:14 pm

Re: No srt external subtitles on samsung ue55ju6440w

It's like using this https://www.bunkus.org/videotools/mkvtoolnix/, but honestly I don't want to do it every new file and the 5TBs od old files ... I used external subs with avi, mp4. mkv files for over a decade and honestly I don't want to change anything about it :)
<<

gplayersv

Serviio newbie

Posts: 5

Joined: Tue Nov 24, 2015 8:19 am

Post Tue Nov 24, 2015 8:40 am

Re: No srt external subtitles on samsung ue55ju6440w

Same issue here with a Samsung 43J5500. Serviio used to work with my previous samsung tv, but now no subtitles.
Movies play, their extension is indeed shown as *.mkv.mkv, and when checking all the subtitle checkboxes they don't play anymore.

What works for me for the moment is Samsung AllShare but I really don't like it, I would definitely prefer using Serviio.
If I can help in any way let me know.
<<

flaksy

Streaming enthusiast

Posts: 25

Joined: Sat Oct 17, 2015 12:48 pm

Post Tue Nov 24, 2015 8:49 am

Re: No srt external subtitles on samsung ue55ju6440w

zip is working on it atm. So stay tuned :)
<<

gplayersv

Serviio newbie

Posts: 5

Joined: Tue Nov 24, 2015 8:19 am

Post Tue Nov 24, 2015 8:56 am

Re: No srt external subtitles on samsung ue55ju6440w

Great! 10x for the news!
<<

keys

Serviio newbie

Posts: 4

Joined: Sat Dec 22, 2012 7:29 pm

Post Wed Nov 25, 2015 10:36 pm

Re: No srt external subtitles on samsung ue55ju6440w

I have a Samsung UE48JU7500 and got the same problem with subtitles. Some video formats are also not supported.
Currently using Samsung H profile...
<<

gplayersv

Serviio newbie

Posts: 5

Joined: Tue Nov 24, 2015 8:19 am

Post Thu Dec 10, 2015 3:42 pm

Re: No srt external subtitles on samsung ue55ju6440w

No news regarding this? :D
<<

Aaru Bui

Serviio newbie

Posts: 6

Joined: Fri Jun 12, 2015 1:37 am

Post Sat Dec 12, 2015 4:55 am

Re: No srt external subtitles on samsung ue55ju6440w

flaksy, can I also have a copy of the Wireshark files? I can give this another shot.
<<

Schrectacular

Serviio newbie

Posts: 4

Joined: Mon Dec 14, 2015 3:31 am

Post Mon Dec 14, 2015 3:40 am

Re: No srt external subtitles on samsung ue55ju6440w

I have a UN55J6300 and have the same issue, very much looking forward to a fix.

Samsung does support .srt subtitle files on an external disk attached via USB... but only for certain file encodings! So annoying! My wife wants Chinese subtitles but the TV doesn't support UTF-8 or Simplified Chinese subtitle files.

So for now it's the laptop with an HDMI cable. But that gets old fast.

Thanks for the great product and support, I love Serviio!
PreviousNext

Return to Samsung

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.