FAQ  •  Register  •  Login

Deleted folders still appear

<<

gbswales

Serviio newbie

Posts: 11

Joined: Tue May 27, 2014 10:39 am

Post Tue Oct 06, 2015 10:32 pm

Deleted folders still appear

I recently re-organised my media folders into series eg \program series 1 \program series 2 etc rather than have the files in one folder for a whole series. When I had done this I deleted the old folders from the hard drive and forced a refresh. The new files appear in the right folders in media browser and my Samsung TV but in both places I still see the deleted folders. I have refreshed several times over a couple of days but they are still there. These are all sub folders of the main media directory, I don't understand how it can still be showing folders I have deleted from the drive
<<

DenyAll

DLNA master

Posts: 2070

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Wed Oct 07, 2015 1:42 am

Re: Deleted folders still appear

These are all sub folders of the main media directory
Was the main shared folder (as appears in Serviio Console, Library tab) also deleted? Is "Search for updates of currently shared files" ticked? Have you restarted the Serviio server?
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

gbswales

Serviio newbie

Posts: 11

Joined: Tue May 27, 2014 10:39 am

Post Wed Oct 07, 2015 4:04 am

Re: Deleted folders still appear

No the top level folder was not deleted
Yes I do have the auto update ticked (which works fine as I add things)
I had not tried stopping the server but I stopped it just now and then restarted it.
but serviio is still displaying the deleted folders. The attached image shows a simplified structure of the problem. The folders were deleted after I moved the video files to the new ones.

One strange thing is that today I deleted another folder and this one is no longer displaying - the only difference was that I deleted the folder while the video files were still in it. - forget this the folder is still showing in servioo!
Attachments
serviio folders.jpg
serviio folders.jpg (91.36 KiB) Viewed 4183 times
Last edited by gbswales on Wed Oct 07, 2015 12:43 pm, edited 1 time in total.
<<

DenyAll

DLNA master

Posts: 2070

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Wed Oct 07, 2015 11:20 am

Re: Deleted folders still appear

Strange. What OS are you on?

I am on Win7 and couldn't emulate your issue. I created a folder with two video files in it - folder appeared in Media Browser as did the files. As soon as I deleted the two files, it removed the folder from Mediabrowser ie. I didn't have to delete the folder itself, as soon as it is empty of valid media files it is removed from the Serviio library.

I wonder of what would happen if you recreate the folder "Title\Series1", move a media file to their (check that the file appears) and then move it back - will that make the folder disappear?
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

gbswales

Serviio newbie

Posts: 11

Joined: Tue May 27, 2014 10:39 am

Post Wed Oct 07, 2015 12:49 pm

Re: Deleted folders still appear

I am running Windows 8.1 and from what I can tell now - ANY deleted folder (with or without media) is still displayed in media browser.

I have also tried restarting computer and refreshing serviio but they are still showing its as if syncing removes links to media that is deleted or moved but not the link to a folder that gets deleted
<<

dates74

Serviio newbie

Posts: 2

Joined: Thu Oct 08, 2015 3:54 pm

Post Thu Oct 08, 2015 4:18 pm

Re: Deleted folders still appear

I run Windows 7 Professional on my Home Media Server and i use Serviio to provide content to my DLNA devices. I too am having a problem with these deleted folders showing up in my Serviio selections. If I open Serviio on my Panasonic Viera TC-P65VT30 or my Sony XBR-70X850B, and i select videos, then i select folders, then i select a folder that i titled Kids movies, or HD movies. When i open the folder I see folders that I already deleted that once contained content. I deleted the folder off of the HDD but it still shows up in Serviio and i cannot figure out how to remove it. I like serviio and i have used it for years now. I have never had these problems before. I seems like it started happening after a recent update.

Can anyone help? I'd really like to keep using serviio, but as these delete folder continue to accumulate, it has become a practically unusable.
<<

atc98092

User avatar

DLNA master

Posts: 2214

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state) - temporary assignment to Washington DC

Post Thu Oct 08, 2015 6:05 pm

Re: Deleted folders still appear

One possibility. When something is deleted from Windows, it isn't really gone. It's moved into a hidden folder at the root of the drive. That's where things in the Recycle Bin actually reside. I've had times that deleted videos are still listed, and I have to remove them from the hidden folder.

Two things you can try. First, don't have any of your folders directly at the root of the drive. That way the hidden trash folder isn't in the Serviio search path. for example, on one of my drives with TV episodes, my folder structure is as follows: I:\Series1\Each Series Folder\. The folder location set in the Serviio console is I:\Series1, NOT I:\.

You can also just manually go to the hidden folder and delete the files/folders from within. You have to enable Viewing Hidden System files in Windows Explorer. I've done it this way, but since you have to do it every time, the first method is preferable.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging Identify video file contents
<<

gbswales

Serviio newbie

Posts: 11

Joined: Tue May 27, 2014 10:39 am

Post Thu Oct 08, 2015 10:55 pm

Re: Deleted folders still appear

I understand the theory of what you are suggesting however I already have explorer set to display hidden files and folders but my media partition only shows the three folders I created also serviio points to three specific folders individually rather than the partition. The deleted folders displaying in Serviio were all in the one I have highlighted
folder structure.jpg
folder structure.jpg (55.03 KiB) Viewed 4163 times


With media files and folders I generally use shift + delete so they should not get stored in recycle bin anyway.
<<

atc98092

User avatar

DLNA master

Posts: 2214

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state) - temporary assignment to Washington DC

Post Fri Oct 09, 2015 12:11 am

Re: Deleted folders still appear

To see the folder I am referring to, you have to uncheck "Hide protected operating system files (Recommended)". It is considered a system folder, and just showing "hidden" folders won't show it. It should be labeled "$RECYCLE.BIN".

That's why my second suggestion is the easier. Just don't set Serviio to see the root of the hard drive, and these deleted things should go away. Although doing the SHIFT-DELETE should bypass the hidden folder.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging Identify video file contents
<<

dates74

Serviio newbie

Posts: 2

Joined: Thu Oct 08, 2015 3:54 pm

Post Mon Oct 12, 2015 12:41 am

Re: Deleted folders still appear

dates74 wrote:I run Windows 7 Professional on my Home Media Server and i use Serviio to provide content to my DLNA devices. I too am having a problem with these deleted folders showing up in my Serviio selections. If I open Serviio on my Panasonic Viera TC-P65VT30 or my Sony XBR-70X850B, and i select videos, then i select folders, then i select a folder that i titled Kids movies, or HD movies. When i open the folder I see folders that I already deleted that once contained content. I deleted the folder off of the HDD but it still shows up in Serviio and i cannot figure out how to remove it. I like serviio and i have used it for years now. I have never had these problems before. I seems like it started happening after a recent update.

Can anyone help? I'd really like to keep using serviio, but as these delete folder continue to accumulate, it has become a practically unusable.



Update: Problem solved: I totally deinstalled Serviio. I reinstalled it, but changed the name of the folder to Serviio 152, just to be certain I had a fresh install. Everything loaded fine and is working perfectly.

try it
<<

gbswales

Serviio newbie

Posts: 11

Joined: Tue May 27, 2014 10:39 am

Post Mon Oct 12, 2015 4:05 am

Re: Deleted folders still appear

I had guessed that uninstalling re-installing might get rid of the current problem but I wonder if the problem will return the next time I delete sub -folders.
<<

MikeH

Serviio newbie

Posts: 1

Joined: Tue Dec 01, 2015 4:12 pm

Post Tue Dec 01, 2015 4:16 pm

Re: Deleted folders still appear

This drove me mad - Eventually I deleted the folder from Serviio - Library - Folder - and hit Save
Waited a while and added folder in again - all nice and neat - don't know if it will last but it was a fix for me that took little effort !
<<

falk

Serviio newbie

Posts: 5

Joined: Wed Apr 06, 2016 8:16 pm

Post Wed Apr 06, 2016 8:51 pm

Re: Deleted folders still appear

This thread shows up first in a Google search, so let me append to it ...

I am having the exact same problem and it is driving me nuts. Serviio 1.6 and MacOSX 10.10.

Deleting and adding the library path, or reinstalling Serviio is no option for me. Because a full fresh Serviio scan takes several days to complete because of the extremely slow code which creates thumbnails for very large images.

Any new insight about this bug in the Serviio delta scanner? It should be a simple piece of Java code. I don't get why it doesn't work as advertized.

Kind regards,
Falk
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16495

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Apr 06, 2016 9:14 pm

Re: Deleted folders still appear

It's OS dependent really. OSX though doesn't use the OS events, so it basically monitors a folder state vs what is in memory as a last state of the folder. You can enable detailed log, delete a file / folder and post the log here with details of what you removed.
<<

keithyv

Serviio newbie

Posts: 2

Joined: Sat Nov 09, 2013 2:01 am

Post Tue Nov 08, 2016 2:26 pm

Re: Deleted folders still appear

I have same issue.

I think I renamed some folders but now on remote clients the old folders still show up and an error is thrown when you try to play one of the non-existent files.

V1.7.1.1 (upgraded from earlier version but problem remained)

I've re-created the folders that Serviio thinks at still there , refreshed library but errors remain...
Error:

2016-11-08 22:22:12,752 DEBUG [VideoDAOImpl] Retrieving list of videos for folder 362 (from=0, count=30) [No_Restriction]
2016-11-08 22:22:12,798 ERROR [ContainerNode] Cannot retrieve results of action command: Cannot execute library command for list: No enum constant org.serviio.library.local.OnlineDBIdentifier.5
org.serviio.upnp.service.contentdirectory.command.CommandExecutionException: Cannot execute library command for list: No enum constant org.serviio.library.local.OnlineDBIdentifier.5
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItemList(AbstractCommand.java:160)
at org.serviio.upnp.service.contentdirectory.definition.ContainerNode.executeListAction(ContainerNode.java:256)
at org.serviio.upnp.service.contentdirectory.definition.ActionNode.retrieveContainerItems(ActionNode.java:142)
at org.serviio.upnp.service.contentdirectory.ContentDirectoryEngine.browse(ContentDirectoryEngine.java:102)
at org.serviio.upnp.service.contentdirectory.ContentDirectory.Browse(ContentDirectory.java:164)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeOperation(ServiceInvoker.java:253)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeService(ServiceInvoker.java:93)
at org.serviio.upnp.webserver.ServiceControlRequestHandler.handleRequest(ServiceControlRequestHandler.java:65)
at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:66)
at org.apache.http.protocol.HttpService.doService(HttpService.java:423)
at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:78)
at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:341)
at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:204)
Caused by: java.lang.IllegalArgumentException: No enum constant org.serviio.library.local.OnlineDBIdentifier.5
at java.lang.Enum.valueOf(Enum.java:238)
at org.serviio.library.local.OnlineDBIdentifier.valueOf(OnlineDBIdentifier.java:16)
at org.serviio.library.local.OnlineDBIdentifier$1.enumValue(OnlineDBIdentifier.java:23)
at org.serviio.library.local.OnlineDBIdentifier$1.enumValue(OnlineDBIdentifier.java:20)
at org.serviio.library.local.EnumMapConverter.convert(EnumMapConverter.java:29)
at org.serviio.library.local.OnlineDBIdentifier.parseFromString(OnlineDBIdentifier.java:28)
at org.serviio.library.dao.VideoDAOImpl.initVideo(VideoDAOImpl.java:1558)
at org.serviio.library.dao.VideoDAOImpl.mapResultSet(VideoDAOImpl.java:1482)
at org.serviio.library.dao.VideoDAOImpl.retrieveVideosForFolder(VideoDAOImpl.java:354)
at org.serviio.library.local.service.VideoService.getListOfVideosForFolder(VideoService.java:358)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.getItemsForMediaType(AbstractListObjectsByFSHierarchyCommand.java:256)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.retrieveList(AbstractListObjectsByFSHierarchyCommand.java:124)
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItemList(AbstractCommand.java:154)
... 16 more
2016-11-08 22:22:12,802 WARN [ContentDirectory] Browse for object id V_F^FOL*R1$F274$F362 failed with exception: org.serviio.upnp.service.contentdirectory.command.CommandExecutionException: Cannot execute library command for list: No enum constant org.serviio.library.local.OnlineDBIdentifier.5
java.lang.RuntimeException: org.serviio.upnp.service.contentdirectory.command.CommandExecutionException: Cannot execute library command for list: No enum constant org.serviio.library.local.OnlineDBIdentifier.5
at org.serviio.upnp.service.contentdirectory.definition.ContainerNode.executeListAction(ContainerNode.java:259)
at org.serviio.upnp.service.contentdirectory.definition.ActionNode.retrieveContainerItems(ActionNode.java:142)
at org.serviio.upnp.service.contentdirectory.ContentDirectoryEngine.browse(ContentDirectoryEngine.java:102)
at org.serviio.upnp.service.contentdirectory.ContentDirectory.Browse(ContentDirectory.java:164)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeOperation(ServiceInvoker.java:253)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeService(ServiceInvoker.java:93)
at org.serviio.upnp.webserver.ServiceControlRequestHandler.handleRequest(ServiceControlRequestHandler.java:65)
at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:66)
at org.apache.http.protocol.HttpService.doService(HttpService.java:423)
at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:78)
at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:341)
at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:204)
Caused by: org.serviio.upnp.service.contentdirectory.command.CommandExecutionException: Cannot execute library command for list: No enum constant org.serviio.library.local.OnlineDBIdentifier.5
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItemList(AbstractCommand.java:160)
at org.serviio.upnp.service.contentdirectory.definition.ContainerNode.executeListAction(ContainerNode.java:256)
... 15 more
Caused by: java.lang.IllegalArgumentException: No enum constant org.serviio.library.local.OnlineDBIdentifier.5
at java.lang.Enum.valueOf(Enum.java:238)
at org.serviio.library.local.OnlineDBIdentifier.valueOf(OnlineDBIdentifier.java:16)
at org.serviio.library.local.OnlineDBIdentifier$1.enumValue(OnlineDBIdentifier.java:23)
at org.serviio.library.local.OnlineDBIdentifier$1.enumValue(OnlineDBIdentifier.java:20)
at org.serviio.library.local.EnumMapConverter.convert(EnumMapConverter.java:29)
at org.serviio.library.local.OnlineDBIdentifier.parseFromString(OnlineDBIdentifier.java:28)
at org.serviio.library.dao.VideoDAOImpl.initVideo(VideoDAOImpl.java:1558)
at org.serviio.library.dao.VideoDAOImpl.mapResultSet(VideoDAOImpl.java:1482)
at org.serviio.library.dao.VideoDAOImpl.retrieveVideosForFolder(VideoDAOImpl.java:354)
at org.serviio.library.local.service.VideoService.getListOfVideosForFolder(VideoService.java:358)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.getItemsForMediaType(AbstractListObjectsByFSHierarchyCommand.java:256)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.retrieveList(AbstractListObjectsByFSHierarchyCommand.java:124)
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItemList(AbstractCommand.java:154)
... 16 more
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16495

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Nov 10, 2016 8:50 am

Re: Deleted folders still appear

I will look at this error. Looks like corrupted DB might be the case but let me double check.
<<

MegaMike

Streaming enthusiast

Posts: 27

Joined: Sat Jan 12, 2013 7:58 pm

Post Tue Sep 05, 2017 7:10 am

Re: Deleted folders still appear

I've experienced this problem too, with deleted files and folders lingering for a long time. I've found that rebooting my computer sometimes helps clear these deleted folders and files.

Return to Samsung

Who is online

Users browsing this forum: Bing [Bot] and 4 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.