FAQ  •  Register  •  Login

HEVC

<<

421ImLate

Serviio newbie

Posts: 6

Joined: Tue Apr 19, 2016 8:43 pm

Location: Washington State

Post Tue Apr 19, 2016 9:17 pm

HEVC

Hi,
I'm having problems with Serviio not playing x265 HEVC files, all I get when trying to play x265 HEVC files is Not Supported Video codex. I'm using Serviio 1.6.1, Win 7 Pro X64, Samsung UN46C6800. The files play fine on my computer using VLC, so all I can see is that Serviio doesn't have the codex to play x265 HEVC files? I have come across a few other files (.avi) that won't play, but I just convert them to mkv or mp4 and they work.

List of x265 HEVC files that are reported as Not Supported Video Codex..... *arkness Falls 2003 BDRip 1080p x265 AC 3, The *rothers Grimm 2005 BDRip 1080p x265 AC3, The *eople Under The Stairs 1991 BDRip 1080p x265 AC3, The *ark Knight Triology 1080p BluRay HEVC x265... all three movies report as Not Supported Video Codex.

I also tried playing the files thru my Samsung Blu-Ray player BD-D5700 and get the same result.... Not Supported Video Codex.


Thanks,

421ImLate
<<

atc98092

User avatar

DLNA master

Posts: 2150

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Wed Apr 20, 2016 12:08 am

Re: HEVC

What profile are you using? I'm not sure any of the profiles have been updated yet for H265 except for the J and maybe H series profiles. I can play H.265 MP4 videos on my TV with no problem, but of course the TV will play them without transcoding.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Samsung UN24H4500 TV, Sony BDP-S3500, Insignia Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging
<<

421ImLate

Serviio newbie

Posts: 6

Joined: Tue Apr 19, 2016 8:43 pm

Location: Washington State

Post Wed Apr 20, 2016 12:59 am

Re: HEVC

atc98092 wrote:What profile are you using? I'm not sure any of the profiles have been updated yet for H265 except for the J and maybe H series profiles. I can play H.265 MP4 videos on my TV with no problem, but of course the TV will play them without transcoding.



I'm using the Samsung c/d series profile on both the TV and the Blu-Ray player. Just checked to see if they would play thru the TV's USB, and nope they won't, Not Supported Video Codex.

Personal computer, i7 3770k, AsRock MB, 16GB DDR3@2133Mhz, AMD 290X 4GB video card, 36TB hard-drive space.
Private P2P server/Home server, i7 2600k, AsRock MB 8GB DDR3@1600Mhz, AMD 6850 1GB x2 video cards, 5TB hard-drive space
<<

DenyAll

DLNA master

Posts: 2064

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Wed Apr 20, 2016 4:57 am

Re: HEVC

Do you have Transcoding enabled?
The Samsung C/D Profile inherits from the Samsung H profile, which transcodes H265 files.
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

421ImLate

Serviio newbie

Posts: 6

Joined: Tue Apr 19, 2016 8:43 pm

Location: Washington State

Post Wed Apr 20, 2016 7:07 am

Re: HEVC

DenyAll wrote:Do you have Transcoding enabled?
The Samsung C/D Profile inherits from the Samsung H profile, which transcodes H265 files.



If Transcoding is enabled I get Not Supported Video Data, with Transcoding disabled I get Not Supported Video Codex. Either way they won't play on the TV. Is H265 the same as x265 HEVC?

I only have one file that is H265 and it does not play either.

Used a program called Everything to search my computer for x265 and found the x265 codex in VLC folders and in the FFmpeg 3.0.1 folder and about 30 movies/shows that are x265, I have watched some of them using an older version of Serviio. I just switched to the 1.6.1 version.
<<

421ImLate

Serviio newbie

Posts: 6

Joined: Tue Apr 19, 2016 8:43 pm

Location: Washington State

Post Wed Apr 20, 2016 7:38 am

Re: HEVC

ok, I fixed it, went back to Serviio 1.5.2 and they are all working now. Looked at the transcoding folder which is on a empty 60 gig SSD and Serviio is transcoding the files correctly. So I would think its a bug in the 1.6.1 version.
<<

atc98092

User avatar

DLNA master

Posts: 2150

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Wed Apr 20, 2016 12:25 pm

Re: HEVC

Only the 4K TVs will play HEVC (H.265) without transcoding, so yes yours needs to be transcoded. Not sure why 1.6.1 isn't working, but Zip will need to look at that.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Samsung UN24H4500 TV, Sony BDP-S3500, Insignia Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16420

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Apr 22, 2016 6:40 pm

Re: HEVC

could you post detailed log of playing the file in 1.5.2 and 1.6.1 ?
<<

dpaul1701

Serviio newbie

Posts: 4

Joined: Tue Nov 13, 2012 2:32 pm

Post Fri Dec 30, 2016 11:51 am

Re: HEVC

I am glad that someone else has discovered this issue. I have the exact same problem with a similar resolution with the exception that I only had to revert to v1.6.  Ever since 1.6.1 Serviio will no longer play x265 files on my TV (Samsung UN55D8000 Series TV using the C/D profile). I am not quite sure how my TV successfully plays the x265 files without transcoding, but it does and only with Serviio 1.6 and earlier. Once I upgraded to 1.6.1, 1.7.1.1 or 1.8, HECV files no longer play, I receive the same error messages as '421ImLate'. I can only conclude that something changed since v1.6. Any chance that you could investigate and perhaps restore this functionality? I am happy to assist with testing in any way that I can. Thank you!
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16420

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Dec 30, 2016 9:47 pm

Re: HEVC

can you post ffmpeg -i for the file?

Return to Samsung

Who is online

Users browsing this forum: No registered users and 6 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.