FAQ  •  Register  •  Login

Playlist never shows up in F6400 browsing

<<

Mozts

Serviio newbie

Posts: 11

Joined: Fri Aug 30, 2013 10:42 pm

Post Thu Dec 07, 2017 5:00 pm

Playlist never shows up in F6400 browsing

I've been trying to get Serviio to show a music playlist from the library. I'm sorry if this is repetitive, however I have searched the forums for a solution but couldn't find any that worked.

Simply put, playlists will not appear in the library. I've tried both Serviio 1.5.2 and the latest 1.9, I've tried Windows Media Player created playlists and Playlist Creator's playlist (absolute and relative types), pls and m3u extensions, tried folder browsing, playlist browsing, different folders... Same result always.

I've refreshed the entire library just to make sure it was working properly. It still wouldn't pick up the playlist. But then I copied I single .mp3 in the playlist folder and it was refreshed instantly (auto refresh on, pole off). Serviio seems to be ignoring .pls and .m3u extensions.

Everything else works perfectly, it's a fan-freaking-tastic, by far the best DLNA I've used.

My system is a Windows 10 x64 with a Samsung F4600 (setup with the provided profile).

In any case, thanks for the great software.
<<

atc98092

User avatar

DLNA master

Posts: 2764

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Thu Dec 07, 2017 9:36 pm

Re: Playlist never shows up in F6400 browsing

I use PLS files created with Playlist Creator without any issue. Could you upload one of your playlist files here to see if there's something that doesn't look right? A question I have to ask: are your playlist files located in one of your media folders? It has to be a location that Serviio scans. A copy of your log would be of assistance as well.

Have you checked to see if the playlists appear in Media Browser? One final question that has to be asked: you do have Playlists enabled on the Presentation tab of the console, right?
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

Mozts

Serviio newbie

Posts: 11

Joined: Fri Aug 30, 2013 10:42 pm

Post Fri Dec 08, 2017 1:41 am

Re: Playlist never shows up in F6400 browsing

atc98092 wrote:I use PLS files created with Playlist Creator without any issue. Could you upload one of your playlist files here to see if there's something that doesn't look right?


Can't seem to upload them straight to forum, but here they are at 4shared:

PLS: https://www.4shared.com/file/abmWHW0Kca ... o_CD1.html

M3U: https://www.4shared.com/file/S7RvEioKca ... o_CD1.html

atc98092 wrote:A question I have to ask: are your playlist files located in one of your media folders? It has to be a location that Serviio scans.


Both the source folders and playlist folder are added in serviio's library and functional except for the playlist files.

Source folder is added as sub-folders, if that means anything.

atc98092 wrote:A copy of your log would be of assistance as well.


Attached.

atc98092 wrote:Have you checked to see if the playlists appear in Media Browser?


They do not. Same result as the TV browser.

atc98092 wrote:One final question that has to be asked: you do have Playlists enabled on the Presentation tab of the console, right?


My setup is as follows:

Image

Thanks for your time.
Attachments
serviio.log
(322.25 KiB) Downloaded 99 times
<<

JenniferT

Serviio newbie

Posts: 1

Joined: Mon Dec 04, 2017 8:50 am

Post Fri Dec 08, 2017 7:14 am

Re: Playlist never shows up in F6400 browsing

I didn't face it with mine.
<<

atc98092

User avatar

DLNA master

Posts: 2764

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Fri Dec 08, 2017 11:07 am

Re: Playlist never shows up in F6400 browsing

I tried downloading from the posting site, but they want me to provide information I'm not willing to provide. Try zipping the file then uploading the zipped file. I'll look over the log when I get home this afternoon. Since they aren't appearing in MediaBrowser, we can eliminate any issue with the profile you are using.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

freaknik

User avatar

DLNA master

Posts: 195

Joined: Thu Mar 27, 2014 2:05 pm

Post Fri Dec 08, 2017 11:53 am

Re: Playlist never shows up in F6400 browsing

M3u is text based you can use something like pastebin or even the [code*] tag without asterisk. https://pastebin.com no registration required
<<

atc98092

User avatar

DLNA master

Posts: 2764

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Fri Dec 08, 2017 2:12 pm

Re: Playlist never shows up in F6400 browsing

pls is also text based, so could be pasted here as well. But yes, it's good to use the CODE tags to keep the post size under control and provide the scrolling window for larger amounts of text.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

Mozts

Serviio newbie

Posts: 11

Joined: Fri Aug 30, 2013 10:42 pm

Post Sat Dec 09, 2017 12:34 am

Re: Playlist never shows up in F6400 browsing

freaknik wrote:M3u is text based you can use something like pastebin or even the [code*] tag without asterisk. https://pastebin.com no registration required


Ohh did not know that. Thanks.

There it goes, same playlist, m3u and pls versions.

  Code:
#EXTM3U
#EXTINF:115,Iron Maiden - Intro
\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\Intro.mp3
#EXTINF:281,Iron Maiden - The Wicker Man
\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\The Wicker Man.mp3
#EXTINF:408,Iron Maiden - Ghost Of The Navigator
\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\Ghost Of The Navigator.mp3
#EXTINF:366,Iron Maiden - Brave New World
\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\Brave New World.mp3
#EXTINF:185,Iron Maiden - Wrathchild
\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\Wrathchild.mp3
#EXTINF:386,Iron Maiden - 2 Minutes To Midnight
\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\2 Minutes To Midnight.mp3
#EXTINF:435,Iron Maiden - Blood Brothers
\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\Blood Brothers.mp3
#EXTINF:649,Iron Maiden - Sign Of The Cross
\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\Sign Of The Cross.mp3
#EXTINF:282,Iron Maiden - The Mercenary
\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\The Mercenary.mp3
#EXTINF:275,Iron Maiden - The Trooper
\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\The Trooper.mp3


  Code:
[playlist]
File1=\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\Intro.mp3
Title1=Iron Maiden - Intro
Length1=115
File2=\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\The Wicker Man.mp3
Title2=Iron Maiden - The Wicker Man
Length2=281
File3=\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\Ghost Of The Navigator.mp3
Title3=Iron Maiden - Ghost Of The Navigator
Length3=408
File4=\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\Brave New World.mp3
Title4=Iron Maiden - Brave New World
Length4=366
File5=\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\Wrathchild.mp3
Title5=Iron Maiden - Wrathchild
Length5=185
File6=\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\2 Minutes To Midnight.mp3
Title6=Iron Maiden - 2 Minutes To Midnight
Length6=386
File7=\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\Blood Brothers.mp3
Title7=Iron Maiden - Blood Brothers
Length7=435
File8=\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\Sign Of The Cross.mp3
Title8=Iron Maiden - Sign Of The Cross
Length8=649
File9=\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\The Mercenary.mp3
Title9=Iron Maiden - The Mercenary
Length9=282
File10=\Ramon\Músicas\Iron Maiden\Rock In Rio\CD 1\The Trooper.mp3
Title10=Iron Maiden - The Trooper
Length10=275
NumberOfEntries=10
Version=2


And here's a pastebin for the log: https://pastebin.com/k19DKaQE
<<

atc98092

User avatar

DLNA master

Posts: 2764

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sat Dec 09, 2017 2:03 pm

Re: Playlist never shows up in F6400 browsing

You might try changing the file path to absolute, with drive letter. Although mine works both ways, it seems more reliable if the full file path is listed.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

Mozts

Serviio newbie

Posts: 11

Joined: Fri Aug 30, 2013 10:42 pm

Post Sun Dec 10, 2017 2:00 pm

Re: Playlist never shows up in F6400 browsing

atc98092 wrote:You might try changing the file path to absolute, with drive letter. Although mine works both ways, it seems more reliable if the full file path is listed.


And just like that it worked.

Thank you very much.
<<

atc98092

User avatar

DLNA master

Posts: 2764

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sun Dec 10, 2017 2:56 pm

Re: Playlist never shows up in F6400 browsing

Excellent! :D
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents

Return to Samsung

Who is online

Users browsing this forum: Google [Bot] and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.