FAQ  •  Register  •  Login

MKV Fast Forward working!!

<<

aolivero

Serviio newbie

Posts: 4

Joined: Thu Sep 22, 2011 12:03 am

Post Thu Sep 22, 2011 12:13 am

MKV Fast Forward working!!

Hi All,

this post only to explain why in some case fast forward and rewind doesn't work in MKV.
The problem is related to the version of mkvtoolnix (and related mkvmerge) used to create the mkv.
Basically if you create the mkv with a version 4.0 or >, the Samsung BD reader (and may be also the television) doesn't handle the mkv in the right way. If you use a previous version (e.g i used the 3.4) everything work fine.
This is not a problem related to serviio but to the samsung firmware/codec. In fact the same problem exist also when you copy the mkv to a usb drive and you try to run it direcly from the player.
So the way to fix the mkv than doesn't fast forward or rewind is:

1) Install mkvtoolnix 3.4
2) Open the mkv with this version and resave it

That's all.

Ciao.
<<

Illico

User avatar

DLNA master

Posts: 4337

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Thu Sep 22, 2011 7:23 am

Re: MKV Fast Forward working!!

Thank you, I had heard this before. Thanks for that refresh. This could be a sticky topic TIP.
Illico
Sony 2010 KDL-46EX501 | BDP-S373 | SMP-N100 | Windows 8-i7 | Network DD HD-CE1.5TLU2 | Livebox2-UHD86 | ServiiDroid | ServiiGo | BubbleUPnP
Serviio beta tester - Moderator
<<

Grumpa

Serviio newbie

Posts: 7

Joined: Sun Feb 20, 2011 3:14 am

Post Mon Oct 03, 2011 6:40 pm

Re: MKV Fast Forward working!!

Unfortunately that didn't work for me. I've remuxed with 3.4, 4.0 and 5.0 (with compression at "none") with no difference. All play well, but none FF.

:( I have no idea yet what the problem is but it all started after the latest firmware update on my C5500. I'm going to gather a few MediaInfo reports from files that FF and those that don't. Lately more don't than do.
<<

Sebanisu

Streaming enthusiast

Posts: 29

Joined: Tue Sep 13, 2011 3:31 am

Post Fri Oct 14, 2011 1:28 am

Re: MKV Fast Forward working!!

I tried remuxing with 3.0.0 and it still didn't. FF.
The length of video on top of the screen says 00:00:00/00:00:00
and some off the files like this end early.
I thought remuxing would fix it.
I used mkvclean and it didn't help either.
I'm looking at other alternatives.
Samsung BD-C5500 And XBOX 360| Windows 7)
<<

aolivero

Serviio newbie

Posts: 4

Joined: Thu Sep 22, 2011 12:03 am

Post Sun Oct 16, 2011 3:22 pm

Re: MKV Fast Forward working!!

Sebanisu wrote:I tried remuxing with 3.0.0 and it still didn't. FF.
The length of video on top of the screen says 00:00:00/00:00:00
and some off the files like this end early.
I thought remuxing would fix it.
I used mkvclean and it didn't help either.
I'm looking at other alternatives.


2 suggestion:

1) Try using version 3.4 and not 3.0
2) Update firmware of BD Player to latest version.

If this still doesn't work you can try to uncrop the video that doesn't work, if they are cropped. See my post on Panasonic thread for further details.

Hope it can help.
<<

tomrum

Serviio newbie

Posts: 4

Joined: Tue Jul 20, 2010 1:32 pm

Post Mon Oct 24, 2011 1:28 am

Re: MKV Fast Forward working!!

I'll try this. I've been remuxing all mkv to m2ts with tsmuxer and that works too. Only noticed this since the latest firmware update for the BD player.
<<

Vintila

Streaming enthusiast

Posts: 39

Joined: Wed Nov 02, 2011 5:57 pm

Post Fri Nov 04, 2011 7:36 pm

Re: MKV Fast Forward working!!

tomrum wrote:I'll try this. I've been remuxing all mkv to m2ts with tsmuxer and that works too. Only noticed this since the latest firmware update for the BD player.


Thanks a lot this worked!
<<

JLMiller

User avatar

Serviio newbie

Posts: 17

Joined: Fri Nov 04, 2011 11:20 pm

Location: Deerfield, NH / Sanford, FL, US

Post Wed Nov 23, 2011 12:27 am

Re: MKV Fast Forward working!!

Well, not for me. I re-muxed a .mkv file to .m2ts, and it still won't FF / FR on my Samsung BD-C6800 Blu-ray player.
<<

Digitoxin

Streaming enthusiast

Posts: 28

Joined: Thu Dec 08, 2011 4:30 am

Post Thu Dec 08, 2011 4:55 am

Re: MKV Fast Forward working!!

The .MKV needs to be muxed with the option --clusters-in-meta-seek in mkvmerge. This was turned on by default in previous versions, but is off by default now. This is required to be able to jump backwards and forwards on Samsung players.
<<

JLMiller

User avatar

Serviio newbie

Posts: 17

Joined: Fri Nov 04, 2011 11:20 pm

Location: Deerfield, NH / Sanford, FL, US

Post Sun Dec 11, 2011 3:28 pm

Re: MKV Fast Forward working!!

@Digitoxin - Thanks for trying, but still no FF/FR.

- John
<<

DLN Eh?

Serviio newbie

Posts: 7

Joined: Mon Dec 12, 2011 12:48 am

Post Mon Dec 12, 2011 1:29 am

Re: MKV Fast Forward working!!

Digitoxin wrote:The .MKV needs to be muxed with the option --clusters-in-meta-seek in mkvmerge.


This seems to have worked! I remuxed a file using this option and now I can skip ahead, backward, and jump to a specific point in time. I still have the original mkv and it still doesn't allow skipping.

Just to be clear, I use the left/right arrows to skip, and the Tools button to jump. This was working on all older MKVs and stopped working for most newer ones until this fix. The Rew/FF has never worked.

Samsumg C5500 fw 1024.0, mkvmerge 5.0.1
<<

XtraCrispi

Serviio newbie

Posts: 3

Joined: Mon Dec 12, 2011 6:33 am

Post Mon Dec 12, 2011 6:35 am

Re: MKV Fast Forward working!!

Digitoxin, I downloaded ver 3.4 and do not see the option "clusters-in-meta-seek in mkvmerge". Where is this option located?
Last edited by XtraCrispi on Mon Dec 12, 2011 7:06 am, edited 2 times in total.
<<

DLN Eh?

Serviio newbie

Posts: 7

Joined: Mon Dec 12, 2011 12:48 am

Post Mon Dec 12, 2011 6:57 am

Re: MKV Fast Forward working!!

I've done a few of these repairs now.
You don't need v3.4, I've been using 5.0.1.

The option goes in the 'User defined options' field on the 'Extra options' tab. Just paste this in, including the hyphens:
--clusters-in-meta-seek
You need to highlight a track to get to the Extra Options.

Also, I think I found a reliable way to check for the problem. If you look at the headers (I use mkvinfo GUI) there is a section called 'Seek head.' The problem files only have 3 'Seek entries', called KaxInfo, KaxTracks, and KaxCues. The repaired files get a 4th entry called 'KaxSeekHead'.
<<

XtraCrispi

Serviio newbie

Posts: 3

Joined: Mon Dec 12, 2011 6:33 am

Post Mon Dec 12, 2011 7:07 am

Re: MKV Fast Forward working!!

Thanks for the quick reply DLN eh. I got the new version and still don't see the option but I don't think I need it now. I remuxed a file and the fast forward is now working. GREAT! Now I have problem with the subtitles. It seems they disappeared. When I load the original file it shows a subtitle track and it's checked when I run it. Do I have to set the subtitle charset from "default" to something else for it to work? What do I set it to?
<<

DLN Eh?

Serviio newbie

Posts: 7

Joined: Mon Dec 12, 2011 12:48 am

Post Mon Dec 12, 2011 7:23 am

Re: MKV Fast Forward working!!

XtraCrispi wrote: I got the new version and still don't see the option but I don't think I need it now. I remuxed a file and the fast forward is now working.


Yeah, as Digitoxin mentioned, the setting is on by default in the older versions, so you only need to turn in on for newer ones.

Sorry, can't help with your Subtitles issue, but I'm sure someone else here can :D
<<

DLN Eh?

Serviio newbie

Posts: 7

Joined: Mon Dec 12, 2011 12:48 am

Post Mon Dec 12, 2011 7:32 am

Re: MKV Fast Forward working!!

Here's a screen shot of the setting in mkvmerge 5.0.1. You might need to scroll down to see the whole thing.
Notice you need to highlight a track (eg Video) to get access to the Extra Options tab.
mkvmergeOption.jpg
mkvmergeOption.jpg (102.29 KiB) Viewed 18977 times
<<

JLMiller

User avatar

Serviio newbie

Posts: 17

Joined: Fri Nov 04, 2011 11:20 pm

Location: Deerfield, NH / Sanford, FL, US

Post Mon Dec 12, 2011 1:54 pm

Re: MKV Fast Forward working!!

A somewhat more straightforward way to specify options to mkvmerge is to select the "Muxing" tab -> "Add command line options" and select the ones you want from the drop-down list. (I'm using v5.1.0).

Per DLN eh?'s post, I took a look at the headers of a couple of .mkv files. They all have the four seek entries he mentioned (after re-muxing), but still won't FF/FR. Exasperating.

- John
<<

DLN Eh?

Serviio newbie

Posts: 7

Joined: Mon Dec 12, 2011 12:48 am

Post Tue Dec 13, 2011 12:57 am

Re: MKV Fast Forward working!!

JLMiller wrote:A somewhat more straightforward way to specify options to mkvmerge is to select the "Muxing" tab -> "Add command line options" and select the ones you want from the drop-down list. (I'm using v5.1.0).


LMAO, has that been there the whole time? Saves me copying and pasting every time, plus this way it can be saved with the settings :)

JLMiller wrote:Per DLN eh?'s post, I took a look at the headers of a couple of .mkv files. They all have the four seek entries he mentioned (after re-muxing), but still won't FF/FR.


What device are you trying to play on and what FW version? Maybe we can find someone with the same one and try the same test.
<<

JLMiller

User avatar

Serviio newbie

Posts: 17

Joined: Fri Nov 04, 2011 11:20 pm

Location: Deerfield, NH / Sanford, FL, US

Post Tue Dec 13, 2011 3:20 pm

Re: MKV Fast Forward working!!

@DLN Eh? - glad to help.

My device is a Samsung BD-C6800 Blu-ray player. The firmware version is BSP-C6800WWB-1012.0, which is presumably the latest release.

- John
<<

XtraCrispi

Serviio newbie

Posts: 3

Joined: Mon Dec 12, 2011 6:33 am

Post Tue Dec 13, 2011 6:45 pm

Re: MKV Fast Forward working!!

Anyone have any ideas of my subtitle issue? I recoded a movie with subtitles. I saw the subtitle track on the list and it was checked. The recoded movie has no subs displayed. What do I have to enable? Do I have to select a charset?
Next

Return to Samsung

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.