FAQ  •  Register  •  Login

Playback terminating unexpectedly

<<

gavsdavs

Serviio newbie

Posts: 16

Joined: Sat Jan 14, 2012 11:15 am

Location: London

Post Thu Jul 27, 2017 7:06 pm

Playback terminating unexpectedly

I have a couple of Sony Devices using serviio very successfully for playout of movies.

A Television: KDL-32EX723 (Sony, 2011 according to Serviio)
A Blu ray player: BDP-Sx70/SMP-N100 (Sony, 2010 according to Serviio)

I have some 300 odd movies, and recently, some of the films I have are only playing partially on the TV. I watch 30-40 minutes and playback stops and I get "Playback not available" on the TV.

It is not all films, only a handful of them.
The affected films always appear to stop playback at the same place.

The bluray player appears unaffected.

This kind of suggests I have a fault with the TV, because the same media will play to completion using serviio using the Blu ray player.

I do not know how to debug/diagnose this. I've left the logging in serviio at the defaults

I get this message:
2017-07-24 23:50:37,699 INFO [PlaybackEventsManager] Playback of media item 274 (xxxxxxxxx( 2017).1080p.x264.mp4]) has stopped at 17% on Identifier=10.99.99.7, Profile=Sony Bravia TV (2011), Name=KDL-32EX723

The TV says it doesn't have any new updates to install.

How would people suggest I try and work out why playback is terminating like this ?
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16495

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Jul 28, 2017 10:03 am

Re: Playback terminating unexpectedly

It could be due to the file encoding. probably something the TV doesn't like. Maybe too high bitrate at that point (busy scene?) or just something that makes the TV think the file is corrupt.
<<

gavsdavs

Serviio newbie

Posts: 16

Joined: Sat Jan 14, 2012 11:15 am

Location: London

Post Fri Jul 28, 2017 5:52 pm

Re: Playback terminating unexpectedly

zip wrote:It could be due to the file encoding. probably something the TV doesn't like. Maybe too high bitrate at that point (busy scene?) or just something that makes the TV think the file is corrupt.

I don't think the exit points are particularly busy scenes.

The machine serviio runs on should have enough horsepower and IO to transcode the file - and it should have got through that by the 35-40 minutes or so which is when it crashes out.

I may end up tcpdumping it to a file or stracing the process.

What fun.

Thanks for your thoughts - let me know if you have any other ideas....

Return to Sony

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.