FAQ  •  Register  •  Login

LG BP-620 Browsing Library fails/hangs with 1.0.1

<<

roedi

Serviio newbie

Posts: 7

Joined: Fri Aug 17, 2012 12:19 pm

Post Fri Aug 17, 2012 12:59 pm

LG BP-620 Browsing Library fails/hangs with 1.0.1

Hi,

I've just upgraded Serviio from 0.6.2 to 1.0.1 and now I cannot access the Media-Library (neither videos nor photo or music) anymore. Serviio shows in the list of available sources and the device shows as active in the Serviio device list. As before I'm using the LG TV/player profile. When selecting Serviio on the player, it remains waiting, displaying the animated spinner. Any help would be appreciated.

Thank you!

The log reads basically:
2012-08-17 14:25:32,531 DEBUG [WebServer] Incoming connection from /192.168.178.35:50260
2012-08-17 14:25:32,531 DEBUG [RendererDAOImpl] Reading a Renderer with ip address 192.168.178.35
2012-08-17 14:25:32,531 DEBUG [ServiceControlRequestHandler] ServiceControl request received for action '"urn:schemas-upnp-org:service:ContentDirectory:1#Browse"' from 192.168.178.35:
2012-08-17 14:25:32,531 DEBUG [RendererDAOImpl] Reading a Renderer with ip address 192.168.178.35
2012-08-17 14:25:32,562 DEBUG [ContentDirectory] Browse() called for renderer LG PLAYER (profile 8) with parameters: objectID = 0, browseFlag = BrowseDirectChildren, filter = res@size, startIndex = 0, count = 0, sortCriteria =
2012-08-17 14:25:32,562 DEBUG [AccessGroupDAOImpl] Reading a AccessGroup (id = 1)
2012-08-17 14:25:32,593 DEBUG [ServiceControlRequestHandler] Returning OK SOAP message
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16879

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Aug 17, 2012 2:04 pm

Re: LG BP-620 Browsing Library fails/hangs with 1.0.1

did you change the presentation settings somehow (on Presentation tab)?
<<

roedi

Serviio newbie

Posts: 7

Joined: Fri Aug 17, 2012 12:19 pm

Post Fri Aug 17, 2012 2:14 pm

Re: LG BP-620 Browsing Library fails/hangs with 1.0.1

zip wrote:did you change the presentation settings somehow (on Presentation tab)?


Yes, actually two times: Once, back when I was using 0.6.3 and after the upgrade as an attempt to get things working. With the previous version I had a few things disabled.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16879

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Aug 18, 2012 10:43 am

Re: LG BP-620 Browsing Library fails/hangs with 1.0.1

Does it work if you leave everything enabled?
<<

roedi

Serviio newbie

Posts: 7

Joined: Fri Aug 17, 2012 12:19 pm

Post Mon Aug 20, 2012 5:41 pm

Re: LG BP-620 Browsing Library fails/hangs with 1.0.1

zip wrote:Does it work if you leave everything enabled?


Sadly, no - not even with a clean installation and just my videos added (no photos, no music and no online resources)
<<

marteh

Serviio newbie

Posts: 1

Joined: Sun Sep 02, 2012 7:06 pm

Post Sun Sep 02, 2012 10:14 pm

Re: LG BP-620 Browsing Library fails/hangs with 1.0.1

Same situation here with an LG blu ray home theatre - was working fine until upgrading. Now the browser just hangs indefinitely. Once I was able to get it to work by disabling all the metadata stuff, but it seems now to have been a fluke.
<<

roedi

Serviio newbie

Posts: 7

Joined: Fri Aug 17, 2012 12:19 pm

Post Fri Sep 07, 2012 5:28 pm

Re: LG BP-620 Browsing Library fails/hangs with 1.0.1

I've been trying different settings, fresh installations, smaller libraries and the lg settings from the other thread without any luck and I think I'll give up with serviio 1.0.1. Hopefully this regression will be fixed soon, I like serviio a lot and I dont want to keep stuck on 0.6.2 or go into checking out other dlna servers again.

:(
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16879

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Sep 11, 2012 12:06 pm

Re: LG BP-620 Browsing Library fails/hangs with 1.0.1

roedi wrote:
zip wrote:Does it work if you leave everything enabled?


Sadly, no - not even with a clean installation and just my videos added (no photos, no music and no online resources)

Any chance of detailed log of browsing using the fresh installation, with no file added (in case it breaks as well, otherwise with a few videos). I'd need a bit longer log that what you posted above.
<<

roedi

Serviio newbie

Posts: 7

Joined: Fri Aug 17, 2012 12:19 pm

Post Tue Sep 11, 2012 6:43 pm

Re: LG BP-620 Browsing Library fails/hangs with 1.0.1

zip wrote:Any chance of detailed log of browsing using the fresh installation, with no file added (in case it breaks as well, otherwise with a few videos). I'd need a bit longer log that what you posted above.


Thanks for your reply. I'll provide a log asap (which probably means next weekend, sorry).
<<

roedi

Serviio newbie

Posts: 7

Joined: Fri Aug 17, 2012 12:19 pm

Post Sun Sep 16, 2012 8:30 pm

Re: LG BP-620 Browsing Library fails/hangs with 1.0.1

Sorry for the late reply. I re-installed Serviio today and tried to reproduce the problem but I wasn't able to. As suggested, I started with a fresh installation and just one folder with just one video-file, which worked this time. Afterwards I increased the number of files without any problem. I'm not sure, what caused the bug to disappear, maybe the order in which I added the files or (more likely I think) a new firmware that might have been installed on my player ota. Anyway I'm happy that serviio now works well with my player and most of my files using the generic profile.

best regards
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16879

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Sep 17, 2012 6:35 pm

Re: LG BP-620 Browsing Library fails/hangs with 1.0.1

Looking again at your log, there is this line:

  Code:
 Browse() called for renderer LG PLAYER (profile 8) with parameters: objectID = 0, browseFlag = BrowseDirectChildren, filter = res@size, startIndex = 0, count = 0, sortCriteria =


which is asking for a list of items, but specifies it needs only 0 of them (count = 0). That looks like a bug in the player's firmware. If you ever get the same issue, check if this line is included in the log.
<<

roedi

Serviio newbie

Posts: 7

Joined: Fri Aug 17, 2012 12:19 pm

Post Wed Sep 26, 2012 3:45 pm

Re: LG BP-620 Browsing Library fails/hangs with 1.0.1

zip wrote:...That looks like a bug in the player's firmware. If you ever get the same issue, check if this line is included in the log.


I'll keep that in mind, thank you.
<<

strug

Serviio newbie

Posts: 4

Joined: Fri Jun 08, 2012 6:28 am

Post Tue Oct 22, 2013 10:07 am

Re: LG BP-620 Browsing Library fails/hangs with 1.0.1

Hi,

I have just had the exact same thing happen to me after months of carefree operation on version 1.3.1.
I haven't changed any settings on the server or updated my firmware and last night I could not browse folders as described above.
I tried everything and eventually this morning I generated a debug log to post here.
I looked through the log and noticed that the time on my server system clock was wrong even though it is supposed to synchronise with internet time.
I reset the server clock. restarted Serviio and now everything works as normal again.

Maybe this can help someone else with a similar problem.

Return to LG

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.