FAQ  •  Register  •  Login

47LM6400 and wtv files

<<

rjb

Serviio newbie

Posts: 6

Joined: Mon Apr 01, 2013 9:24 pm

Post Mon Apr 01, 2013 9:50 pm

47LM6400 and wtv files

Hi folks,

Before I dig deeper into profiles and transcoding, I was hoping somebody experienced with LG could tell me if I am just going to be beating my head against a wall...

I have Win7 and Win8 boxes recording TV programs. The Win7 and Win8 built-in DLNA servers show up on the LG 47LM6400 just fine, but when I go to play a TV recording, I get only about 5 seconds of video and sound and then the video freezes and the sound continues by itself. (other mkv, avi, etc. files from other sources come across and play just fine on the TV from the built-in Win7/Win8 dlna service.)

Windows 7/8 built-in "Play-to" function basically does the same thing when I try to send WTV files to the LG TV DMR: I get a few seconds of all looking good and then the video freezes and the sound continues on with the frozen video picture.

I've been trying other DLNA servers (Plex, Nero MediaHome, etc.) but they don't appear to even present the files in a usable format. The TV just says "This video file is invalid" or the TV doesn't even let me select the file.

I've been reading everything I can find on Google and that has led me here where I've seen some discussions about transcoding issues for LG. I've tried setting up Serviio and selecting the "LG TV/Player" profile for my TV. Serviio shows up right away on the TV, but I still get the "invalid file" message when I try to play one of these WTV videos.

What I want: To be able to play the WTV files from my Win7/Win8 PC on my LG 47LM6400 via the network without having to manually transcode them into another format each time they are recorded.
What I am asking here: Is this a lost cause and should I just buy some other add-on streaming device to plug into the LG TV in order to view these WTV files? (I'm almost to the point of buying an xbox 360 to plug into the LGTV just so I can use the extender functionality.)

I was really hopeful when I saw the native Win7/Win8 DLNA servers show up on the TV input screen and actually "start" playing the video files... that is for those few seconds before the video froze and only the sound continued. These are not copy-restricted or cablecard encrypted files. These are just plain broadcast recordings which play just fine over PLEX to my Roku box in another room.

Anyway, thanks very much in advance for any advice/guidance you might be willing to provide.
Best regards,
rjb
<<

slyguy42o

DLNA master

Posts: 480

Joined: Wed Oct 24, 2012 5:29 am

Post Mon Apr 01, 2013 10:07 pm

Re: 47LM6400 and wtv files

can you post a detailed serviio log please?
<<

rjb

Serviio newbie

Posts: 6

Joined: Mon Apr 01, 2013 9:24 pm

Post Mon Apr 01, 2013 10:24 pm

Re: 47LM6400 and wtv files

absolutely... appreciate the help. I'm new to this so I'll go figure out what I need to do from the support page and then get a log posted.

In the mean time, I just tried switching to the "Sony Bravia TV (2012) - US" profile based on another post I saw somewhere in this forum and I did get improved results. The videos wtv files start playing now and they do not freeze like when using the windows dlna server. They are a bit jittery (something like a bad network connection.... though other files play just fine) and if I try to fast forward or skip ahead, the TV seems to give up and go back to "this file is invalid."

Just wanted to pass that on in case it offers any clues.

I'll go work on getting a log file now.

thanks very much,
rjb
<<

rjb

Serviio newbie

Posts: 6

Joined: Mon Apr 01, 2013 9:24 pm

Post Mon Apr 01, 2013 10:30 pm

Detailed now - Re: 47LM6400 and wtv files

okay... I found the debug instructions on the wiki. I've replaced the attachment with the detailed log file.

first you'll see the files completely fail to play when using the LG profile. then you'll see some better results with the Bravia profile. With the Bravia, the files play, but if I try to fast forward or advance the position in the file at all, the TV hangs up and dumps out to "invalid file" again.

-- original post ---
Is this the log file you requested? (attached)
C:\Program Files\Serviio\log\serviio.log


thanks
Attachments
serviio.zip
(191.19 KiB) Downloaded 143 times
derby.log
(1.12 KiB) Downloaded 164 times
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16802

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Apr 02, 2013 8:52 pm

Re: 47LM6400 and wtv files

try to use this LG profile

  Code:
<Profile id="8" name="LG TV / player" extendsProfileId="1">
      <Detection>
         <HttpHeaders>
            <friendlyName.dlna.org>LG.*</friendlyName.dlna.org>
         </HttpHeaders>
      </Detection>
      <!-- ResourceTransportProtocolHandler>org.serviio.upnp.protocol.http.transport.LGProtocolHandler</ResourceTransportProtocolHandler -->
      <MediaFormatProfiles>
         <MediaFormatProfile mime-type="video/mp4" name="">AVI</MediaFormatProfile>
      </MediaFormatProfiles>      
      
      <Transcoding>
         <Video targetContainer="mpegts" targetACodec="ac3">
            <Matches container="matroska" aCodec="dca" />
         </Video>
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" >
            <Matches container="flv" />
               <Matches container="asf" vCodec="wmv2"/>
               <Matches container="rm" />
               <Matches container="wtv" />
         </Video>
      </Transcoding>
      <Subtitles>
         <SoftSubs mime-type="text/srt" />         
      </Subtitles>   
   </Profile>
<<

rjb

Serviio newbie

Posts: 6

Joined: Mon Apr 01, 2013 9:24 pm

Post Tue Apr 16, 2013 8:50 pm

Re: 47LM6400 and wtv files

Sorry for the delay in responding. I did try out that new profile and I get similar results to using the Sony Bravia profile; the wtv file does play and seems to work fine if I just let it run from start to finish, but if I try any shuttle controls (ff, rw, etc.) the video stops and the screen bounces to an error saying something like "invalid video file"

Think there is any possibility of getting it working or is this just an issue with these LG TVs?

LG also just put out another software update for this tv (v 05.00.00). Unfortunately, it didn't make any difference with this issue. In fact, I haven't been able to see any differences in the TV at all with the new update.

thanks again for any help,
rjb
<<

rjb

Serviio newbie

Posts: 6

Joined: Mon Apr 01, 2013 9:24 pm

Post Wed Apr 17, 2013 4:48 pm

Re: 47LM6400 and wtv files

don't know if this might help. I have both the 47LM6400 and the 55LM6400. Seeing same results on both. Here is the output from the "Provide Supported Formats" HOWTO. I went to post them to the wiki indicated in the HOWTO, but I'm not sure the wiki is working right...

The supported formats appear to be identical between the two models (as I guess we would expect...)

LG 55LM6400 Software Update v05.00.00
http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_SM
http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_MED
http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_LRG
http-get:*:audio/L16;rate=44100;channels=1:DLNA.ORG_PN=LPCM
http-get:*:audio/L16;rate=44100;channels=2:DLNA.ORG_PN=LPCM
http-get:*:audio/mpeg:DLNA.ORG_PN=MP3
http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL
http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_PS_PAL
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_PS_NTSC
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_NA
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_NA_T
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_SD_NA_ISO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_HD_NA
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_HD_NA_T
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_HD_NA_ISO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_KO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_KO_T
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_SD_KO_ISO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_HD_KO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_HD_KO_T
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_HD_KO_ISO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_EU
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_EU_T
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_SD_EU_ISO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_JP_T
http-get:*:video/mp4:DLNA.ORG_PN=AVC_MP4_BL_CIF15_AAC_520
http-get:*:video/x-ms-wmv:DLNA.ORG_PN=WMVHIGH_FULL
http-get:*:video/x-ms-wmv:DLNA.ORG_PN=WMVHIGH_PRO
http-get:*:video/x-ms-wmv:DLNA.ORG_PN=WMVMED_BASE
http-get:*:video/x-ms-wmv:DLNA.ORG_PN=WMVMED_FULL
http-get:*:video/x-ms-wmv:DLNA.ORG_PN=WMVMED_PRO
http-get:*:audio/mpegurl:*
http-get:*:audio/mp3:*
http-get:*:audio/mpeg:*
http-get:*:audio/mpeg3:*
http-get:*:video/x-ms-wmv:*
http-get:*:video/x-ms-asf:*
http-get:*:video/x-ms-avi:*
http-get:*:video/mpeg:*
http-get:*:video/avi:*
http-get:*:video/mp4:*
http-get:*:video/x-matroska:*

LG 47LM6400 Software Update v04.34.01
http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_SM
http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_MED
http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_LRG
http-get:*:audio/L16;rate=44100;channels=1:DLNA.ORG_PN=LPCM
http-get:*:audio/L16;rate=44100;channels=2:DLNA.ORG_PN=LPCM
http-get:*:audio/mpeg:DLNA.ORG_PN=MP3
http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL
http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_PS_PAL
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_PS_NTSC
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_NA
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_NA_T
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_SD_NA_ISO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_HD_NA
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_HD_NA_T
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_HD_NA_ISO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_KO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_KO_T
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_SD_KO_ISO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_HD_KO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_HD_KO_T
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_HD_KO_ISO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_EU
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_SD_EU_T
http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_TS_SD_EU_ISO
http-get:*:video/vnd.dlna.mpeg-tts:DLNA.ORG_PN=MPEG_TS_JP_T
http-get:*:video/mp4:DLNA.ORG_PN=AVC_MP4_BL_CIF15_AAC_520
http-get:*:video/x-ms-wmv:DLNA.ORG_PN=WMVHIGH_FULL
http-get:*:video/x-ms-wmv:DLNA.ORG_PN=WMVHIGH_PRO
http-get:*:video/x-ms-wmv:DLNA.ORG_PN=WMVMED_BASE
http-get:*:video/x-ms-wmv:DLNA.ORG_PN=WMVMED_FULL
http-get:*:video/x-ms-wmv:DLNA.ORG_PN=WMVMED_PRO
http-get:*:audio/mpegurl:*
http-get:*:audio/mp3:*
http-get:*:audio/mpeg:*
http-get:*:audio/mpeg3:*
http-get:*:video/x-ms-wmv:*
http-get:*:video/x-ms-asf:*
http-get:*:video/x-ms-avi:*
http-get:*:video/mpeg:*
http-get:*:video/avi:*
http-get:*:video/mp4:*
http-get:*:video/x-matroska:*
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16802

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Apr 19, 2013 1:04 pm

Re: 47LM6400 and wtv files

FFWD/REV on the LG's is probably using a method Serviio doesn't support for transcoded files, resulting in Serviio giving the TV an error code. At that point the TV fails to continue with the file. Shame DLNA in LGs sucks ;-/

Return to LG

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.