FAQ  •  Register  •  Login

Panasonic TH-50AS700A won't play avi files

<<

wbroek

Serviio newbie

Posts: 3

Joined: Tue Jul 29, 2014 12:50 am

Location: Upper Lansdowne NSW, Australia

Post Tue Jul 29, 2014 1:36 am

Panasonic TH-50AS700A won't play avi files

I have recently had my Panasonic TV replaced by Panasonic under warranty, the new model is a TH-50AS700A the old TV was a TH-L47ET50A. I am running Serviio 1.4.1.2 pro on QNAP nas. The new TV will not play avi files (file not supported) with any of the Panasonic profiles selected, however it will play them using the generic profile, the old TV had no problems in this regard. Any suggestions? Thanks In advance
<<

DenyAll

DLNA master

Posts: 2169

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Tue Jul 29, 2014 12:27 pm

Re: Panasonic TH-50AS700A won't play avi files

Haven't as yet developed a Panasonic 2014 Profile and a lot more info is needed in order to do so. Perhaps the new model requires a different mime type for AVI's - what file type does the TV report the AVI file to be when it is played using the Generic profile (other Panasonics list these as a DivX file).

You could try:

  • Continue using the Generic Profile for this TV. You haven't stated whether this is causing you issues with other file types - if its working for AVI's and not causing grief with other file types, why not keep using it? If you do take this path let us know what file types do fail when/if you come across them (MediaInfo please for the file) as this will ultimately feed into any Panasonic 2014 profile if one is needed;
    or
  • Edit the Panasonic 2013 Profile and remove the following code:
  Code:
<MediaFormatProfiles>
   <MediaFormatProfile mime-type="video/divx">AVI</MediaFormatProfile>
</MediaFormatProfiles>
    and
  Code:
<!-- AVI files will be transcoded into mpeg-ts, mpeg2 video and ac3 audio. 
This section is NOT inherited by other Panasonic profiles  -->
<Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" aBitrate="384">
   <Matches container="avi" />      <!-- Remove this line for models that natively support AVI's with Xvid video (some ST60's) -->
   <Matches container="avi" vCodec="mpeg4" vFourCC="div3,div4,div5,divx,dm4v,dx50" />
   <Matches container="avi" vCodec="msmpeg4" vFourCC="div3,div4,div5,divx,dm4v,dx50" />
   <Matches container="avi" vCodec="dvvideo" />
</Video>
    This will remove all the "customisation" of the Generic profile related to AVI files. After editing the profile you must restart the Serviio service (or your PC) for the changes to take effect.
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

wbroek

Serviio newbie

Posts: 3

Joined: Tue Jul 29, 2014 12:50 am

Location: Upper Lansdowne NSW, Australia

Post Wed Jul 30, 2014 12:19 am

Re: Panasonic TH-50AS700A won't play avi files

Thank you for your reply, i have been running with the generic profile and had no problems so far, but i just use MKV, MP4 and avi formats. i have copied the "Panasonic 2013" profile into a new profile named "Panasonic 2014" and removed the sections as per your suggestion, then restarted the server and selected the Panasonic 2014 profile it is now working. Panasonic seems to have dropped support for "Dvix", no where in the documentation and help do they mention Dvix where they did for the old TV.
PS. when playing AVI files with generic profile the Panasonic reports the format as "video"
<<

DenyAll

DLNA master

Posts: 2169

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Wed Jul 30, 2014 11:19 am

Re: Panasonic TH-50AS700A won't play avi files

Cool - if you want to :D you could continue to use the Generic Profile and feedback to the forum any files that don't work. This will help with the development of a 2014 profile. I suspect it will only be a few cases that still need transcoding (high level h264 profiles and a few of the less common format combinations).
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

wbroek

Serviio newbie

Posts: 3

Joined: Tue Jul 29, 2014 12:50 am

Location: Upper Lansdowne NSW, Australia

Post Wed Jul 30, 2014 8:22 pm

Re: Panasonic TH-50AS700A won't play avi files

I don't know if I'm going to continue with this TV . What a piece of crap, 2 years later and they have made the dlna worse not better. I am noticing compression artefacts ie when a person walks across a scene at a certain speed you get a ghosting affect around the person. The old TV had no problems playing the same video. A $100 wd live box does a better job. Time to go to a samsung I think.

Ps there are other problems but not related to dlna.

Bill

Return to Panasonic

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.