FAQ  •  Register  •  Login

Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV OK!)

<<

SmugWimp

User avatar

Serviio newbie

Posts: 3

Joined: Sun Sep 04, 2011 4:59 pm

Post Sun Sep 04, 2011 5:39 pm

Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV OK!)

This 'should' work with the X3 series. It certainly works great with mine. MP4 and MKV played fine, but I had issues with AVI, WMV, and FLV files. Through a few different posts I combined a few great suggestions into a workable profile.

I am using an old windows box, so this goes for the windows version. The profile should be the same. Your access and edit tools will vary from platform to platform.

1) Stop Server Service
2) Open your profile.xml (I use notepad++, but whatever text editor should work)
3) Paste the following at the end of the file (provided your basic file ends with a device numbered 13. Otherwise, renumber it to be consistent with your device list.

  Code:
   <Profile id="14" name="Panasonic Viera Plasma TCP50X3" extendsProfileId="1">
      <Detection>
         <HttpHeaders>
            <User-Agent>Panasonic MIL DLNA CP UPnP/1.*</User-Agent>
         </HttpHeaders>
      </Detection>
      <ContentDirectoryMessageBuilder>org.serviio.upnp.service.contentdirectory.PanasonicDLNAMessageBuilder</ContentDirectoryMessageBuilder>
        <SubtitlesMimeType>text/srt</SubtitlesMimeType>
        <Transcoding>
            <!-- remux DTS in MKV to AC3 -->
            <Video targetContainer="mpegts" targetACodec="ac3">
                <Matches container="matroska" vCodec="h264" aCodec="dca" />
            </Video>
            <!-- Remux all h264 video to MPEG-TS stream -->
            <Video targetContainer="mpegts">
                <Matches container="avi" vCodec="h264" />
                <Matches container="mp4" vCodec="h264" />
                <Matches container="matroska" vCodec="h264" />
            </Video>
            <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3">
                <Matches container="avi" vCodec="mpeg4" aCodec="lpcm" />
                <Matches container="flv" />
            </Video>                  
            <!-- Transcode all other formats not supported -->
            <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3">
                <Matches container="asf" />
            <Matches container="avi" />
            </Video>             

            <Audio targetContainer="mp3">
                <Matches container="mp4" />
                <Matches container="flac" />
            <Matches container="ogg" />
            </Audio>
        </Transcoding>
   </Profile>

4) Save
5) Restart Server and test


Genuinely hopes this speeds up a few folks' use of the product, which I'm really digging right now!

Cheers!
<<

Cerberus

User avatar

DLNA master

Posts: 4123

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Tue Sep 06, 2011 6:36 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

doesnt the standard viera profile work ???
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

SmugWimp

User avatar

Serviio newbie

Posts: 3

Joined: Sun Sep 04, 2011 4:59 pm

Post Wed Sep 07, 2011 8:17 am

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

Cerberus wrote:doesnt the standard viera profile work ???


Unfortunately not. I tried both the 'panasonic viera' and 'generic' and neither worked for avi files, which is all I was trying in my 'test' config. Once I got an AVI file to work, I just kind of cut and pasted other file types that I use from various configs until I got all of them working.

I think the determining factor was the 'User Agent' string (found by gleaning info from the error log) because once the server 'recognized' my TV, it was all downhill from there.
<<

superfanatico

Serviio newbie

Posts: 1

Joined: Sat Sep 24, 2011 4:45 am

Post Sat Sep 24, 2011 4:47 am

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

I have the same tv and am having the same problem. I tried your code but everytime I save it the server wont start. I had kept a copy of the old profiles and when I put that back its fine but of course I have no .avi ablity. Any suggestions?
<<

Cerberus

User avatar

DLNA master

Posts: 4123

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Sat Sep 24, 2011 2:20 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

superfanatico wrote:I have the same tv and am having the same problem. I tried your code but everytime I save it the server wont start. I had kept a copy of the old profiles and when I put that back its fine but of course I have no .avi ablity. Any suggestions?


1. change profile id to 99 and save that section at bottom of the profile.xml file.

2. restart serviio completely or restart pc running serviio

3. select the new profile for your device in console

4. all done.
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

SmugWimp

User avatar

Serviio newbie

Posts: 3

Joined: Sun Sep 04, 2011 4:59 pm

Post Sat Oct 01, 2011 2:36 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

If your profiles.xml file is not syntax correct, the service will hang. Check the file to make sure no extra characters were added/subtracted.

That said, I also noticed that with the new upgrade to Serviio version 0.6.0.x I needed to change this line in my profiles.xml file:

<ContentDirectoryMessageBuilder>org.serviio.upnp.service.contentdirectory.PanasonicDLNAMessageBuilder</ContentDirectoryMessageBuilder>

to this line (obtained from the profile for the standard Panasonic Viera):

<ContentDirectoryMessageBuilder>org.serviio.upnp.service.contentdirectory.PacketVideoDLNAMessageBuilder</ContentDirectoryMessageBuilder>

Notice the difference where it says "PacketVideo" rather than "Panasonic". It's important.

Before I made this change, the server would hang, and not start.

After the new edit and a restart you should be working fine again.

Hope this helps!
<<

fredman1365

Serviio newbie

Posts: 1

Joined: Wed Aug 17, 2011 5:38 am

Post Mon Oct 10, 2011 12:00 am

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

OMG Thank you! This totally fixed my problem for like half a year. Now just need to get some MKV to work. They are xvid with MKV. For some reason just won't play.
<<

dhoran73

Serviio newbie

Posts: 8

Joined: Wed Oct 12, 2011 11:33 pm

Post Wed Oct 12, 2011 11:40 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

I have a Panasonic Viera tcp60s30 that won't work right with the transcoders I've found. Both Serviio and Mezzmo each have a Viera profile, but neither works with my TV. To get Mezzmo to work I have to choose the profile "Veira (no Divx)". Serviio looks like it will work better for me, but the Viera profile won't work (though some others seem to work). I was hoping that the code at the begining of this thread would work for me, but every time I edit the profiles xml file Serviio won't start anymore. I was very careful (using Notepad) to make sure the addtional Veira profile was formatted the same as the previous entries...but time and time again Serviio won't even start until I replace the edited profile xml file with the original. Any hints?

My edited xml files (saved at a txt) is attached.

Anyone else have problems getting this, apparently new, Viera product to work?

thanks for any help,
--Daniel
<<

dhoran73

Serviio newbie

Posts: 8

Joined: Wed Oct 12, 2011 11:33 pm

Post Wed Oct 12, 2011 11:44 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

Well...I tried to upload the txt file...it doesn't look like it's working though...
<<

Cerberus

User avatar

DLNA master

Posts: 4123

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Thu Oct 13, 2011 6:51 am

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

dhoran73 wrote:Well...I tried to upload the txt file...it doesn't look like it's working though...


just attach your edited XML file as it is and i will take a look at it, if you havent done this by tonight i will edit the one i have at home for you and attach it here for you to use :)
Last edited by Cerberus on Thu Oct 13, 2011 11:40 am, edited 1 time in total.
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

dhoran73

Serviio newbie

Posts: 8

Joined: Wed Oct 12, 2011 11:33 pm

Post Thu Oct 13, 2011 11:38 am

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

The upload attachment option doesn't seem to be working. When I browse to the file (either in my programs or on my desktop) it puts the path in the text box, but then pushing "add the file" doesn't do anything...it just erases the path...tried as both a txt file and an xml.
<<

Illico

User avatar

DLNA master

Posts: 4398

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Thu Oct 13, 2011 12:20 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

make a zip archive.
Illico
Sony 2010 KDL-46EX501 | BDP-S373 | SMP-N100 | Windows 8-i7 | Network DD HD-CE1.5TLU2 | Livebox2-UHD86 | ServiiDroid | ServiiGo | BubbleUPnP
Serviio beta tester - Moderator
<<

dhoran73

Serviio newbie

Posts: 8

Joined: Wed Oct 12, 2011 11:33 pm

Post Thu Oct 13, 2011 1:31 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

Made it into a zip file, same result...
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 14115

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Oct 13, 2011 1:36 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

try a different browser if you have the chance
<<

dhoran73

Serviio newbie

Posts: 8

Joined: Wed Oct 12, 2011 11:33 pm

Post Thu Oct 13, 2011 2:50 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

Used Chrome this time...looks like it worked. I was using IE9 before. Ok...so here's my edited xml file.

thanks!
--Daniel
Attachments
profiles.zip
edited xml file
(6.92 KiB) Downloaded 154 times
<<

dhoran73

Serviio newbie

Posts: 8

Joined: Wed Oct 12, 2011 11:33 pm

Post Thu Oct 13, 2011 10:47 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

I found a modified Viera profile in one of the other Pansonic threads that works. I'm not sure why the other one wouldn't work, but it hardley matters now. Thanks all for the help and the offered help.

What I do notice though it that avi files that play fine on the PS3 play at a smaller resolution using the TV & Serviio, and changing the format to one that fills the entire screen results in a blurred image, whereas the PS3 gives much sharper full-screen image. I'm guessing it's just a result of the transcoding as I noticed the same thing when trying out Mezzmo. I'm tempted to convert my entire avi collection to m2ts just to get the quality, but it takes so long...and will likely also result in larger file sizes.

I know, the other option is just keep using the PS3, but I got this fancy new TV and I'd like to give the PS3 a rest...it gets so hot!

--Daniel
<<

cil1rjn

Serviio newbie

Posts: 4

Joined: Sun Oct 30, 2011 9:01 pm

Post Mon Oct 31, 2011 3:00 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

New to forum but found my way with same prob as original poster, very frustrating. Have attached my edited profiles.xml
file. Greatly appreciated if the forum experts could point me in the right direction.
Attachments
profiles.zip
Edited *not working* file
(6.42 KiB) Downloaded 94 times
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 14115

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Oct 31, 2011 5:00 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

cil1rjn wrote:New to forum but found my way with same prob as original poster, very frustrating. Have attached my edited profiles.xml
file. Greatly appreciated if the forum experts could point me in the right direction.

What are the problems?
<<

cil1rjn

Serviio newbie

Posts: 4

Joined: Sun Oct 30, 2011 9:01 pm

Post Tue Nov 01, 2011 12:34 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

Windows XPsp3 using serviio v0.6.0.1 throws error message when starting its service after PC reboot
with edited profiles.xml (something to the effect of "service not running, will exit now"). After replacing edited profiles.xml with original, serviio starts normally. Problem is my Pana Viera TC-P46X3 cannot read avi's in my media library that
serviio has found which is same prob original poster had with Pana TC-50X3. Tried all the profiles.xml thread fixes in this thread but still no luck getting serviio to run with edited profiles.xml file (used Notepad++ as the editor).
<<

dhoran73

Serviio newbie

Posts: 8

Joined: Wed Oct 12, 2011 11:33 pm

Post Tue Nov 01, 2011 1:50 pm

Re: Panasonic Viera TC-P50X3 Config Profile (AVI, FLV, WMV O

I've had the same problem with Vista SP3...anytime the server is stopped ("exit servio") the only way to start it again is to reboot the machine. Otherwise I get the same message about how there server is not running, closing now.
Next

Return to Panasonic

Who is online

Users browsing this forum: Google [Bot] and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.