FAQ  •  Register  •  Login

Unable to use Serviio 1.8.32 with JRE 8.101

<<

DEJ710

User avatar

DLNA master

Posts: 162

Joined: Mon Jan 31, 2011 4:02 am

Location: Melbourne, Australia

Post Fri Mar 24, 2017 11:36 pm

Unable to use Serviio 1.8.32 with JRE 8.101

Hi zip,

What would cause Serviio not to run after installing JRE 8.101?

engine_error.log shows problems with shared libraries libdl.so wrong class ELF expecting ELFCLASS32.

How do I fix this please?
Thanks.

Sony KD-75X8500D 4K TV Samsung PS51E550 LCD Samsung UBD-K8500 4K Blu Ray Sony BDP-S5100 R.769 Sony BDP-S370 R.794 Onkyo TX-NR809 Windows 7 SP1 x64 ASUS RT-AC66U Dual Band Router - Merlin FW 380.64 NETGEAR WN3500RP Dual Band Wireless Extender QNAP TS-451 x86 4 Bay NAS 18 TB
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16286

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Mar 27, 2017 7:07 pm

Re: Unable to use Serviio 1.8.32 with JRE 8.101

it looks like a problem with the JRE - some 32 vs 64 bit compilation.
<<

DEJ710

User avatar

DLNA master

Posts: 162

Joined: Mon Jan 31, 2011 4:02 am

Location: Melbourne, Australia

Post Tue Mar 28, 2017 10:40 am

Re: Unable to use Serviio 1.8.32 with JRE 8.101

zip wrote:it looks like a problem with the JRE - some 32 vs 64 bit compilation.


Hi zip,

Here is the full error message.

/share/CACHEDEV1_DATA/.qpkg/JRE/jre/bin/java: error while loading shared libraries: libdl.so.2: wrong ELF class: ELFCLASS32
Thanks.

Sony KD-75X8500D 4K TV Samsung PS51E550 LCD Samsung UBD-K8500 4K Blu Ray Sony BDP-S5100 R.769 Sony BDP-S370 R.794 Onkyo TX-NR809 Windows 7 SP1 x64 ASUS RT-AC66U Dual Band Router - Merlin FW 380.64 NETGEAR WN3500RP Dual Band Wireless Extender QNAP TS-451 x86 4 Bay NAS 18 TB
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16286

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Mar 28, 2017 2:41 pm

Re: Unable to use Serviio 1.8.32 with JRE 8.101

yes... so that is somethiing wrong with the JRE package.... maybe try to remove Java and add it again?
<<

DEJ710

User avatar

DLNA master

Posts: 162

Joined: Mon Jan 31, 2011 4:02 am

Location: Melbourne, Australia

Post Wed Mar 29, 2017 7:46 am

Re: Unable to use Serviio 1.8.32 with JRE 8.101

I have already tried that several times.

Are you able to test this at all?
Also, will the next version of Serviio include a bundled JRE like you did for the windows version?
Thanks.

Sony KD-75X8500D 4K TV Samsung PS51E550 LCD Samsung UBD-K8500 4K Blu Ray Sony BDP-S5100 R.769 Sony BDP-S370 R.794 Onkyo TX-NR809 Windows 7 SP1 x64 ASUS RT-AC66U Dual Band Router - Merlin FW 380.64 NETGEAR WN3500RP Dual Band Wireless Extender QNAP TS-451 x86 4 Bay NAS 18 TB
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16286

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Mar 29, 2017 6:58 pm

Re: Unable to use Serviio 1.8.32 with JRE 8.101

No, it won't include bundled JRE on QNAP. I don't have 4.3 yet, so can't test.
<<

DEJ710

User avatar

DLNA master

Posts: 162

Joined: Mon Jan 31, 2011 4:02 am

Location: Melbourne, Australia

Post Thu Mar 30, 2017 7:46 am

Re: Unable to use Serviio 1.8.32 with JRE 8.101

I don't have 4.3 either - only 4.2.4.

If I upgrade to 4.3 will this fix the problem then?
Thanks.

Sony KD-75X8500D 4K TV Samsung PS51E550 LCD Samsung UBD-K8500 4K Blu Ray Sony BDP-S5100 R.769 Sony BDP-S370 R.794 Onkyo TX-NR809 Windows 7 SP1 x64 ASUS RT-AC66U Dual Band Router - Merlin FW 380.64 NETGEAR WN3500RP Dual Band Wireless Extender QNAP TS-451 x86 4 Bay NAS 18 TB
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16286

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Mar 30, 2017 8:05 am

Re: Unable to use Serviio 1.8.32 with JRE 8.101

No idea, maybe, as 4.3 is 64 bit AFAIK.

I assume that just executing java in SSH on the NAS gives you this error.
<<

RMcV

Serviio newbie

Posts: 13

Joined: Mon Feb 08, 2016 12:26 pm

Post Wed Apr 19, 2017 1:01 pm

Re: Unable to use Serviio 1.8.32 with JRE 8.101

@DEJ710

Yes, upgrade to OS 4.3.., install JRE 8.101, uninstall 32-bit Serviio, install 64-bit Serviio and you will be good to go.

I think your problem is that JRE 8.101 is 64-bit and your old Serviio is 32-bit. Do the steps I mention above and your problems should be gone.
<<

DEJ710

User avatar

DLNA master

Posts: 162

Joined: Mon Jan 31, 2011 4:02 am

Location: Melbourne, Australia

Post Sun Apr 23, 2017 12:29 am

Re: Unable to use Serviio 1.8.32 with JRE 8.101

@RMcV

Thanks for your response.

I updated to qts 4.3.3, JRE 8.101 and Serviio 1.8.64 last night and here's what I did:
1. Update to qts 4.3.3
2. Update JRE to 8.101
3. Upgrade Serviio to 1.8.64 (Install over the top) using download from serviio download link

Serviio is still functioning and my library is still in tact
Thanks.

Sony KD-75X8500D 4K TV Samsung PS51E550 LCD Samsung UBD-K8500 4K Blu Ray Sony BDP-S5100 R.769 Sony BDP-S370 R.794 Onkyo TX-NR809 Windows 7 SP1 x64 ASUS RT-AC66U Dual Band Router - Merlin FW 380.64 NETGEAR WN3500RP Dual Band Wireless Extender QNAP TS-451 x86 4 Bay NAS 18 TB

Return to NAS installation

Who is online

Users browsing this forum: No registered users and 4 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.