FAQ  •  Register  •  Login

Serviio recently removed from Qnap App Center

<<

namefam

Serviio newbie

Posts: 2

Joined: Thu Apr 17, 2014 6:30 pm

Post Sat Apr 08, 2017 5:28 am

Serviio recently removed from Qnap App Center

When I first got my Qnap TS-453A (v4.2.4) about 2 months ago I was happy to find that Serviio was available in the App center and quickly installed it. But now for some reason it is no longer available, and according to Qnap support "the developer removed it".....

Can anyone shed some light on why this is, and if/when Serviio might make a return to the App Center?

The reason I'm so interested is recently I upgraded my NAS drives, and during the process I decided to rebuild the config, which means all my apps were removed. I'd really like to get Serviio reinstalled, and have tried using some 3rd party repositories to get the qpkgs, but can't haven't been able to get it running in the few attempts I've made.

When I first installed it from the App Center it was a piece of cake, so it would really be nice if it were available again.


Thanks!
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16499

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Apr 08, 2017 10:27 am

Re: Serviio recently removed from Qnap App Center

That's correct. It's due to some codec licensing issues QNAP are dealing with. If / when they resolve the situation Serviio will return to the store.

I might just offer the downloads on serviio.org in the meantime.
<<

namefam

Serviio newbie

Posts: 2

Joined: Thu Apr 17, 2014 6:30 pm

Post Sat Apr 08, 2017 7:25 pm

Re: Serviio recently removed from Qnap App Center

If you could/would offer the downloads it would be much appreciated!
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16499

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Apr 09, 2017 10:23 am

Re: Serviio recently removed from Qnap App Center

It's on serviio.org/download now
<<

shonkster

Serviio newbie

Posts: 2

Joined: Tue Apr 11, 2017 4:46 am

Post Tue Apr 11, 2017 5:01 am

Re: Serviio recently removed from Qnap App Center

Is there anyway i can get an earlier serviio qnap qpkg that will install on qts4.2. My older nas (ts459) does not support qts4.3 so I can't install Serviio 1.8.

Cheers
<<

DEJ710

User avatar

DLNA master

Posts: 168

Joined: Mon Jan 31, 2011 4:02 am

Location: Melbourne, Australia

Post Tue Apr 11, 2017 10:29 am

Re: Serviio recently removed from Qnap App Center

Hi there,
I currently have Serviio 1.8 installed on my nas which is running qts v4.2 so it should also run on yours too.

Try installing qts v4.2.4 if you haven't already.
Thanks.

Sony KD-75X8500D 4K TV Samsung PS51E550 LCD Samsung UBD-K8500 4K Blu Ray Sony BDP-S5100 R.769 Sony BDP-S370 R.794 Onkyo TX-NR809 Windows 7 SP1 x64 ASUS RT-AC66U Dual Band Router - Merlin FW 380.68 NETGEAR WN3500RP Dual Band Wireless Extender QNAP TS-451 x86 4 Bay NAS 24 TB
<<

shonkster

Serviio newbie

Posts: 2

Joined: Tue Apr 11, 2017 4:46 am

Post Tue Apr 11, 2017 12:17 pm

Re: Serviio recently removed from Qnap App Center

Thanks for the reply. You are correct it does work. Appears i made a rookie mistake, checked my nas (uname -m) and thought it was 64bit.. i tried installing the 32bit version of serviio and it worked. :-) happy times.

Thanks appreciated.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16499

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Apr 11, 2017 12:34 pm

Re: Serviio recently removed from Qnap App Center

yeah, I think 4.3 is 64-bit, anything before is 32-bit
<<

DEJ710

User avatar

DLNA master

Posts: 168

Joined: Mon Jan 31, 2011 4:02 am

Location: Melbourne, Australia

Post Wed Apr 12, 2017 12:44 pm

Re: Serviio recently removed from Qnap App Center

Hi zip,
If I update to qts 4.3 will I also have to install the 64-bit version of Serviio as well?
Thanks.

Sony KD-75X8500D 4K TV Samsung PS51E550 LCD Samsung UBD-K8500 4K Blu Ray Sony BDP-S5100 R.769 Sony BDP-S370 R.794 Onkyo TX-NR809 Windows 7 SP1 x64 ASUS RT-AC66U Dual Band Router - Merlin FW 380.68 NETGEAR WN3500RP Dual Band Wireless Extender QNAP TS-451 x86 4 Bay NAS 24 TB
<<

DEJ710

User avatar

DLNA master

Posts: 168

Joined: Mon Jan 31, 2011 4:02 am

Location: Melbourne, Australia

Post Wed Apr 12, 2017 12:48 pm

Re: Serviio recently removed from Qnap App Center

shonkster wrote:Thanks for the reply. You are correct it does work. Appears i made a rookie mistake, checked my nas (uname -m) and thought it was 64bit.. i tried installing the 32bit version of serviio and it worked. :-) happy times.

Thanks appreciated.


Glad you were able to get it working.
Thanks.

Sony KD-75X8500D 4K TV Samsung PS51E550 LCD Samsung UBD-K8500 4K Blu Ray Sony BDP-S5100 R.769 Sony BDP-S370 R.794 Onkyo TX-NR809 Windows 7 SP1 x64 ASUS RT-AC66U Dual Band Router - Merlin FW 380.68 NETGEAR WN3500RP Dual Band Wireless Extender QNAP TS-451 x86 4 Bay NAS 24 TB
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16499

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Apr 12, 2017 9:23 pm

Re: Serviio recently removed from Qnap App Center

DEJ710 wrote:Hi zip,
If I update to qts 4.3 will I also have to install the 64-bit version of Serviio as well?

Yes, if I understand it well... It's all a bit confusing
<<

DEJ710

User avatar

DLNA master

Posts: 168

Joined: Mon Jan 31, 2011 4:02 am

Location: Melbourne, Australia

Post Thu Apr 13, 2017 10:19 am

Re: Serviio recently removed from Qnap App Center

I'm just a bit hesitant as last time I tried to update to Serviio 64-bit, it failed and trashed my Serviio installation completely ie. It removed it completely from my apps list.

Has anyone else already tried to update to qts 4.3 and installed Serviio 64-bit? Did it work?
Thanks.

Sony KD-75X8500D 4K TV Samsung PS51E550 LCD Samsung UBD-K8500 4K Blu Ray Sony BDP-S5100 R.769 Sony BDP-S370 R.794 Onkyo TX-NR809 Windows 7 SP1 x64 ASUS RT-AC66U Dual Band Router - Merlin FW 380.68 NETGEAR WN3500RP Dual Band Wireless Extender QNAP TS-451 x86 4 Bay NAS 24 TB
<<

RMcV

Serviio newbie

Posts: 14

Joined: Mon Feb 08, 2016 12:26 pm

Post Wed Apr 19, 2017 12:47 pm

Re: Serviio recently removed from Qnap App Center

@ DEJ710

I have updated to qnap os 4.3.. It said the JRE needed to be updated so I did that. I tried to run Serviio that I have installed, but it wouldn't work. I uninstalled the 32-bit Serviio, installed the 64-bit version that is on the Serviio download page, configured it and it works like a charm.

So to answer your question, yes, go ahead and do the os update, then uninstall your 32-bit Serviio and install the 64-bit Serviio.
<<

DEJ710

User avatar

DLNA master

Posts: 168

Joined: Mon Jan 31, 2011 4:02 am

Location: Melbourne, Australia

Post Sun Apr 23, 2017 12:33 am

Re: Serviio recently removed from Qnap App Center

@RMcV

Thanks for your response.

I updated to qts 4.3.3, JRE 8.101 and Serviio 1.8.64 last night and here's what I did:
1. Update to qts 4.3.3
2. Update JRE to 8.101
3. Upgrade Serviio to 1.8.64 (Install over the top) using download from serviio download link

Serviio is still functioning and my library is still in tact
Thanks.

Sony KD-75X8500D 4K TV Samsung PS51E550 LCD Samsung UBD-K8500 4K Blu Ray Sony BDP-S5100 R.769 Sony BDP-S370 R.794 Onkyo TX-NR809 Windows 7 SP1 x64 ASUS RT-AC66U Dual Band Router - Merlin FW 380.68 NETGEAR WN3500RP Dual Band Wireless Extender QNAP TS-451 x86 4 Bay NAS 24 TB
<<

RMcV

Serviio newbie

Posts: 14

Joined: Mon Feb 08, 2016 12:26 pm

Post Mon Apr 24, 2017 11:49 am

Re: Serviio recently removed from Qnap App Center

@DEJ710

I was hesitant about installing the 64-bit version over the 32-bit version. I'm glad that it works and keeps the media catalogue intact, thanks for the tip.
<<

hybrid

Streaming enthusiast

Posts: 28

Joined: Thu Apr 19, 2012 7:27 am

Post Mon May 01, 2017 2:45 pm

Re: Serviio recently removed from Qnap App Center

After many messages send for help on this and to developers i reached out to Qnap for help.

they came back with the below.

"We have temporarily removed the Serviio app from App center due to lack of cooperation from Serviio developers. We are in talks with them, not sure when it will get back.
Many thanks for your understanding."

Can we please have a elaboration on the reason serviio was removed from QNAP?
TVS-871 using Serviio/Mediabrowser (1.5Rev1) on IPad, Iphone, Android Phone , Samsung TV's , OTT MXQ M10 TV Box, PS4 and Xbox.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16499

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue May 02, 2017 8:15 am

Re: Serviio recently removed from Qnap App Center

The issue is they now require Serviio to be licensed with Dolby for the use of ac3 codecs. Removing this from Serviio would make it basically useless. As far as I know, being a European company Serviio is not obliged to pay royalties for the Dolby patents (see VLC for example). But I assume the Qnap store is located globally so they play by different rules.

Anyway, I'm waiting for their deal with Dolby (apparently they are negotiating it now) and then it should be possible to return Serviio back to the store.

I will reach out to them again to see what the status is now.

I assume the "lack of cooperation from Serviio developers" is the fact I cannot remove ac3 from Serviio, nor am I willing to spend absurd amount of money for the royalty fees.
<<

RMcV

Serviio newbie

Posts: 14

Joined: Mon Feb 08, 2016 12:26 pm

Post Wed May 03, 2017 1:31 pm

Re: Serviio recently removed from Qnap App Center

@Zip

I saw a post from a user on the QNAP forum saying that the patent for AC-3 (Dolby Digital) had expired. True or not I don't know.

"on 19.3.2017 last pattent from Dolby US5890106 has expired, so AC-3 is now free and QNAP is able to compile new codex pack with full transcoding support, crossing my fingers for that"

RMcV
<<

Xmantium

User avatar

DLNA master

Posts: 1418

Joined: Sat Jul 23, 2011 2:12 pm

Location: Manchester, UK

Post Wed May 03, 2017 6:28 pm

Re: Serviio recently removed from Qnap App Center

No wonder i couldn't use Serviio after Firmware 4.3.3 update!

I was relying on App Center to auto update Serviio until i saw this post... JRE auto updated to 8.101.1
I installed the 64 bit (from Serviio download page) over existing installed 32 bit and worked fine for me!

Hope Serviio QPKG comes back to App Center again
Sony Bravia 2010 52NX803 - Sony PS3 - Xbox 360
Serviio running on QNAP NAS 639 Pro - 1.6 Intel Dual Core - 2GB RAM and QNAP NAS 121 - 2Ghz ARM Marvell - 1GB RAM
Console using ServiiDroid for Android, ServiiMetro and ServiiWP for Windows Phone and WebUI for iOS
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16499

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed May 03, 2017 8:58 pm

Re: Serviio recently removed from Qnap App Center

RMcV wrote:@Zip

I saw a post from a user on the QNAP forum saying that the patent for AC-3 (Dolby Digital) had expired. True or not I don't know.

"on 19.3.2017 last pattent from Dolby US5890106 has expired, so AC-3 is now free and QNAP is able to compile new codex pack with full transcoding support, crossing my fingers for that"

RMcV

I'm aware of this, and am asking Qnap. I could just remove TrueHD and eac3 support. But it depends what their legal team says, so I'm not keeping my hope high.
Next

Return to NAS installation

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.