FAQ  •  Register  •  Login

HOWTO: Serviio on DNS-320 & DNS-325

<<

nightwish

Serviio newbie

Posts: 2

Joined: Sat Nov 19, 2011 7:20 pm

Post Sun Nov 20, 2011 2:45 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

Hi tihob

Thank you very much for your reply and thank you for all your effort in creating a solution for running serviio on the 320!

The result of 'ps -auxref' is..
USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
root 4142 0.0 0.7 2512 924 ttyp0 R+ 03:30 0:00 ps -auxref TERM=xterm SHELL=/bin/bash SSH_CLIENT=192.168.11.

so I guess that 0.6.0.1 isn't running. I think that before I upgraded from 0.5.2 to 0.6.0.1 I may have stopped the server in 0.5.2. Would this affect things?

Should I consider reinstalling the package from scratch and reinstalling 0.6.0.1 again? I don't have any data in the library anyway.

BTW all my files in tsqueeze & subfolders are read-only and I cannot drop files into any subfolders using windows - only via telnet (putty) for top level and then using SSH (putty) for the tsqueeze folder. Is this normal?

Thanks so much again.
<<

tihob

Streaming enthusiast

Posts: 38

Joined: Tue Feb 08, 2011 8:30 pm

Location: France

Post Sun Nov 20, 2011 2:31 pm

Re: HOWTO: Serviio on DNS-320 & DNS-325

nightwish wrote:Hi tihob

Thank you very much for your reply and thank you for all your effort in creating a solution for running serviio on the 320!

The result of 'ps -auxref' is..
USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
root 4142 0.0 0.7 2512 924 ttyp0 R+ 03:30 0:00 ps -auxref TERM=xterm SHELL=/bin/bash SSH_CLIENT=192.168.11.

so I guess that 0.6.0.1 isn't running. I think that before I upgraded from 0.5.2 to 0.6.0.1 I may have stopped the server in 0.5.2. Would this affect things?

Should I consider reinstalling the package from scratch and reinstalling 0.6.0.1 again? I don't have any data in the library anyway.

BTW all my files in tsqueeze & subfolders are read-only and I cannot drop files into any subfolders using windows - only via telnet (putty) for top level and then using SSH (putty) for the tsqueeze folder. Is this normal?

Thanks so much again.


I don't know why you have this error...
I'm working to make a new package with serviio 0.6.0.1, i'm uploading this afternoon.
When i will post, try to reinstall the package.
Thx
<<

tihob

Streaming enthusiast

Posts: 38

Joined: Tue Feb 08, 2011 8:30 pm

Location: France

Post Sun Nov 20, 2011 8:01 pm

Re: HOWTO: Serviio on DNS-320 & DNS-325

I uploaded the new package with Serviio 0.6.0.1 & webUI For Serviio 0.6.
It's bigger than the precedent package because i add some local file (spanish, french, russian,...)

For the installation please read the "READ ME.txt" file place into the zip file.

If you can't update serviio manually:
Be careful, your serviio's library will be deleted, after reinstalling the package you must rescan all your files.
To install this new package, rename your fun_plug file in fun_plug.serviio, and renamne the backup of fun_plug (if you keep it fun_plug.ffp) to reboot with Fonz fun_plug script.
Then reboot the nas, delete tsqueeze folder (rm -r tsqueeze) and follow the instruction in the READ ME.
<<

page

Serviio newbie

Posts: 2

Joined: Thu Dec 22, 2011 11:35 pm

Post Fri Dec 23, 2011 12:35 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

Hey

i have a dns-320 with debian_squeeze and a samsung d6100. is it possible, the serviio doesnt use index? when i am browsing on the tv, i cant open any folder and it is telling me there is no files. i tried again and i can open now the same directory (and the browsing is getting faster), but i cant open an other one. i choose allshare on the tv again, and now i can open two folder. when i discover all of the folders myself, serviio works perfectly, but i add a new video to a folder, and i cant open that folder again.
is there a way to do the serviio discover or cache or use index automatically? or i missed something?
thanks anyway


  Code:
2011-12-23 00:35:50,722 INFO  [MediaServer] ------------------------------------------------------------------------
2011-12-23 00:35:50,741 INFO  [MediaServer] Serviio DLNA media streaming server v 0.6.0.1 (rev. 8e4ee98bff12)
2011-12-23 00:35:50,741 INFO  [MediaServer] Petr Nejedly 2009-2011
2011-12-23 00:35:50,742 INFO  [MediaServer] http://www.serviio.org
2011-12-23 00:35:50,743 INFO  [MediaServer]
2011-12-23 00:35:50,743 INFO  [MediaServer] Java 1.6.0_18-Sun Microsystems Inc.
2011-12-23 00:35:50,744 INFO  [MediaServer] OS Linux arm 2.6.22.18
2011-12-23 00:35:50,745 INFO  [MediaServer] File encoding: US-ASCII
2011-12-23 00:35:50,750 INFO  [MediaServer] Headless mode enabled: true
2011-12-23 00:35:50,751 INFO  [MediaServer] User home dir: /root
2011-12-23 00:35:50,751 INFO  [MediaServer] Temp dir: /tmp
2011-12-23 00:35:50,752 INFO  [MediaServer] ------------------------------------------------------------------------
2011-12-23 00:35:51,992 INFO  [RestletServer] Starting Restlet server exposed on port 23423
2011-12-23 00:35:52,580 INFO  [DBSchemaUpdateExecutor] Checking if DB schema needs to be updated
2011-12-23 00:36:17,838 INFO  [ProfilesDefinitionParser] Parsing Profiles definition
2011-12-23 00:36:33,792 INFO  [ProfilesDefinitionParser] Added profile 'Generic DLNA profile' (id=1)
2011-12-23 00:36:47,558 INFO  [ProfilesDefinitionParser] Added profile 'Samsung TV (B-series)' (id=2)
2011-12-23 00:36:57,171 INFO  [ProfilesDefinitionParser] Added profile 'XBox 360' (id=3)
2011-12-23 00:37:07,052 INFO  [ProfilesDefinitionParser] Added profile 'Playstation 3' (id=4)
2011-12-23 00:37:15,487 INFO  [ProfilesDefinitionParser] Added profile 'Samsung TV (A-series)' (id=5)
2011-12-23 00:37:24,060 INFO  [ProfilesDefinitionParser] Added profile 'DirecTV HD-DVR' (id=6)
2011-12-23 00:37:45,371 INFO  [ProfilesDefinitionParser] Added profile 'Samsung TV / player (C/D-series)' (id=7)
2011-12-23 00:37:49,007 INFO  [ProfilesDefinitionParser] Added profile 'LG TV / player' (id=8)
2011-12-23 00:38:18,085 INFO  [ProfilesDefinitionParser] Added profile 'Sony Bravia TV' (id=9)
2011-12-23 00:39:11,817 INFO  [ProfilesDefinitionParser] Added profile 'Sony BD Player' (id=10)
2011-12-23 00:39:33,740 INFO  [ProfilesDefinitionParser] Added profile 'Panasonic Viera' (id=12)
2011-12-23 00:39:55,335 INFO  [ProfilesDefinitionParser] Added profile 'Toshiba REGZA' (id=13)
2011-12-23 00:40:01,404 INFO  [ProfilesDefinitionParser] Added profile 'WDTV Live' (id=14)
2011-12-23 00:40:04,743 INFO  [ProfilesDefinitionParser] Added profile 'LaCie LaCinema Media Player' (id=15)
2011-12-23 00:40:15,701 INFO  [ProfilesDefinitionParser] Added profile 'Manta WIFI Centre' (id=16)
2011-12-23 00:40:20,725 INFO  [ProfilesDefinitionParser] Added profile 'Pure Flow' (id=17)
2011-12-23 00:40:32,269 INFO  [ProfilesDefinitionParser] Added profile 'Sharp Aquos' (id=18)
2011-12-23 00:41:12,901 INFO  [ProfilesDefinitionParser] Added profile 'Sony Bravia TV 2011' (id=19)
2011-12-23 00:41:50,634 INFO  [ProfilesDefinitionParser] Added profile 'Sony SMP-N100' (id=20)
2011-12-23 00:41:50,938 INFO  [CompositeCacheManager] Creating cache manager from config file: /cache.ccf
2011-12-23 00:41:51,057 INFO  [ThreadPoolManager] thread_pool.default PoolConfiguration = useBoundary = [true] boundarySize = [2000] maximumPoolSize = [150] minimumPoolSize = [4] keepAliveTime = [300000] whenBlockedPolicy = [RUN] startUpSize = [4]
2011-12-23 00:41:51,091 INFO  [CompositeCacheConfigurator] Setting default auxiliaries to null
2011-12-23 00:41:51,092 INFO  [CompositeCacheConfigurator] No special CompositeCacheAttributes class defined for key [jcs.default.cacheattributes], using default class.
2011-12-23 00:41:51,110 INFO  [CompositeCacheConfigurator] setting defaultCompositeCacheAttributes to [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 100, maxSpoolPerRun = -1, diskUsagePattern = 0 ]
2011-12-23 00:41:51,111 INFO  [CompositeCacheConfigurator] No special ElementAttribute class defined for key [jcs.default.elementattributes], using default class.
2011-12-23 00:41:51,114 INFO  [CompositeCacheConfigurator] setting defaultElementAttributes to [ IS_LATERAL = true, IS_SPOOL = true, IS_REMOTE = true, IS_ETERNAL = true, MaxLifeSeconds = -1, IdleTime = -1, CreateTime = 1324597311112, LastAccessTime = 1324597311112, getTimeToLiveSeconds() = -1, createTime = 1324597311112 ]
2011-12-23 00:41:51,542 INFO  [LRUMemoryCache] initialized LRUMemoryCache for thumbnails
2011-12-23 00:41:51,543 INFO  [CompositeCache] Constructed cache with name [thumbnails] and cache attributes [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 1000, maxSpoolPerRun = -1, diskUsagePattern = 0 ]
2011-12-23 00:41:51,548 INFO  [LRUMemoryCache] initialized LRUMemoryCache for online_feeds
2011-12-23 00:41:51,549 INFO  [CompositeCache] Constructed cache with name [online_feeds] and cache attributes [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 1000, maxSpoolPerRun = -1, diskUsagePattern = 0 ]
2011-12-23 00:41:51,552 INFO  [CompositeCacheConfigurator] No special ElementAttribute class defined for key [jcs.region.local_default.elementattributes], using default class.
2011-12-23 00:41:51,554 INFO  [LRUMemoryCache] initialized LRUMemoryCache for local_default
2011-12-23 00:41:51,555 INFO  [CompositeCache] Constructed cache with name [local_default] and cache attributes [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 1000, maxSpoolPerRun = -1, diskUsagePattern = 0 ]
2011-12-23 00:41:51,558 INFO  [CompositeCacheConfigurator] No special ElementAttribute class defined for key [jcs.region.local_resetafterplay.elementattributes], using default class.
2011-12-23 00:41:51,559 INFO  [LRUMemoryCache] initialized LRUMemoryCache for local_resetafterplay
2011-12-23 00:41:51,560 INFO  [CompositeCache] Constructed cache with name [local_resetafterplay] and cache attributes [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 1000, maxSpoolPerRun = -1, diskUsagePattern = 0 ]
2011-12-23 00:41:51,562 INFO  [CompositeCacheConfigurator] Parsed regions [thumbnails, online_feeds, local_default, local_resetafterplay]
2011-12-23 00:41:51,563 INFO  [CompositeCacheConfigurator] Finished configuration in 486 ms.
2011-12-23 00:41:52,055 INFO  [WebServer] Socket buffer set to 65535 bytes
2011-12-23 00:41:52,061 INFO  [Device] Created UPnP Device with UUID: 223a9375-eb61-3269-abcf-3ad9f2e63b1f, bound address: 192.168.1.6
2011-12-23 00:41:52,388 INFO  [PluginCompilerThread] Looking for plugins at /opt/serviio/serviio-0.5.2/plugins
2011-12-23 00:41:52,394 INFO  [PluginCompilerThread] Started looking for plugins
2011-12-23 00:41:54,258 INFO  [AbstractTranscodingDeliveryEngine] Cleaning transcode engine and its data
2011-12-23 00:41:54,796 INFO  [WebServer] WebServer starting on port 8895
2011-12-23 00:41:54,857 INFO  [EventSubscriptionExpirationChecker] Starting EventSubscriptionExpirationChecker
2011-12-23 00:41:54,870 INFO  [DiscoveryAdvertisementNotifier] Starting DiscoveryAdvertisementNotifier
2011-12-23 00:41:54,858 INFO  [EventDispatcher] Starting EventDispatcher
2011-12-23 00:41:54,927 INFO  [RendererSearchSender] Searching for Renderer devices
2011-12-23 00:41:54,930 INFO  [RendererExpirationChecker] Starting RendererExpirationChecker
2011-12-23 00:41:54,953 INFO  [DiscoverySSDPMessageListener] Starting DiscoverySSDPMessageListener using interface egiga0 (egiga0) and address 192.168.1.6, timeout = 0
2011-12-23 00:42:21,342 INFO  [FeedUpdaterThread] Started looking for information about online feeds
2011-12-23 00:42:21,819 INFO  [LibraryAdditionsCheckerThread] Started looking for newly added files
2011-12-23 00:42:22,052 INFO  [LibraryUpdatesCheckerThread] Started looking for updates to currently shared files
<<

tihob

Streaming enthusiast

Posts: 38

Joined: Tue Feb 08, 2011 8:30 pm

Location: France

Post Fri Dec 23, 2011 10:43 pm

Re: HOWTO: Serviio on DNS-320 & DNS-325

page wrote:Hey

i have a dns-320 with debian_squeeze and a samsung d6100. is it possible, the serviio doesnt use index? when i am browsing on the tv, i cant open any folder and it is telling me there is no files. i tried again and i can open now the same directory (and the browsing is getting faster), but i cant open an other one. i choose allshare on the tv again, and now i can open two folder. when i discover all of the folders myself, serviio works perfectly, but i add a new video to a folder, and i cant open that folder again.
is there a way to do the serviio discover or cache or use index automatically? or i missed something?
thanks anyway



hi,
Do you use WebUI to configure Serviio ?
if yes, you can configure how serviio check your media library.
<<

page

Serviio newbie

Posts: 2

Joined: Thu Dec 22, 2011 11:35 pm

Post Sat Dec 24, 2011 5:02 pm

Re: HOWTO: Serviio on DNS-320 & DNS-325

tihob wrote:hi,
Do you use WebUI to configure Serviio ?
if yes, you can configure how serviio check your media library.


hi
yes, i use the latest webui. how should i configure that?
thanks the advice
<<

tihob

Streaming enthusiast

Posts: 38

Joined: Tue Feb 08, 2011 8:30 pm

Location: France

Post Thu Dec 29, 2011 10:45 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

page wrote:
tihob wrote:hi,
Do you use WebUI to configure Serviio ?
if yes, you can configure how serviio check your media library.


hi
yes, i use the latest webui. how should i configure that?
thanks the advice


do you know how to connect to WEBUI ?
If yes, you have the same option than in "classic serviio".
If no, please read the "how to", and make your question from this.
<<

Lukas718

Streaming enthusiast

Posts: 41

Joined: Sun Aug 28, 2011 7:04 pm

Post Fri Jan 06, 2012 9:46 pm

Re: HOWTO: Serviio on DNS-320 & DNS-325

I fallowed all steps but I got stock on installation part (READ ME FILE) where it says:
# cd /mnt/HD/HD_a2/tsqueeze

I get :
/ # cd /mnt/HD/HD_a2/tsqueeze
/ffp/bin/sh: cd: can't cd to /mnt/HD/HD_a2/tsqueeze

Im using PuTTY to telnet

UPDATE.

I was able to copy and extract tsqueeze to /mnt/HD/HD_a2/tsqueeze - it looks like all files are there.
Next step in readme says
" Now you should have a working Debian Squeeze distribution that can be chrooted during bootup.
To make it work simply copy file "fun_plug.debian" to "fun_plug"."

how to copy that ? open fun_plug.debian in txt editor copy and past txt into fun_plug ? or is there a linux command i should be using for that ?

I tried to skip this step but PuTTY SSH is not connecting.
<<

jsviverette

Serviio newbie

Posts: 11

Joined: Sat Jan 07, 2012 12:41 am

Post Sat Jan 07, 2012 1:14 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

To make it work you dont "copy" it you rename it. what he means by that line is to type
"cp fun_plug.debian fun_plug"
Which will take that file make a copy and rename it.

---- After that i am stuck here too

I did this:
Installed fun_plug-
SShed into box

cp fun_plug fun_plug.ffp
rm fun_plug
mkdir tsqueeze
unzip serviio0.6.0.1_squeeze.zip
mv tsqueeze.tar.gz /tsqueeze
cd /tsqueeze
gunzip tsqueeze.tar.gz
tar -xf squeeze.tar
cd ../
cp fun_plug.debian fun_plug
Reboot

I have all the files extracted to /Volume_1/tsqueeze and the fun_plug file - (and its running because the only user name and pass that works is root and serviio) but when i input root and pass serviio it just closes the connection or says wrong if i type anything else. help!?

I am assuming a permission error on a folder....?
<<

Lukas718

Streaming enthusiast

Posts: 41

Joined: Sun Aug 28, 2011 7:04 pm

Post Sat Jan 07, 2012 1:35 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

thanks bud!

I get the same thing

login as: root
root@192.168.2.43's password: serviio

I get error: Server unexpectedly closed network connection

that crashes PuTTY's SSH connection
<<

jsviverette

Serviio newbie

Posts: 11

Joined: Sat Jan 07, 2012 12:41 am

Post Sat Jan 07, 2012 3:46 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

let me know if you figure it out.........
<<

jsviverette

Serviio newbie

Posts: 11

Joined: Sat Jan 07, 2012 12:41 am

Post Sat Jan 07, 2012 4:14 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

fix'd it.

The beta package is broken. DL the version 5 package and it works fine.
<<

Lukas718

Streaming enthusiast

Posts: 41

Joined: Sun Aug 28, 2011 7:04 pm

Post Sat Jan 07, 2012 4:15 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

jsviverette wrote:fix'd it.

The beta package is broken. DL the version 5 package and it works fine.


can u post the link to it plz

Also can u tell me exactly (step by step) how u did it ?

Thanks again bud
<<

jsviverette

Serviio newbie

Posts: 11

Joined: Sat Jan 07, 2012 12:41 am

Post Sat Jan 07, 2012 4:36 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

Same link as in the first post just dl the other one.

---http://www.megaupload.com/?d=EMVLFG19

Then follow the directions in the file. Basicly its:

Unzip the file linked above:
fun_plug.debian
tsqueeze.tgz
and put them to \\DNS-device\Volume_1

Telnet/SSH to the device.
cd /mnt/HD/HD_a2
gunzip tsqueeze.tgz
tar -xf tsqueeze.tar (this makes the folder you dont need to)

Make sure to rename the starting script in /mnt/HD/HD_a2/ from fun_plug.debian to fun_plug
<<

Lukas718

Streaming enthusiast

Posts: 41

Joined: Sun Aug 28, 2011 7:04 pm

Post Sat Jan 07, 2012 4:59 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

"..Make sure to rename the starting script in /mnt/HD/HD_a2/ from fun_plug.debian to fun_plug.."

can u explain that plz ? ( rename in the file or file itself ) ?
<<

jsviverette

Serviio newbie

Posts: 11

Joined: Sat Jan 07, 2012 12:41 am

Post Sat Jan 07, 2012 5:10 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

The file /mnt/HD/HD_a2/fun_plug Tells the DNS-320 to boot linux. If you use the fun_plug file that came with the fonz package you will boot into the /ffp folder.

You need to replace this file with the one from serviio (fun_plug.debian)

So take the normal file -fun_plug and rename it to fun_plug.ffp (so you still have it) and rename the fun_plug.debian file to fun_plug so it boots /tsqueeze
<<

Lukas718

Streaming enthusiast

Posts: 41

Joined: Sun Aug 28, 2011 7:04 pm

Post Sat Jan 07, 2012 6:30 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

did u delete previous folders (tsqueeze) before you started new install ?
<<

Lukas718

Streaming enthusiast

Posts: 41

Joined: Sun Aug 28, 2011 7:04 pm

Post Sat Jan 07, 2012 6:35 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

for some reason I cant telnet
<<

Lukas718

Streaming enthusiast

Posts: 41

Joined: Sun Aug 28, 2011 7:04 pm

Post Sat Jan 07, 2012 6:59 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

ok got it :)
<<

jsviverette

Serviio newbie

Posts: 11

Joined: Sat Jan 07, 2012 12:41 am

Post Sat Jan 07, 2012 9:15 am

Re: HOWTO: Serviio on DNS-320 & DNS-325

how is it working for you because it seems, broken at best for me.....
PreviousNext

Return to NAS installation

Who is online

Users browsing this forum: Google [Bot] and 3 guests

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.