FAQ  •  Register  •  Login

PACKAGE: Serviio 1.9 - Synology NAS, with HW transcoding!

<<

lesley

Serviio newbie

Posts: 1

Joined: Sun May 22, 2016 3:14 pm

Post Sun May 22, 2016 3:30 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

patters wrote:This does not happen on my system. Did you do something non-standard when 1.6 first came out, and there were issues upgrading from 1.5.2? I remember someone on here published some instructions to edit the firewall definitions registration inside the package and I urged people not to do this as they would end up with an orphaned firewall definition.

Try restarting the NAS, sometimes that can glitchy fix port conflict messages.

I had the same problem with "Port undefined" after upgrade, but managed to solve it by removing the file
/usr/local/etc/services.d/Serviio.sc
that seems to disturb the installation

I also got problem with missing dejavu-fonts-ttf-2.35.tar.bz2 that I needed to find and download to my public map from https://sourceforge.net/projects/dejavu/

At last - my old database was saved in /volume1/@appstore/Serviio_db_migration so after installation I copied it into Serviio/library:
cp -R /volume1/@appstore/Serviio_db_migration/db /volume1/@appstore/Serviio/library

Now Serviio is running again at my Synology :-)

/ Lesley
<<

M3kk

Serviio newbie

Posts: 7

Joined: Fri Jan 30, 2015 4:46 pm

Post Mon May 23, 2016 10:30 am

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

Simply i cant install anymore, due that error.
<<

patters

User avatar

DLNA master

Posts: 1239

Joined: Sat Oct 09, 2010 3:51 pm

Location: London, UK

Post Wed May 25, 2016 12:18 am

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

I just upgraded my old DS111 NAS from Serviio 1.6 to 1.6.1 without issue. Maybe it's a glitch that only affects certain models, or under certain specific circumstances. I haven't encountered it on either of my own two Synology systems.

If you still have problems I would suggest entirely removing Serviio, deleting the file Lesley mentions in the post just above this one, and trying to install once again.
PS4 | Bravia KDL-32V5500 | Xbox One S | Synology DS214play
Serviio 1.9 package for Synology NAS - with hardware transcoding support!
<<

M3kk

Serviio newbie

Posts: 7

Joined: Fri Jan 30, 2015 4:46 pm

Post Wed May 25, 2016 2:22 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

Hello, yes what lesley said was the trick. The /usr/local/etc/services.d/Serviio.sc should be removed, or modified.

Sorry, when i did my last reply i didnt see lesley's post :).

Thanks again.
<<

kiskouli

Serviio newbie

Posts: 9

Joined: Sun Feb 15, 2015 10:53 pm

Post Wed May 25, 2016 6:18 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

Hi Patters
Upgrade from 1.6.0 to 1.6.1 went well on my side
But after a few watch tries, some files not playing anymore, samsung tv goes off after few seconds(?! O_o), for working ones, quality could be awful, encounter some freezes...
Don't want to go deeper in the troubles...
So would like to revert to 1.6.0 package: were can i find this package? 403 on http://download.serviio.org/releases/...
Thank's
<<

patters

User avatar

DLNA master

Posts: 1239

Joined: Sat Oct 09, 2010 3:51 pm

Location: London, UK

Post Fri May 27, 2016 8:21 am

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

PS4 | Bravia KDL-32V5500 | Xbox One S | Synology DS214play
Serviio 1.9 package for Synology NAS - with hardware transcoding support!
<<

polanskiman

Serviio newbie

Posts: 1

Joined: Thu Jun 09, 2016 4:00 am

Post Thu Jun 09, 2016 4:44 am

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

Hello,

I recently installed Serviio 1.6.1 on a Xpenology NAS. I am using my PS3 to stream the videos to the TV. All was working nicely until last night when I tried to play one episode of a serie I am watching. I kept getting an error from the PS3 saying the following: Media Server Error: A network error has occurred. (000001F4). I tried streaming the same episode with plex and it worked fine so I looked at Serviio's log and found out that the subtitle file (srt) corresponding to that episode was creating an error in Serviio. After trial and error I figured out that the problem was coming from an apostrophe in the SRT's file name. I was able to reproduce this consistently each time by adding and then deleting the apostrophe from the SRT file's name. Here is the corresponding error section in the log:

  Code:
2016-06-08 21:30:28,286 WARN  [ProcessExecutor] Process /var/packages/Serviio/target/bin/ffmpeg has a return code of 1! This is a possible error. Detailed output follows.
_STATISTICS_TAGS: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
_STATISTICS_TAGS-eng: BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
[Parsed_subtitles_0 @ 0x8120100] Unable to open /volume1/media/video/TV Shows/Suits/Season 4/Suits S04E07 - We\re Done (2014 July 30).srt
[AVFilterGraph @ 0x80ac320] Error initializing filter 'subtitles' with args 'filename=/volume1/media/video/TV Shows/Suits/Season 4/Suits S04E07 - We\\\re Done (2014 July 30).srt:original_size=1280x720:charenc=UTF-8[v]'
Error configuring filters.
2016-06-08 21:30:29,020 INFO  [FeedUpdaterWorker] Started looking for information about online resources
2016-06-08 21:30:29,039 INFO  [FileDeltaWatcher] Using 'sun.nio.fs.LinuxWatchService' for delta scan
2016-06-08 21:30:29,044 INFO  [RepositoriesStatusCoordinator$RepositoriesStatusThread] Started checking repositories status
2016-06-08 21:30:29,053 INFO  [LocalLibraryManager] Starting automatic library scan
2016-06-08 21:30:29,880 INFO  [LibraryDeltaScanner] Added repository '/volume1/media/video' to delta scanner (NATIVE)
2016-06-08 21:30:29,880 INFO  [LibraryDeltaScanner] Starting the library delta scan
2016-06-08 21:30:29,881 INFO  [PlaylistMaintainerWorker] Started looking for playlist changes
2016-06-08 21:31:28,380 ERROR [ResourceTransportRequestHandler] Error while processing resource, sending back 500 error. Message: Transcoded file '/volume1/@tmp/Serviio/transcoding-temp-1028-4-ORIGINAL-f3ad1ac8bbe36e1cda3671333481bd4d.stf' cannot be found, FFmpeg execution probably failed
java.io.IOException: Transcoded file '/volume1/@tmp/Serviio/transcoding-temp-1028-4-ORIGINAL-f3ad1ac8bbe36e1cda3671333481bd4d.stf' cannot be found, FFmpeg execution probably failed
   at org.serviio.delivery.resource.transcode.FileBasedTranscodingDeliveryStrategy.createInputStream(FileBasedTranscodingDeliveryStrategy.java:47)
   at org.serviio.delivery.resource.transcode.AbstractAVTranscodingDeliveryEngine.retrieveTranscodedResource(AbstractAVTranscodingDeliveryEngine.java:143)
   at org.serviio.delivery.resource.AbstractDeliveryEngine.deliver(AbstractDeliveryEngine.java:93)
   at org.serviio.delivery.MediaResourceRetrievalStrategy.retrieveResource(MediaResourceRetrievalStrategy.java:158)
   at org.serviio.delivery.GETMethodProcessor.retrieveResource(GETMethodProcessor.java:121)
   at org.serviio.delivery.GETMethodProcessor.buildDeliveryContainer(GETMethodProcessor.java:48)
   at org.serviio.delivery.AbstractMethodProcessor.handleRequest(AbstractMethodProcessor.java:100)
   at org.serviio.delivery.ResourceDeliveryProcessor.deliverContent(ResourceDeliveryProcessor.java:81)
   at org.serviio.upnp.webserver.ResourceTransportRequestHandler.handleRequest(ResourceTransportRequestHandler.java:86)
   at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:61)
   at org.apache.http.protocol.HttpService.doService(HttpService.java:423)
   at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:78)
   at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:341)
   at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:204)
<<

lagarde01

Serviio newbie

Posts: 1

Joined: Sun Jun 12, 2016 6:12 pm

Post Sun Jun 12, 2016 6:24 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

hi lesley

it seem that I have the same problem, after trying to upgrade from 1.4.2 to 1.6.1. I got the message "port undefined etc. etc. " I have alreade removed the old version en installed manually the 1.5.2 version, however the problem stays.

So I guess that the solution you placed on the forum is the right on for me, however how do I get to the file to delete it as you mentioned

/usr/local/etc/services.d/Serviio.sc

I've heard of putty but never worked with it, couldt you advice me on this

tx Machiel
<<

NRB

Serviio lover

Posts: 67

Joined: Thu Nov 11, 2010 5:29 am

Post Sun Jun 19, 2016 12:03 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

Since upgrading to 1.6.1 from 1.5.1 (had to reinstall) on my Synology DS413 i can't stream to my Sony Bravia KDL-32EX-600. It throws an error that the TV can't connect to the server. It streams fine to an Android box connected to the same wireless receiver.
<<

Morbeas

Streaming enthusiast

Posts: 28

Joined: Wed Jan 16, 2013 7:44 pm

Post Mon Jul 18, 2016 2:41 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

Trying to upgrade from version 1.5.2 and getting the following error. This is running on a DS1511+, DSM version 6.0.1-7393 Update 1.

Edit: Running Java SE embedded 8. 1.8.0_65-0035.
Attachments
Clipboard01.jpg
Clipboard01.jpg (14.72 KiB) Viewed 3671 times
<<

patters

User avatar

DLNA master

Posts: 1239

Joined: Sat Oct 09, 2010 3:51 pm

Location: London, UK

Post Tue Jul 19, 2016 12:23 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

See Lesley's post at the top of this page. Connect to your NAS via SSH (PuTTY, or Terminal on Mac OS).
On DSM 5.x log in as username "root" with the same password you use for admin in DSM.
If you're running DSM 6.0 you need to log in as usename "admin", then run "sudo -i" and enter the same password again. Now you're root.

Delete the file using:
  Code:
rm /usr/local/etc/services.d/Serviio.sc


Now you should be able to install the package without encountering that error.
PS4 | Bravia KDL-32V5500 | Xbox One S | Synology DS214play
Serviio 1.9 package for Synology NAS - with hardware transcoding support!
<<

Morbeas

Streaming enthusiast

Posts: 28

Joined: Wed Jan 16, 2013 7:44 pm

Post Tue Jul 19, 2016 1:21 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

patters wrote:See Lesley's post at the top of this page. Connect to your NAS via SSH (PuTTY, or Terminal on Mac OS).
On DSM 5.x log in as username "root" with the same password you use for admin in DSM.
If you're running DSM 6.0 you need to log in as usename "admin", then run "sudo -i" and enter the same password again. Now you're root.

Delete the file using:
  Code:
rm /usr/local/etc/services.d/Serviio.sc


Now you should be able to install the package without encountering that error.


Thanks for the response, Patters but after deleting the file, I still cannot update. I still get the same error. Any other suggestions? :(
<<

Morbeas

Streaming enthusiast

Posts: 28

Joined: Wed Jan 16, 2013 7:44 pm

Post Wed Jul 27, 2016 5:24 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

Morbeas wrote:
patters wrote:See Lesley's post at the top of this page. Connect to your NAS via SSH (PuTTY, or Terminal on Mac OS).
On DSM 5.x log in as username "root" with the same password you use for admin in DSM.
If you're running DSM 6.0 you need to log in as usename "admin", then run "sudo -i" and enter the same password again. Now you're root.

Delete the file using:
  Code:
rm /usr/local/etc/services.d/Serviio.sc


Now you should be able to install the package without encountering that error.


Thanks for the response, Patters but after deleting the file, I still cannot update. I still get the same error. Any other suggestions? :(


Is there no hope for me, Patters? :(
<<

zoti

Serviio newbie

Posts: 2

Joined: Fri Aug 19, 2016 12:24 pm

Post Fri Aug 19, 2016 12:37 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

Hello,
i updated Serviio to Version 1.6.1-030, after some errors i reinstalled Serviio and now it won't start anymore.

my log:
  Code:
2016-08-19 13:48:32,000 Starting Serviio
Java HotSpot(TM) Embedded Client VM warning: G1 GC is disabled in this release.
2016-08-19 13:48:36,115 INFO  [MediaServer] ------------------------------------------------------------------------
2016-08-19 13:48:36,118 INFO  [MediaServer] Serviio DLNA media streaming server v 1.6.1 (rev. 34f326d2b259)
2016-08-19 13:48:36,119 INFO  [MediaServer] Petr Nejedly 2009-2015
2016-08-19 13:48:36,119 INFO  [MediaServer] http://www.serviio.org
2016-08-19 13:48:36,119 INFO  [MediaServer]
2016-08-19 13:48:36,119 INFO  [MediaServer] Java 1.8.0_101-Oracle Corporation arm
2016-08-19 13:48:36,119 INFO  [MediaServer] OS Linux 3.2.40
2016-08-19 13:48:36,120 INFO  [MediaServer] File encoding: UTF-8
2016-08-19 13:48:36,573 INFO  [MediaServer] Headless mode enabled: true
2016-08-19 13:48:36,573 INFO  [MediaServer] User: root
2016-08-19 13:48:36,574 INFO  [MediaServer] User home dir: /root
2016-08-19 13:48:36,574 INFO  [MediaServer] Temp dir: /tmp
2016-08-19 13:48:36,574 INFO  [MediaServer] ------------------------------------------------------------------------
2016-08-19 13:48:36,744 INFO  [DBSchemaUpdateExecutor] Checking if DB schema needs to be updated
2016-08-19 13:48:36,900 INFO  [DatabaseManager] Using DERBY database language
2016-08-19 13:48:41,930 WARN  [DBConnectionPool] Can't create a new connection for jdbc:derby:db;create=true
java.sql.SQLException: Failed to create database 'db', see the next exception for details.
   at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
   at org.apache.derby.impl.jdbc.SQLExceptionFactory.getSQLException(Unknown Source)
   at org.apache.derby.impl.jdbc.Util.seeNextException(Unknown Source)
   at org.apache.derby.impl.jdbc.EmbedConnection.createDatabase(Unknown Source)
   at org.apache.derby.impl.jdbc.EmbedConnection.<init>(Unknown Source)
   at org.apache.derby.jdbc.InternalDriver$1.run(Unknown Source)
   at org.apache.derby.jdbc.InternalDriver$1.run(Unknown Source)
   at java.security.AccessController.doPrivileged(Native Method)
   at org.apache.derby.jdbc.InternalDriver.getNewEmbedConnection(Unknown Source)
   at org.apache.derby.jdbc.InternalDriver.connect(Unknown Source)
   at org.apache.derby.jdbc.InternalDriver.connect(Unknown Source)
   at org.apache.derby.jdbc.AutoloadedDriver.connect(Unknown Source)
   at java.sql.DriverManager.getConnection(DriverManager.java:664)
   at java.sql.DriverManager.getConnection(DriverManager.java:270)
   at org.serviio.db.DBConnectionPool.newConnection(DBConnetionPool.java:186)
   at org.serviio.db.DBConnectionPool.getConnection(DBConnetionPool.java:123)
   at org.serviio.db.DBConnectionPool.getConnection(DBConnetionPool.java:149)
   at org.serviio.db.DatabaseManager.getConnection(DatabaseManager.java:71)
   at org.serviio.db.DatabaseManager.getConnection(DatabaseManager.java:64)
   at org.serviio.update.dao.DBLogDAOImpl.isScriptPresent(DBLogDAOImpl.java:49)
   at org.serviio.update.DBSchemaUpdateExecutor.updateDBSchema(DBSchemaUpdateExecutor.java:78)
   at org.serviio.MediaServer.main(MediaServer.java:119)
Caused by: ERROR XJ041: Failed to create database 'db', see the next exception for details.
   at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
   at org.apache.derby.impl.jdbc.SQLExceptionFactory.wrapArgsForTransportAcrossDRDA(Unknown Source)
   ... 22 more
Caused by: ERROR XBM01: Startup failed due to an exception. See next exception for details.
   at org.apache.derby.iapi.error.StandardException.newException(Unknown Source)
   at org.apache.derby.iapi.services.monitor.Monitor.exceptionStartingModule(Unknown Source)
   at org.apache.derby.impl.services.monitor.BaseMonitor.bootService(Unknown Source)
   at org.apache.derby.impl.services.monitor.BaseMonitor.createPersistentService(Unknown Source)
   at org.apache.derby.impl.services.monitor.FileMonitor.createPersistentService(Unknown Source)
   at org.apache.derby.iapi.services.monitor.Monitor.createPersistentService(Unknown Source)
   at org.apache.derby.impl.jdbc.EmbedConnection$5.run(Unknown Source)
   at java.security.AccessController.doPrivileged(Native Method)
   at org.apache.derby.impl.jdbc.EmbedConnection.createPersistentService(Unknown Source)
   ... 19 more
Caused by: java.lang.ArrayIndexOutOfBoundsException: 0
   at sun.nio.cs.UTF_8$Encoder.encode(UTF_8.java:716)
   at java.lang.StringCoding$StringEncoder.encode(StringCoding.java:304)
   at java.lang.StringCoding.encode(StringCoding.java:344)
   at java.lang.String.getBytes(String.java:918)
   at java.io.UnixFileSystem.getBooleanAttributes0(Native Method)
   at java.io.UnixFileSystem.getBooleanAttributes(UnixFileSystem.java:242)
   at java.io.File.exists(File.java:819)
   at org.apache.derby.impl.store.raw.data.RAFContainer.privGetFileName(Unknown Source)
   at org.apache.derby.impl.store.raw.data.RAFContainer.run(Unknown Source)
   at java.security.AccessController.doPrivileged(Native Method)
   at org.apache.derby.impl.store.raw.data.RAFContainer.createContainer(Unknown Source)
   at org.apache.derby.impl.store.raw.data.RAFContainer4.createContainer(Unknown Source)
   at org.apache.derby.impl.store.raw.data.FileContainer.createIdent(Unknown Source)
   at org.apache.derby.impl.store.raw.data.FileContainer.createIdentity(Unknown Source)
   at org.apache.derby.impl.services.cache.ConcurrentCache.create(Unknown Source)
   at org.apache.derby.impl.store.raw.data.BaseDataFileFactory.addContainer(Unknown Source)
   at org.apache.derby.impl.store.raw.xact.Xact.addContainer(Unknown Source)
   at org.apache.derby.impl.store.access.btree.BTree.create(Unknown Source)
   at org.apache.derby.impl.store.access.btree.index.B2I.create(Unknown Source)
   at org.apache.derby.impl.store.access.btree.index.B2IFactory.createConglomerate(Unknown Source)
   at org.apache.derby.impl.store.access.RAMTransaction.createConglomerate(Unknown Source)
   at org.apache.derby.impl.sql.catalog.DataDictionaryImpl.bootstrapOneIndex(Unknown Source)
   at org.apache.derby.impl.sql.catalog.DataDictionaryImpl.bootStrapSystemIndexes(Unknown Source)
   at org.apache.derby.impl.sql.catalog.DataDictionaryImpl.makeCatalog(Unknown Source)
   at org.apache.derby.impl.sql.catalog.DataDictionaryImpl.createDictionaryTables(Unknown Source)
   at org.apache.derby.impl.sql.catalog.DataDictionaryImpl.boot(Unknown Source)
   at org.apache.derby.impl.services.monitor.BaseMonitor.boot(Unknown Source)
   at org.apache.derby.impl.services.monitor.TopService.bootModule(Unknown Source)
   at org.apache.derby.impl.services.monitor.BaseMonitor.startModule(Unknown Source)
   at org.apache.derby.impl.services.monitor.FileMonitor.startModule(Unknown Source)
   at org.apache.derby.iapi.services.monitor.Monitor.bootServiceModule(Unknown Source)
   at org.apache.derby.impl.db.BasicDatabase$5.run(Unknown Source)
   at java.security.AccessController.doPrivileged(Native Method)
   at org.apache.derby.impl.db.BasicDatabase.bootServiceModule(Unknown Source)
   at org.apache.derby.impl.db.BasicDatabase.boot(Unknown Source)
   at org.apache.derby.impl.services.monitor.BaseMonitor.boot(Unknown Source)
   at org.apache.derby.impl.services.monitor.TopService.bootModule(Unknown Source)
   ... 26 more
2016-08-19 13:48:43,955 ERROR [MediaServer] An unexpected error occured. Ending the application. Message: null
java.lang.NullPointerException
   at org.serviio.update.dao.DBLogDAOImpl.isScriptPresent(DBLogDAOImpl.java:50)
   at org.serviio.update.DBSchemaUpdateExecutor.updateDBSchema(DBSchemaUpdateExecutor.java:78)
   at org.serviio.MediaServer.main(MediaServer.java:119)

Java 8 version 1.8.0_101 is installed.
it's a DS414
DSM Version: DSM 6.0.1-7393 Update 2

please help :)
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16495

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Aug 19, 2016 3:33 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

Try to use the Synology official Java rather than Patters' one.
<<

zoti

Serviio newbie

Posts: 2

Joined: Fri Aug 19, 2016 12:24 pm

Post Fri Aug 19, 2016 7:26 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

Thanks zip, it works. :)
<<

patters

User avatar

DLNA master

Posts: 1239

Joined: Sat Oct 09, 2010 3:51 pm

Location: London, UK

Post Thu Aug 25, 2016 3:47 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

I think this is because DSM 6.0 saw certain ARM systems switch from soft to hard float ABI. Your system uses ARMADA XP SoC, and this is indeed the case. I need to update the Java package to take this into account.
PS4 | Bravia KDL-32V5500 | Xbox One S | Synology DS214play
Serviio 1.9 package for Synology NAS - with hardware transcoding support!
<<

Illico

User avatar

DLNA master

Posts: 4649

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Sat Sep 03, 2016 12:48 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

Hi Patters,

I just have a new DS116 synology NAS.
I install the official Java 8 package.
I install your serviio package.( I have to create a public shared folder for the serviio installation)


This is the NAS DS116 hardware information.
root@SynoDS116:~# uname -a
Linux SynoDS116 3.10.77 #8451 SMP Wed Aug 17 05:12:58 CST 2016 armv7l GNU/Linux synology_armada38x_ds116

root@SynoDS116:~# cat /proc/cpuinfo
processor : 0
model name : ARMv7 Processor rev 1 (v7l)
BogoMIPS : 3719.16
Features : swp half thumb fastmult vfp edsp neon vfpv3 tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x4
CPU part : 0xc09
CPU revision : 1

processor : 1
model name : ARMv7 Processor rev 1 (v7l)
BogoMIPS : 3726.54
Features : swp half thumb fastmult vfp edsp neon vfpv3 tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x4
CPU part : 0xc09
CPU revision : 1

Hardware : Marvell Armada 380/381/382/383/384/385/388 (Device Tree)
Revision : 0000
Serial : 0000000000000000



I add a shared folder to build the library (44% cpu load avg, 66KB/s avg download eth0).

I make a test on my SonyBravia2010 with an simple AVI file 640p. The cpu load was at 80% (transcoding enabled), 350KB/s upload on eth0 network.
I make another test with a 720p avi file. The CPU load reach 84% during transcoding process.

So all seems good here. I will chek with more formats.

Thanks Patters for this NAS package
<<

nevets14

Serviio newbie

Posts: 10

Joined: Sat Mar 26, 2016 6:19 am

Post Mon Nov 07, 2016 7:32 pm

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

patters wrote:I think this is because DSM 6.0 saw certain ARM systems switch from soft to hard float ABI. Your system uses ARMADA XP SoC, and this is indeed the case. I need to update the Java package to take this into account.


Has there been any word on this update to the Java package? I have a feeling this may solve a lot of the current problems with Serviio 1.6 on Armada based Synology NAS's.
<<

patters

User avatar

DLNA master

Posts: 1239

Joined: Sat Oct 09, 2010 3:51 pm

Location: London, UK

Post Sat Jan 07, 2017 12:48 am

Re: PACKAGE: Serviio 1.6.1 - Synology NAS, with HW transcodi

nevets14 wrote:Has there been any word on this update to the Java package? I have a feeling this may solve a lot of the current problems with Serviio 1.6 on Armada based Synology NAS's.


I just released an updated version which should fix this, and it's updated to Java 8u111.
PS4 | Bravia KDL-32V5500 | Xbox One S | Synology DS214play
Serviio 1.9 package for Synology NAS - with hardware transcoding support!
PreviousNext

Return to NAS installation

Who is online

Users browsing this forum: No registered users and 5 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.