FAQ  •  Register  •  Login

Web UI in PHP - support thread

<<

Xmantium

User avatar

DLNA master

Posts: 1417

Joined: Sat Jul 23, 2011 2:12 pm

Location: Manchester, UK

Post Sun Feb 01, 2015 6:11 pm

Re: Web UI in PHP - support thread

Its changed to "Add local..."
Sony Bravia 2010 52NX803 - Sony PS3 - Xbox 360
Serviio running on QNAP NAS 639 Pro - 1.6 Intel Dual Core - 2GB RAM and QNAP NAS 121 - 2Ghz ARM Marvell - 1GB RAM
Console using ServiiDroid for Android, ServiiMetro and ServiiWP for Windows Phone and WebUI for iOS
<<

M3kk

Serviio newbie

Posts: 7

Joined: Fri Jan 30, 2015 4:46 pm

Post Mon Feb 02, 2015 1:42 pm

Re: Web UI in PHP - support thread

Not really.. Add Local is for browsing, Add Path is to write directly the Path..
<<

Swoop

Serviio lover

Posts: 87

Joined: Fri Mar 29, 2013 10:21 am

Post Mon Feb 09, 2015 10:23 pm

Re: Web UI in PHP - support thread

Update is close ;)
<<

Swoop

Serviio lover

Posts: 87

Joined: Fri Mar 29, 2013 10:21 am

Post Tue Feb 10, 2015 11:53 am

Re: Web UI in PHP - support thread

...and now done ;) HF
<<

M3kk

Serviio newbie

Posts: 7

Joined: Fri Jan 30, 2015 4:46 pm

Post Wed Feb 11, 2015 9:47 am

Re: Web UI in PHP - support thread

Thanks, a bit bugged, but its OK :).
<<

Swoop

Serviio lover

Posts: 87

Joined: Fri Mar 29, 2013 10:21 am

Post Wed Feb 11, 2015 9:15 pm

Re: Web UI in PHP - support thread

Why bugged?
<<

M3kk

Serviio newbie

Posts: 7

Joined: Fri Jan 30, 2015 4:46 pm

Post Fri Feb 27, 2015 10:41 am

Re: Web UI in PHP - support thread

With removing or adding shared folder is bugged. For example when i want to remove an entry, he removes the other one and so on :).
<<

Swoop

Serviio lover

Posts: 87

Joined: Fri Mar 29, 2013 10:21 am

Post Sat Feb 28, 2015 1:09 pm

Re: Web UI in PHP - support thread

Thanks for mentioning. I'll have a look ;)
<<

ddfs

Serviio newbie

Posts: 17

Joined: Sat Oct 29, 2011 4:50 pm

Post Thu Apr 09, 2015 7:27 am

Re: Web UI in PHP - support thread

I confirm that I have the same bug with adding/removing a path. When this will be fixed? ;)
<<

Swoop

Serviio lover

Posts: 87

Joined: Fri Mar 29, 2013 10:21 am

Post Thu Apr 16, 2015 10:27 pm

Re: Web UI in PHP - support thread

Hm, I should avoid putting in too much garbage for testing... Apparently, I tend to overlook stuff then :oops:

Should have been fixed. DL the updated version and give it a shot and let me know.
<<

madseason41

Serviio newbie

Posts: 17

Joined: Thu Mar 05, 2015 12:48 am

Post Tue Apr 21, 2015 2:06 pm

Re: Web UI in PHP - support thread

After corrupting my install, I reinstalled both serviio and the latest webui. I seem to be having library path issues as well. I saved 2 library paths and they saved and scanned. I cannot add a third path. When I attempt this I get either a http error 0 box and or it removes other library paths.

I am running the latest git version, downloaded last night.

Thoughts?
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16237

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Apr 21, 2015 3:15 pm

Re: Web UI in PHP - support thread

Make sure your paths are not duplicate, eg:

c:\a\b
c:\a\b\c

This would throw an error as all files from c:\a\b are already shared anyway.
<<

madseason41

Serviio newbie

Posts: 17

Joined: Thu Mar 05, 2015 12:48 am

Post Tue Apr 21, 2015 3:40 pm

Re: Web UI in PHP - support thread

They are not and the error just introduced itself after the reinstall.

Paths are desired to be:
/share/Multimedia/Video/TV Shows
/share/Multimedia/Video/Movies
/share/Multimedia/Music/iTunes
/share/Multimedia/Photos

I don't think the above is redundant or should cause problems?
<<

Swoop

Serviio lover

Posts: 87

Joined: Fri Mar 29, 2013 10:21 am

Post Tue Apr 21, 2015 8:48 pm

Re: Web UI in PHP - support thread

I think madseason41 has made another one up. I was able to reproduce it with using "add local" as an ID doesn't count up correctly. However, it doesn't seem to happen if you use "add path". Strange enough since both basically use the same functions. Will try to figure it out shortly.

You might wanna try using "add path" meanwhile?!
<<

Swoop

Serviio lover

Posts: 87

Joined: Fri Mar 29, 2013 10:21 am

Post Tue Apr 21, 2015 9:04 pm

Re: Web UI in PHP - support thread

Should be ok now. What a simple +1 can do :D
<<

madseason41

Serviio newbie

Posts: 17

Joined: Thu Mar 05, 2015 12:48 am

Post Tue Apr 21, 2015 9:07 pm

Re: Web UI in PHP - support thread

You know, in my slumber of troubleshooting, I think I added the second library by choosing add path.

After coming back to add the rest I diverted back to "add local" and started noticing errors.

After trying the "add path" method to add the rest of the libraries it seems to do the trick.

Sorry if I missed this in the thread!
<<

Swoop

Serviio lover

Posts: 87

Joined: Fri Mar 29, 2013 10:21 am

Post Tue Apr 21, 2015 9:45 pm

Re: Web UI in PHP - support thread

It does not necessarily matter which one you use as either should worl but thanks for highlighting this. Reproducing it screwed my lib since the path has been overwritten somehow so it was indeed an error :lol:
<<

madseason41

Serviio newbie

Posts: 17

Joined: Thu Mar 05, 2015 12:48 am

Post Tue Apr 21, 2015 10:29 pm

Re: Web UI in PHP - support thread

Hmm maybe that's how my library got messed up. That was the reason i did a fresh install.

Regardless the latest version seems to work.

Thanks
<<

Wixie

Serviio newbie

Posts: 16

Joined: Wed Aug 13, 2014 7:44 pm

Post Sun May 03, 2015 6:03 pm

Re: Web UI in PHP - support thread

How can i password protect the webgui ?
<<

Swoop

Serviio lover

Posts: 87

Joined: Fri Mar 29, 2013 10:21 am

Post Thu May 07, 2015 10:16 pm

Re: Web UI in PHP - support thread

You have to have a .htaccess file in the corresponding directory. Just fire up google and it will guide you through ;)
PreviousNext

Return to Third-party tools integration

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.