FAQ  •  Register  •  Login

YouTube

<<

michaelrash

Serviio newbie

Posts: 3

Joined: Tue Jan 24, 2017 9:58 pm

Post Tue Jan 24, 2017 10:23 pm

Re: YouTube

CraigWally wrote:OK Thanks - I think I understand
Is there a way to get a feed url for a specific video


you can grab the share link bellow the video, theres different formats you can use, hope that helps :)
<<

DEFCON SHARK

Serviio newbie

Posts: 5

Joined: Sat Mar 05, 2016 12:52 am

Post Wed Jan 25, 2017 8:40 pm

Re: YouTube

zip wrote:Hi,

I tried this playlist and it plays on both, MediaBrowser and XBox One.


The problem is exclusive to me then ... where can it be coming from ?
<<

fidmas

Serviio lover

Posts: 90

Joined: Thu Dec 17, 2015 8:29 pm

Post Wed Jan 25, 2017 10:16 pm

Re: YouTube

I assume I should just forget about this viewtopic.php?f=20&t=3276&start=460#p111592 question?
<<

Canapla

Serviio newbie

Posts: 2

Joined: Thu Jun 02, 2016 5:35 pm

Post Thu Feb 09, 2017 12:11 pm

Re: YouTube

I have just installed the plugin on the firefox, but I'm not able to make it come out... it's an old versione and no more supported fot the new firefox? serviio is the latest 1.8 with the latest youtube addon, I tried to installthe foxtube but nothing happen to the firefox.. any new button or something else.

Help me plz
<<

Combat Jack

Streaming enthusiast

Posts: 26

Joined: Fri Nov 07, 2014 10:34 pm

Post Mon Feb 13, 2017 12:47 am

Re: YouTube

[edit]

UPDATE: Does this plugin still work for anyone else? I can still see old videos in the list up until Feb 9. After that no more new videos show in the list and none of the old videos will play.

Did they change the API or is there a problem with Serviio's Youtube API key? The plugin no longer works for me.

Update 2: The plugin plays videos for some channels but not for others. Very strange. All of them are done in the same method (as shown below) but some channels aren't showing new video updates and are causing my TV to crash.

Below is a channel that is no longer working for me since Feb 9th:

  Code:
Web resource:
https://www.googleapis.com/youtube/v3/channels?forUsername=Bayareabuggs


Below is a channel that still works perfectly (notice same API call)

  Code:
Web resource:
https://www.googleapis.com/youtube/v3/channels?forUsername=HistoricDepths
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16231

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Feb 14, 2017 8:40 pm

Re: YouTube

your playlists still work for me
<<

Combat Jack

Streaming enthusiast

Posts: 26

Joined: Fri Nov 07, 2014 10:34 pm

Post Wed Feb 15, 2017 9:27 am

Re: YouTube

Thanks for checking.

Very odd. I have deleted them from Serviio and re-created them and they are still "frozen" for me. Any suggestions on how to deal with this? I have 4 of them that I regularly watch and they haven't updated since Feb 9th and they all crash my Samsung TV if I sit and try to let them play.

UPDATE: I completely uninstalled Serviio and deleted any Serviio files I could find remaining in the APPDATA folder and the install folder. I used CCleaner to remove any registry entries for Serviio remaining. I re-downloaded the Youtube Plugin and the Firefox browser addon. I re-added all of my Youtube channels and the 4 channels that were giving me trouble are still giving me trouble. No videos are being listed for them.

Is there a setting that the Youtube creator can choose in which the video wouldn't show up in Serviio? ie monetize the video?

UPDATE2: I have two computers with Serviio installed and both are behaving exactly the same. The same 4 channels don't work any more with Serviio. One machine is a Windows 10 and the other Windows 7.

UPDATE3: When I look at my own personal channel only 2 out of the 4 videos show. Both play fine but there should be 4. The Youtube plugin is wonky and needs fixing. All videos are not being displayed in the list.
<<

Combat Jack

Streaming enthusiast

Posts: 26

Joined: Fri Nov 07, 2014 10:34 pm

Post Sat Feb 18, 2017 3:24 pm

Re: YouTube

zip wrote:your playlists still work for me


I am confused by your last statement. I am not using playlists. I am trying to show videos by Youtube username.

For me none of the videos show in the following list (Not since Feb 9th):

  Code:
Web resource:
https://www.googleapis.com/youtube/v3/channels?forUsername=Bayareabuggs


I have 2 computers with 2 different versions of Serviio and both are showing the same result of zero results when I try to view them on my TV.

By the way on version 1.8 when I click the button "check stream URL" I get the error message "The stream URL is not valid or is not currently available". That error shows up on all my Youtube entries whether they work properly or not.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16231

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Feb 18, 2017 9:18 pm

Re: YouTube

The check stream only works for Live Stream type of online resource. Are you sure your you tube list is marked as WebResource?
<<

Combat Jack

Streaming enthusiast

Posts: 26

Joined: Fri Nov 07, 2014 10:34 pm

Post Wed Feb 22, 2017 2:01 pm

Re: YouTube

zip wrote:The check stream only works for Live Stream type of online resource. Are you sure your you tube list is marked as WebResource?


Yup.

I even installed the Firefox plugin when testing to see if I could fix this issue and it is the same result when I delete and then re-add those channels using the Firefox plugin.

The Youtube plugin isn't displaying all of the videos on some channels. On some channels all the videos are displayed perfectly. On some channels only 3 out of hundreds of available videos show in the list. On some channels zero videos show on the list. As I said on my own personal channel only 2 out of 4 videos show in the list. The only thing that I can see is that the Youtube plugin is not displaying videos of certain resolutions or perhaps encoding method. Not sure what the common reason is why some display and others don't.

I have since gone back to watching YouTube on the PS4. Wish I could still use Serviio though.

Edit: never mind. I gave up on the Serviio plugin to stream Youtube and bought an android box. Thanks for all the good times Serviio while it worked.
<<

JLin

Serviio newbie

Posts: 4

Joined: Fri Dec 05, 2014 5:07 pm

Post Wed Mar 08, 2017 4:59 pm

Re: YouTube

I am in the same boat as Combat Jack. You Tube is no longer working on Serviio. I have used the Firefox plugin and as of the last week You Tube playlists fail to refresh and show on app. I am using version 1.8
<<

DVD Listing

Serviio newbie

Posts: 3

Joined: Sat Dec 10, 2016 1:59 pm

Post Thu Mar 23, 2017 3:43 pm

Re: YouTube

It looks like Google has changed something in the backgroud.

However, you can change back to the old version of youtube.
Look for the running man in the bottom right corner; select it and choose restore classic you-tube.

The plugin will now work. :)
<<

mihai

Serviio newbie

Posts: 11

Joined: Sat Nov 30, 2013 1:33 pm

Post Thu Mar 23, 2017 6:51 pm

Re: YouTube

Are there plans to add support for 'hlsvp' parsing? In my case the 'fmt_url_map' & 'adaptive_fmts' parameters are missing, while 'url_encoded_fmt_stream_map' is empty. Only the 'hlsvp' has a value, but that is not currently parsed in Youtube.groovy v4.
Previous

Return to Available plugins

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.