FAQ  •  Register  •  Login

YouTube

<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16475

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Sep 22, 2011 7:58 pm

YouTube

YouTube plugin (Web Resource plugin)

The easiest way to add YouTube feeds to Serviio is by using this Firefox plugin.

This plugin utilises the YouTube API v3, which allows it to browse these resources:

Playlist

Use this URL as the resource URL:
  Code:
https://www.googleapis.com/youtube/v3/playlistItems?playlistId=PLAYLIST_ID


where PLAYLIST_ID is the id of the required playlist.

Example

URL of the playlist in your browser:
  Code:
https://www.youtube.com/playlist?list=PLx6bGx4zt6Em-NyeR2FFg3chd2nWx2dUp

  Code:
https://www.youtube.com/watch?v=Qq8OZyruwik&list=PLx6bGx4zt6Em-NyeR2FFg3chd2nWx2dUp

In all these cases, PLAYLIST_ID is PLx6bGx4zt6Em-NyeR2FFg3chd2nWx2dUp


Videos by id's

Use this URL as the resource URL:
  Code:
https://www.googleapis.com/youtube/v3/videos?id=VIDEO_IDS


where VIDEO_IDS is a comman separated list of video IDs.

Example

URL of the video in your browser:
  Code:
https://www.youtube.com/watch?v=Qq8OZyruwik

In all these cases, VIDEO_IDS is Qq8OZyruwik


Most popular videos

Use this URL as the resource URL:
  Code:
https://www.googleapis.com/youtube/v3/videos?chart=mostPopular


Channels

Use this URL as the resource URL:
  Code:
https://www.googleapis.com/youtube/v3/channels?forUsername=USER_NAME

  Code:
https://www.googleapis.com/youtube/v3/channels?id=CHANNEL_ID


Search videos

Use this URL as the resource URL:
  Code:
https://www.googleapis.com/youtube/v3/search?q=SEARCH_QUERY



Added 22/9/2011
Updated for 0.6.1 5/1/2012
Updated for 0.6.2 31/1/2012
Updated with profile 46 7/2/2012
Fixed 403 error 29/9/2012
Changed to WebResourcePlugin 26/04/2015 (thanks to Stefan Andersson)
Further additions 12/05/2015 (thanks to Stefan Andersson)
Supports search API 16/05/2015 (thanks to Stefan Andersson)
Attachments
Youtube.groovy
(10.66 KiB) Downloaded 7537 times
<<

awaraarawa

Serviio newbie

Posts: 12

Joined: Fri Sep 23, 2011 8:26 pm

Post Fri Sep 23, 2011 8:32 pm

Re: YouTube

So, how does this get installed?

I thought all I had to do was to copy the groovy file into the C:\Program Files\Serviio\plugins folder. I have copied the file while Serviio is running as well as when not running but with no change. I have waited for it to show up overnight. Is there an additional step I need to do before it shows up? All I see under the online tab is the Online RSS/Atom Feed only.

My config is WHS v1 on Acer Easystore. DLNA is operational and other locally stored files are visible and viewable.

Would appreciate a clue or two! Thanks.

Cheers
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16475

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Sep 23, 2011 10:15 pm

Re: YouTube

You now need to enter a YouTube RSS feed URL, examples are here: viewtopic.php?f=23&t=3279
<<

awaraarawa

Serviio newbie

Posts: 12

Joined: Fri Sep 23, 2011 8:26 pm

Post Sat Sep 24, 2011 1:07 am

Re: YouTube

OK, got it. I tried the most viewed YouTube sample URL and it seems to work.....a number of YouTube videos were listed for the URL (http://gdata.youtube.com/feeds/api/stan ... time=today) listed. However, I could not get a Hulu URL to work...does that mean I need a plugin for Hulu and thus the Empty results for it?

One more issue - While I can view the YouTube results on my non-DLNA LG TV via a DLNA capable LG BD 670 blue ray player, I am having trouble playing them. This DLNA blue ray player is connected via Ethernet cable to my home network to which the WHS server is also connected. When I play the video, the result is quite bad, one frame a second - not quite a video.....extreme stutter would be an understatement.

Obviously, I am missing something else in the configuration / setup. I manually entered the renderer profile and selected the LG TV / Player profile. Should I let the application discover the player rather than setting it up manually? Switching to a generic DLNA profile did not make any difference in the results either. The YouTube video plays fine on my laptop without a problem, so the issue is not with the video.....internet connection is fast and stable via cable @ around 18Mbps. However, the player appears to be having bad buffering issues. I have MPG videos and JPG photos on the WHS and they play fine via the same setup. So, streaming content from the WHS to the TV is not the issue. Why would the YouTube video channeled via the WHS have a buffering problem?

So, what am I missing with the Serviio configuration? I have changed the Preferred Online Content Quality to LOW from the default of MEDIUM but no change in the results.

Appreciate any assistance/suggestions to get this figured. Thanks.

PS: When adding a new URL for an online source, there is only one source type listed Online RSS/Atom feed.....should other options be showing up here? Is that what is missing?
<<

CraigWally

Serviio newbie

Posts: 9

Joined: Sat Sep 24, 2011 2:38 pm

Post Sat Sep 24, 2011 2:45 pm

Re: YouTube

I can't seem to get this to work
I've added the plugin
entered some url's
But, when selected the content via my panasonic blueray player I get the message
"No files are in this folder"

:(
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16475

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Sep 24, 2011 4:16 pm

Re: YouTube

What does the log say?
<<

CraigWally

Serviio newbie

Posts: 9

Joined: Sat Sep 24, 2011 2:38 pm

Post Sat Sep 24, 2011 10:41 pm

Re: YouTube

Error during feed parsing : Invalid XML: Error on line 7: The entity name must immediately follow the '&' in the entity reference
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16475

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Sep 25, 2011 12:22 am

Re: YouTube

what's the url?
<<

CraigWally

Serviio newbie

Posts: 9

Joined: Sat Sep 24, 2011 2:38 pm

Post Sun Sep 25, 2011 5:24 pm

Re: YouTube

http://www.youtube.com/watch?v=SD1ENnVnMXM


don't laugh - its for the kids :)
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16475

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Sep 25, 2011 5:53 pm

Re: YouTube

you have to use feed URL, not the actual video.

Look here for some examples: viewtopic.php?f=23&t=3279
<<

CraigWally

Serviio newbie

Posts: 9

Joined: Sat Sep 24, 2011 2:38 pm

Post Sun Sep 25, 2011 6:14 pm

Re: YouTube

OK Thanks - I think I understand
Is there a way to get a feed url for a specific video
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16475

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Sep 25, 2011 6:18 pm

Re: YouTube

did you read the linked topic? viewtopic.php?f=23&t=3279#p21886
<<

CraigWally

Serviio newbie

Posts: 9

Joined: Sat Sep 24, 2011 2:38 pm

Post Sun Sep 25, 2011 9:11 pm

Re: YouTube

I did, but I'm still struggling
perhaps if you could write the url I need for the above example
Sorry to be a pain
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16475

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Sep 25, 2011 9:20 pm

Re: YouTube

  Code:
https://gdata.youtube.com/feeds/api/videos/SD1ENnVnMXM?v=2
<<

CraigWally

Serviio newbie

Posts: 9

Joined: Sat Sep 24, 2011 2:38 pm

Post Sun Sep 25, 2011 9:29 pm

Re: YouTube

Nope - still no joy
Nor with the Chronos example from the other thread
the only ones I can get to work are the most viewed or top rated examples
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16475

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Sep 25, 2011 9:39 pm

Re: YouTube

Actually try http instead of https

  Code:
http://gdata.youtube.com/feeds/api/videos/SD1ENnVnMXM?v=2
<<

CraigWally

Serviio newbie

Posts: 9

Joined: Sat Sep 24, 2011 2:38 pm

Post Sun Sep 25, 2011 9:50 pm

Re: YouTube

Nope - still no joy

I'm off to bed
I'll keep trying tomorrow
<<

sonc44

Serviio newbie

Posts: 6

Joined: Mon Sep 26, 2011 3:10 am

Post Mon Sep 26, 2011 3:45 am

Re: YouTube

The below will show the Channels 5 public uploads

http://gdata.youtube.com/feeds/api/user ... be-profile
<<

sucka_punch

Streaming enthusiast

Posts: 21

Joined: Sun Mar 27, 2011 9:31 am

Location: Suedtirol

Post Mon Sep 26, 2011 11:00 am

Re: YouTube

Does the videos automatically refresh?

I set the video expiry interval to 6 hours. But there are still the same videos in the feed as yesterday even if there should be some new available.

Thanks in advance.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16475

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Sep 26, 2011 11:49 am

Re: YouTube

serviio refreshes it. if the feed XML stays the same, I don't know, you can try opening it in a browser and compare the feed contents to what is on the website itself
Next

Return to Available plugins

Who is online

Users browsing this forum: No registered users and 4 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.