FAQ  •  Register  •  Login

Vimeo

<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16744

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Jan 05, 2012 8:48 pm

Vimeo

Requires at least Serviio 0.6.1

Added 5/1/2012
Minor fix 6/1/2012
Fixed playback of videos without HD content 18/1/2012
Fixed the plugin (v2) 28/12/2012
Fixed the plugin (v3) 17/10/2014
Fixed the plugin (v4) 10/12/2015 (needs FFmpeg with SSH support)
Attachments
Vimeo.groovy
(2.88 KiB) Downloaded 582 times
<<

jstahl

Serviio newbie

Posts: 9

Joined: Fri Jan 06, 2012 4:43 pm

Post Fri Jan 06, 2012 4:47 pm

Re: Vimeo

I have this groovy installed.

Running 0.6.1 on osx.

Trying vimeo rss video feed: http://vimeo.com/user4577902/videos/rss

No content appear in that online folder.

Console reports:
  Code:
2012-01-06 11:33:24,107 WARN  [FeedUpdaterThread] Failed to retrieve online item information for http://vimeo.com/moogaloop/play/clip:6/36db8b084548947bfa848f23e38b7c15/1325867601/?q=hd. It might not play.
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:272)
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveTechnicalMetadata(FeedUpdaterThread.java:208)
   at org.serviio.library.online.metadata.FeedUpdaterThread.run(FeedUpdaterThread.java:101)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.metadata.FFmpegMetadataRetriever.validateCodecsFound(FFmpegMetadataRetriever.java:344)
   at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:87)
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:254)
   ... 2 more
2012-01-06 11:37:25,259 WARN  [ProcessExecutor] Process /Applications/Serviio.app/Contents/Resources/Java/../../MacOS/ffmpeg has a return code of 137! This is a possible error.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16744

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Jan 06, 2012 5:13 pm

Re: Vimeo

Check if there is this message in your log: Could not work out FFmpeg default User-Agent

Otherwise post ffmpeg -version
<<

jstahl

Serviio newbie

Posts: 9

Joined: Fri Jan 06, 2012 4:43 pm

Post Fri Jan 06, 2012 5:32 pm

Re: Vimeo

Didn't see that warning in the log.

./ffmpeg -version
ffmpeg version 0.9, Copyright (c) 2000-2011 the FFmpeg developers
built on Dec 14 2011 01:44:37 with gcc 4.0.1 (Apple Inc. build 5493)
configuration: --enable-static --disable-shared --bindir=/tmp/ffmpeg --disable-ffplay --disable-ffserver --enable-libmp3lame --enable-librtmp --enable-pthreads --disable-mmx --extra-ldflags=-L/tmp/static/lib --extra-cflags=-I/tmp/static/include --extra-libs=-lpolarssl
libavutil 51. 32. 0 / 51. 32. 0
libavcodec 53. 42. 0 / 53. 42. 0
libavformat 53. 24. 0 / 53. 24. 0
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 53. 0 / 2. 53. 0
libswscale 2. 1. 0 / 2. 1. 0
ffmpeg 0.9
libavutil 51. 32. 0 / 51. 32. 0
libavcodec 53. 42. 0 / 53. 42. 0
libavformat 53. 24. 0 / 53. 24. 0
libavdevice 53. 4. 0 / 53. 4. 0
libavfilter 2. 53. 0 / 2. 53. 0
libswscale 2. 1. 0 / 2. 1. 0
<<

jstahl

Serviio newbie

Posts: 9

Joined: Fri Jan 06, 2012 4:43 pm

Post Fri Jan 06, 2012 6:21 pm

Re: Vimeo

It looks like the groovy isn't generating the correct videoid.

2012-01-06 12:48:42,925 WARN [FeedUpdaterThread] Failed to retrieve online item information for http://vimeo.com/moogaloop/play/clip:2/ ... 2122/?q=hd. It might not play.


I don't think the videoID is 2 in this test case.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16744

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Jan 06, 2012 9:28 pm

Re: Vimeo

I updated the groovy, install it and try again
<<

jstahl

Serviio newbie

Posts: 9

Joined: Fri Jan 06, 2012 4:43 pm

Post Fri Jan 06, 2012 10:11 pm

Re: Vimeo

Something similar:

Added a RSS feed : http://vimeo.com/revtest/videos/rss
Directory still shows no content.
Console details below

  Code:
2012-01-06 17:00:40,367 INFO  [PluginCompilerThread] Added Feed plugin Vimeo (Vimeo.groovy)
2012-01-06 17:06:02,947 INFO  [LibraryAdditionsCheckerThread] Finished looking for newly added files
2012-01-06 17:06:03,048 INFO  [LibraryUpdatesCheckerThread] Finished looking for updates to currently shared files
2012-01-06 17:06:03,158 INFO  [LibraryAdditionsCheckerThread] Started looking for newly added files
2012-01-06 17:06:03,160 INFO  [LibraryUpdatesCheckerThread] Started looking for updates to currently shared files
2012-01-06 17:06:04,702 WARN  [FeedUpdaterThread] Failed to retrieve online item information for http://vimeo.com/moogaloop/play/clip:34601202/6d94847edab8c02074f75f9b97920801/1325887563/?q=hd. It might not play.
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:272)
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveTechnicalMetadata(FeedUpdaterThread.java:208)
   at org.serviio.library.online.metadata.FeedUpdaterThread.run(FeedUpdaterThread.java:101)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.metadata.FFmpegMetadataRetriever.validateCodecsFound(FFmpegMetadataRetriever.java:344)
   at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:87)
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:254)
   ... 2 more
2012-01-06 17:06:04,914 WARN  [FeedUpdaterThread] Failed to retrieve online item information for http://vimeo.com/moogaloop/play/clip:34543679/06f9181124b2e8bc36ea8982995eac45/1325887563/?q=hd. It might not play.
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:272)
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveTechnicalMetadata(FeedUpdaterThread.java:208)
   at org.serviio.library.online.metadata.FeedUpdaterThread.run(FeedUpdaterThread.java:101)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.metadata.FFmpegMetadataRetriever.validateCodecsFound(FFmpegMetadataRetriever.java:344)
   at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:87)
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:254)
   ... 2 more
2012-01-06 17:06:05,073 WARN  [FeedUpdaterThread] Failed to retrieve online item information for http://vimeo.com/moogaloop/play/clip:26289832/259fe77efbb8d341782e87ee2fa2ab1e/1325887563/?q=hd. It might not play.
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:272)
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveTechnicalMetadata(FeedUpdaterThread.java:208)
   at org.serviio.library.online.metadata.FeedUpdaterThread.run(FeedUpdaterThread.java:101)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.metadata.FFmpegMetadataRetriever.validateCodecsFound(FFmpegMetadataRetriever.java:344)
   at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:87)
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:254)
   ... 2 more
2012-01-06 17:06:05,233 WARN  [FeedUpdaterThread] Failed to retrieve online item information for http://vimeo.com/moogaloop/play/clip:25877371/d5963ca2c0fb7307207c3d700d01f737/1325887564/?q=hd. It might not play.
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:272)
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveTechnicalMetadata(FeedUpdaterThread.java:208)
   at org.serviio.library.online.metadata.FeedUpdaterThread.run(FeedUpdaterThread.java:101)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.metadata.FFmpegMetadataRetriever.validateCodecsFound(FFmpegMetadataRetriever.java:344)
   at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:87)
   at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:254)
   ... 2 more
 
<<

jstahl

Serviio newbie

Posts: 9

Joined: Fri Jan 06, 2012 4:43 pm

Post Fri Jan 06, 2012 10:38 pm

Re: Vimeo

Actually some videos are working now from vimeo.
I think the problem now lies with the videos that are a different ratio. (tall, not wide)
such as this video.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16744

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Jan 06, 2012 11:08 pm

Re: Vimeo

ffmpeg works ok for this one..

try replacing this line in the plugin

  Code:
def videoXmlDetails = openURL(new URL("http://vimeo.com/moogaloop/load/clip:$videoId"), getFFmpegUserAgent())


with

  Code:
def videoXmlDetails = openURL(new URL("http://vimeo.com/moogaloop/load/clip:$videoId"), "Lavf53.24.0")
<<

jstahl

Serviio newbie

Posts: 9

Joined: Fri Jan 06, 2012 4:43 pm

Post Sat Jan 07, 2012 2:22 pm

Re: Vimeo

Hi Zip,
Didn't seem to make a difference.
All the 'tall' video content does not seem to get indexed as content.
Do you think this is an issue with ffmpeg for osx?
Thanks for the help.
<<

BDM

Streaming enthusiast

Posts: 23

Joined: Tue Dec 27, 2011 10:16 am

Post Sat Jan 07, 2012 3:38 pm

Re: Vimeo

Hi Zip,

Installed 0.6.1 and the latest plugins. Alle feeds from VIMEO are showing on Viera but nn of the video's can be played! Something to do with transcoding?
For gear and settings see sign.

Cheers!
Panasonic Viera TX-P54Z1 (2.403) WIRED - Profile: "Toshiba REGZA" | Play Station 3 (4.0) WIRELESS - Profile: "Playstation 3" | OSX LION (10.7.2) | Serviio (0.6.1)
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16744

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Jan 07, 2012 5:53 pm

Re: Vimeo

jstahl wrote:Hi Zip,
Didn't seem to make a difference.
All the 'tall' video content does not seem to get indexed as content.
Do you think this is an issue with ffmpeg for osx?
Thanks for the help.

try to run

  Code:
ffmpeg -i "video_url_from_serviio_log"


Use he ffmpeg from Serviio.app bundle.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16744

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Jan 07, 2012 5:54 pm

Re: Vimeo

BDM wrote:Hi Zip,

Installed 0.6.1 and the latest plugins. Alle feeds from VIMEO are showing on Viera but nn of the video's can be played! Something to do with transcoding?
For gear and settings see sign.

Cheers!

Post detailed log. What message are you getting?
<<

BDM

Streaming enthusiast

Posts: 23

Joined: Tue Dec 27, 2011 10:16 am

Post Sun Jan 08, 2012 11:12 am

Re: Vimeo

zip wrote:
BDM wrote:Hi Zip,

Installed 0.6.1 and the latest plugins. Alle feeds from VIMEO are showing on Viera but nn of the video's can be played! Something to do with transcoding?
For gear and settings see sign.

Cheers!

Post detailed log. What message are you getting?


Hi ZIP, Thanks for your reply! The movies on Vimeo are mostly .MOV or .MP4 which the server "cannot read file". All files show up in the listing and the thumbs are made too.
While all other LOCAL .MOV and .MP4 can be read.
Using the DirecTV HD profile.

Cheers!
Panasonic Viera TX-P54Z1 (2.403) WIRED - Profile: "Toshiba REGZA" | Play Station 3 (4.0) WIRELESS - Profile: "Playstation 3" | OSX LION (10.7.2) | Serviio (0.6.1)
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16744

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Jan 08, 2012 1:59 pm

Re: Vimeo

Why not the Viera plugin?
<<

BDM

Streaming enthusiast

Posts: 23

Joined: Tue Dec 27, 2011 10:16 am

Post Mon Jan 09, 2012 9:52 am

Re: Vimeo

zip wrote:Why not the Viera plugin?


Hi Zip,

The Viera plugin is not working for my gear. No .MOV / .FLV are transcoded with it.
Or am I doing something wrong here?

Cheers!
Panasonic Viera TX-P54Z1 (2.403) WIRED - Profile: "Toshiba REGZA" | Play Station 3 (4.0) WIRELESS - Profile: "Playstation 3" | OSX LION (10.7.2) | Serviio (0.6.1)
<<

JUser

Serviio newbie

Posts: 8

Joined: Mon Jan 09, 2012 10:19 am

Post Mon Jan 09, 2012 10:45 am

Re: Vimeo

Have downloaded Servio 0.6.1
For Vimeo, I have noticed the following : added rss feeds
http://vimeo.com/channels/streoscopy/videos/rss
and
http://Vimeo.com/channels/hd/videos/rss

The above URL works ; I can see in my Sony TV ,all the videos list and play them also.

But many other channels are not working.

For example
http://vimeo.com/channels/saisouljourns/videos/rss

though this is folder is visible, but could not see any contents.
Could you please compare this rss feed and working rss feed (mentioned above hd or streoscopy), and fix it ? Thanks
<<

JUser

Serviio newbie

Posts: 8

Joined: Mon Jan 09, 2012 10:19 am

Post Mon Jan 09, 2012 10:58 am

Re: Vimeo

Hello Zip

in my query submitted few minutes back,,

there is a typo:
The Correct URL is
http://vimeo.com/channels/stereoscopy/videos/rss

and not streoscopy" as mentioned in my post.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16744

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Jan 09, 2012 8:45 pm

Re: Vimeo

works for me. are there any errors in your log?
<<

JUser

Serviio newbie

Posts: 8

Joined: Mon Jan 09, 2012 10:19 am

Post Tue Jan 10, 2012 2:23 am

Some Vimeo channels are not playing

Thanks Zip for your response.
This is regarding Vimeo Plugin for the folllowing rss feed:
http://vimeo.com/channels/saisouljourns/videos/rss

I am able to see the folder in my Sony TV but folder is empty. I am using Windows XP version of Serviio.
Is this problem due to slow internet connection? May be some channels like "stereoscopy" or "hd are retrieved immediately so that their contents appear and the channel like "saisouljourns" respond a bit slow causing this problem?


I am pasting excerpts of the log as follows:

2012-01-10 07:00:24,484 WARN [FeedUpdaterThread] Failed to retrieve online item information for http://vimeo.com/moogaloop/play/clip:33 ... 8992/?q=hd. It might not play.
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:272)
at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveTechnicalMetadata(FeedUpdaterThread.java:208)
at org.serviio.library.online.metadata.FeedUpdaterThread.run(FeedUpdaterThread.java:101)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
at org.serviio.library.metadata.FFmpegMetadataRetriever.validateCodecsFound(FFmpegMetadataRetriever.java:344)
at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:87)
at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:254)
... 2 more
2012-01-10 07:00:27,078 WARN [FeedUpdaterThread] Failed to retrieve online item information for http://vimeo.com/moogaloop/play/clip:33 ... 8993/?q=hd. It might not play.
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:272)
at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveTechnicalMetadata(FeedUpdaterThread.java:208)
at org.serviio.library.online.metadata.FeedUpdaterThread.run(FeedUpdaterThread.java:101)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
at org.serviio.library.metadata.FFmpegMetadataRetriever.validateCodecsFound(FFmpegMetadataRetriever.java:344)
at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:87)
at org.serviio.library.online.metadata.FeedUpdaterThread.retrieveAVMetadata(FeedUpdaterThread.java:254)
Next

Return to Available plugins

Who is online

Users browsing this forum: No registered users and 5 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.