FAQ  •  Register  •  Login

mp4 no playback

<<

pactwo11

Serviio newbie

Posts: 7

Joined: Tue Jul 24, 2012 3:32 pm

Post Sat Mar 09, 2013 11:50 am

mp4 no playback

Since I installed the new serviio on my pc the mp4 files that before used to play are not playing anymore on my vl863 I get media playback error....Do I need some kind of codec?? Thanks
<<

pteeson

Streaming enthusiast

Posts: 38

Joined: Mon Sep 19, 2011 6:29 pm

Location: Toronto, Canada

Post Sun Mar 10, 2013 10:12 pm

Re: mp4 no playback

I have a similar problem. The duration of the .m4v movies is 00:00:00 for all of them although the titles and folders are listed correctly.
Version 1.1 works fine. Version 1.2 has the same path's and I've tried refreshing the library. No effect.

My TV is a Toshiba REGZA 55SL500U and the device shows up in the status page. My computer is a Mac Pro Desktop 4,1 ( early 2009) running Lion 10.7.5
Mac Pro OS X Yosemite, Toshiba 55SL500U
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16480

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Mar 11, 2013 5:16 pm

Re: mp4 no playback

can you post ffmpeg -i of the affected files that don't play in 1.2 and play in 1.1 ?
<<

slickric

Serviio newbie

Posts: 3

Joined: Mon Mar 11, 2013 9:38 pm

Post Mon Mar 11, 2013 9:42 pm

Re: mp4 no playback

Hi, I have the same issue with my Toshiba Regza m4v file report no playback since moving to Serviio 1.2. I can run the same files through my XBox though.

I ran ffmeg -i, results are below, hope it helps.

C:\Program Files\Serviio\lib>ffmpeg.exe -i "F:\DE\shares\Videos\f-iron.lady.720-
1.m4v"
ffmpeg version 1.1.1 Copyright (c) 2000-2013 the FFmpeg developers
built on Feb 5 2013 21:59:54 with gcc 4.7.2 (GCC)
configuration: --enable-static --disable-shared --disable-ffplay --disable-ffs
erver --enable-memalign-hack --enable-libmp3lame --enable-libass --enable-librtm
p --enable-fontconfig --enable-libfreetype --enable-zlib --extra-libs='-lrtmp -l
polarssl -lws2_32 -lwinmm -lexpat -lfreetype -lfribidi -lz' --arch=x86 --enable-
runtime-cpudetect --enable-pthreads --target-os=mingw32 --cross-prefix=i686-w64-
mingw32- --pkg-config=pkg-config
libavutil 52. 13.100 / 52. 13.100
libavcodec 54. 86.100 / 54. 86.100
libavformat 54. 59.106 / 54. 59.106
libavdevice 54. 3.102 / 54. 3.102
libavfilter 3. 32.100 / 3. 32.100
libswscale 2. 1.103 / 2. 1.103
libswresample 0. 17.102 / 0. 17.102
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'F:\DE\shares\Videos\f-iron.lady.720-1.m
4v':
Metadata:
major_brand : mp42
minor_version : 0
compatible_brands: mp42isomavc1
creation_time : 2012-05-08 02:41:24
encoder : HandBrake 0.9.5 2011010300
Duration: 01:44:58.35, start: 0.000000, bitrate: 1309 kb/s
Stream #0:0(und): Video: h264 (Main) (avc1 / 0x31637661), yuv420p, 1280x544
[SAR 1:1 DAR 40:17], 1144 kb/s, 23.98 fps, 23.98 tbr, 90k tbn, 180k tbc
Metadata:
creation_time : 2012-05-08 02:41:24
Stream #0:1(eng): Audio: aac (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 15
9 kb/s
Metadata:
creation_time : 2012-05-08 02:41:24
<<

slickric

Serviio newbie

Posts: 3

Joined: Mon Mar 11, 2013 9:38 pm

Post Mon Mar 11, 2013 9:44 pm

Re: mp4 no playback

When I was running 1.1 I made a backup of the profiles.xml but applying a new profile with the old settings also fails.

Thanks
<<

slickric

Serviio newbie

Posts: 3

Joined: Mon Mar 11, 2013 9:38 pm

Post Mon Mar 11, 2013 9:58 pm

Re: mp4 no playback

When I add the old Regza profile to the profiles.xml there is a difference, I now see the file duration whereas using the standard profile I don't. I still receive "Media Playback Error" though.

TV is a Regza 32RV753

Below is the old profile.

<Profile id="13" name="Toshiba REGZA 2" extendsProfileId="1">
<Transcoding>
<Video targetContainer="mpeg" targetACodec="ac3" targetVCodec="mpeg2video">
<Matches container="mp4" />
<Matches container="avi" />
<Matches container="mpegts" />
<Matches container="mpegvideo" />
<Matches container="asf" />
<Matches container="ogg" />
<Matches container="flv" />
<Matches container="3gp" />
<!-- if audio different to ac3, must be transcoded -->
<Matches container="mpeg" aCodec="aac" />
<Matches container="mpeg" aCodec="mp3" />
<Matches container="mpeg" aCodec="dca" />
</Video>
<Video targetContainer="mpegts" targetACodec="ac3" targetVCodec="mpeg2video">
<Matches container="matroska" />
</Video>
<Audio targetContainer="mp3">
<Matches container="mp4" />
<Matches container="flac" />
<Matches container="ogg" />
<Matches container="asf" />
</Audio>
</Transcoding>
<OnlineTranscoding>
<Video targetContainer="mpeg" targetVCodec="mpeg2video" targetACodec="ac3">
<Matches container="mp4" />
<Matches container="flv" />
</Video>
</OnlineTranscoding>
</Profile>
<<

pteeson

Streaming enthusiast

Posts: 38

Joined: Mon Sep 19, 2011 6:29 pm

Location: Toronto, Canada

Post Mon Mar 11, 2013 10:18 pm

Re: mp4 no playback

It seems there is no ffmpeg per se on my Mac. There is this

/usr/share/zsh/4.3.11/functions pteeson$ ls -al _ff*
-rw-r--r-- 1 root wheel 5278 24 Jul 2011 _ffmpeg

I am not able to run that command (no x permission).
I guess I could download it from somewhere but am a bit reluctant.


But all of my m4v files were made with HandBrake most recently version 0.9.8 x86_64

Anything else I can do to help?

Peter
Mac Pro OS X Yosemite, Toshiba 55SL500U
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16480

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Mar 11, 2013 11:07 pm

Re: mp4 no playback

try to remove this in the profile:

  Code:
<Video targetContainer="mpegts" targetACodec="ac3">
            <Matches container="*" vCodec="h264" />
         </Video>
<<

pteeson

Streaming enthusiast

Posts: 38

Joined: Mon Sep 19, 2011 6:29 pm

Location: Toronto, Canada

Post Tue Mar 12, 2013 2:11 am

Re: mp4 no playback

Are you responding to my post?
If so to which profile are you referring? HandBrake or Serviio?
There are profiles for HandBrake and it's been working just fine since I started using Serviio.
At present I have reverted to 1.1.

Peter
Mac Pro OS X Yosemite, Toshiba 55SL500U
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16480

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Mar 12, 2013 7:36 pm

Re: mp4 no playback

from the Regza Serviio profile in 1.2
<<

pteeson

Streaming enthusiast

Posts: 38

Joined: Mon Sep 19, 2011 6:29 pm

Location: Toronto, Canada

Post Tue Mar 12, 2013 9:19 pm

Re: mp4 no playback

After I figured out where the profiles.xml file was hidden (On my Mac - Serviio server Show package Contents Resources/Java/Config) and commented out those two lines now the durations show up and the video plays. So far so good. Thanks. Peter.
Mac Pro OS X Yosemite, Toshiba 55SL500U
<<

pactwo11

Serviio newbie

Posts: 7

Joined: Tue Jul 24, 2012 3:32 pm

Post Thu Mar 14, 2013 5:00 am

Re: mp4 no playback

zip wrote:try to remove this in the profile:

  Code:
<Video targetContainer="mpegts" targetACodec="ac3">
            <Matches container="*" vCodec="h264" />
         </Video>


Sorry but from where can I access this file please? Thanks
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16480

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Mar 16, 2013 11:51 am

Re: mp4 no playback

http://www.serviio.org/index.php?option ... icle&id=16

Find the Toshiba profile in the file and edit it using a text editor (e.g. notepad, NOT MS Word/WordPad)
<<

allmac

Streaming enthusiast

Posts: 20

Joined: Wed May 08, 2013 9:33 pm

Post Wed May 08, 2013 9:36 pm

Re: mp4 no playback

Same problem... MP4 files not playing in my LG TV, and hard to play in my Samsung Tv.
It was not happening before update.
<<

allmac

Streaming enthusiast

Posts: 20

Joined: Wed May 08, 2013 9:33 pm

Post Wed May 08, 2013 9:44 pm

Re: mp4 no playback

Ops!! AVI files too. And they were all working with old Serviio version.
<<

allmac

Streaming enthusiast

Posts: 20

Joined: Wed May 08, 2013 9:33 pm

Post Wed May 08, 2013 10:23 pm

Re: mp4 no playback

2013-05-08 19:13:59,152 ERROR [ActionNode] Cannot retrieve results of action command: Cannot execute library command for single item: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
org.serviio.upnp.service.contentdirectory.command.CommandExecutionException: Cannot execute library command for single item: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItem(AbstractCommand.java:153)
at org.serviio.upnp.service.contentdirectory.definition.ActionNode.executeRetrieveItemAction(ActionNode.java:179)
at org.serviio.upnp.service.contentdirectory.definition.ActionNode.retrieveDirectoryObject(ActionNode.java:82)
at org.serviio.upnp.service.contentdirectory.ContentDirectoryEngine.browse(ContentDirectoryEngine.java:105)
at org.serviio.upnp.service.contentdirectory.ContentDirectory.Browse(ContentDirectory.java:152)
at sun.reflect.GeneratedMethodAccessor191.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeOperation(ServiceInvoker.java:253)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeService(ServiceInvoker.java:93)
at org.serviio.upnp.webserver.ServiceControlRequestHandler.handleRequest(ServiceControlRequestHandler.java:66)
at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:61)
at org.apache.http.protocol.HttpService.doService(HttpService.java:293)
at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:77)
at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:212)
at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:192)
Caused by: java.lang.NumberFormatException: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
at java.lang.Long.parseLong(Long.java:419)
at java.lang.Long.parseLong(Long.java:468)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.getFolderId(AbstractListObjectsByFSHierarchyCommand.java:224)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.retrieveSingleItem(AbstractListObjectsByFSHierarchyCommand.java:166)
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItem(AbstractCommand.java:148)
... 15 more
2013-05-08 19:17:38,702 ERROR [ActionNode] Cannot retrieve results of action command: Cannot execute library command for single item: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
org.serviio.upnp.service.contentdirectory.command.CommandExecutionException: Cannot execute library command for single item: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItem(AbstractCommand.java:153)
at org.serviio.upnp.service.contentdirectory.definition.ActionNode.executeRetrieveItemAction(ActionNode.java:179)
at org.serviio.upnp.service.contentdirectory.definition.ActionNode.retrieveDirectoryObject(ActionNode.java:82)
at org.serviio.upnp.service.contentdirectory.ContentDirectoryEngine.browse(ContentDirectoryEngine.java:105)
at org.serviio.upnp.service.contentdirectory.ContentDirectory.Browse(ContentDirectory.java:152)
at sun.reflect.GeneratedMethodAccessor191.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeOperation(ServiceInvoker.java:253)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeService(ServiceInvoker.java:93)
at org.serviio.upnp.webserver.ServiceControlRequestHandler.handleRequest(ServiceControlRequestHandler.java:66)
at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:61)
at org.apache.http.protocol.HttpService.doService(HttpService.java:293)
at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:77)
at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:212)
at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:192)
Caused by: java.lang.NumberFormatException: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
at java.lang.Long.parseLong(Long.java:419)
at java.lang.Long.parseLong(Long.java:468)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.getFolderId(AbstractListObjectsByFSHierarchyCommand.java:224)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.retrieveSingleItem(AbstractListObjectsByFSHierarchyCommand.java:166)
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItem(AbstractCommand.java:148)
... 15 more
2013-05-08 19:17:38,726 ERROR [ActionNode] Cannot retrieve results of action command: Cannot execute library command for single item: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
org.serviio.upnp.service.contentdirectory.command.CommandExecutionException: Cannot execute library command for single item: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItem(AbstractCommand.java:153)
at org.serviio.upnp.service.contentdirectory.definition.ActionNode.executeRetrieveItemAction(ActionNode.java:179)
at org.serviio.upnp.service.contentdirectory.definition.ActionNode.retrieveDirectoryObject(ActionNode.java:82)
at org.serviio.upnp.service.contentdirectory.ContentDirectoryEngine.browse(ContentDirectoryEngine.java:105)
at org.serviio.upnp.service.contentdirectory.ContentDirectory.Browse(ContentDirectory.java:152)
at sun.reflect.GeneratedMethodAccessor191.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeOperation(ServiceInvoker.java:253)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeService(ServiceInvoker.java:93)
at org.serviio.upnp.webserver.ServiceControlRequestHandler.handleRequest(ServiceControlRequestHandler.java:66)
at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:61)
at org.apache.http.protocol.HttpService.doService(HttpService.java:293)
at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:77)
at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:212)
at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:192)
Caused by: java.lang.NumberFormatException: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
at java.lang.Long.parseLong(Long.java:419)
at java.lang.Long.parseLong(Long.java:468)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.getFolderId(AbstractListObjectsByFSHierarchyCommand.java:224)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.retrieveSingleItem(AbstractListObjectsByFSHierarchyCommand.java:166)
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItem(AbstractCommand.java:148)
... 15 more
2013-05-08 19:18:39,223 ERROR [ResourceTransportRequestHandler] Error while processing resource, sending back 500 error. Message: Transcoded file '/Users/minitv/TEMP Transcode/Serviio/transcoding-temp-2309-1-ORIGINAL-239431c1cecfa34fe366b3a938ddd872.stf' cannot be found, FFmpeg execution probably failed
java.io.IOException: Transcoded file '/Users/minitv/TEMP Transcode/Serviio/transcoding-temp-2309-1-ORIGINAL-239431c1cecfa34fe366b3a938ddd872.stf' cannot be found, FFmpeg execution probably failed
at org.serviio.delivery.resource.transcode.FileBasedTranscodingDeliveryStrategy.createInputStream(FileBasedTranscodingDeliveryStrategy.java:45)
at org.serviio.delivery.resource.transcode.AbstractTranscodingDeliveryEngine.retrieveTranscodedResource(AbstractTranscodingDeliveryEngine.java:131)
at org.serviio.delivery.resource.AbstractDeliveryEngine.deliver(AbstractDeliveryEngine.java:108)
at org.serviio.delivery.MediaResourceRetrievalStrategy.retrieveResource(MediaResourceRetrievalStrategy.java:120)
at org.serviio.delivery.GETMethodProcessor.retrieveResource(GETMethodProcessor.java:120)
at org.serviio.delivery.GETMethodProcessor.buildDeliveryContainer(GETMethodProcessor.java:48)
at org.serviio.delivery.AbstractMethodProcessor.handleRequest(AbstractMethodProcessor.java:132)
at org.serviio.delivery.ResourceDeliveryProcessor.deliverContent(ResourceDeliveryProcessor.java:80)
at org.serviio.upnp.webserver.ResourceTransportRequestHandler.handleRequest(ResourceTransportRequestHandler.java:85)
at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:61)
at org.apache.http.protocol.HttpService.doService(HttpService.java:293)
at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:77)
at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:212)
at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:192)
2013-05-08 19:18:41,307 ERROR [ResourceTransportRequestHandler] Error while processing resource, sending back 500 error. Message: Transcoded file '/Users/minitv/TEMP Transcode/Serviio/transcoding-temp-2309-1-ORIGINAL-239431c1cecfa34fe366b3a938ddd872.stf' cannot be found, FFmpeg execution probably failed
java.io.IOException: Transcoded file '/Users/minitv/TEMP Transcode/Serviio/transcoding-temp-2309-1-ORIGINAL-239431c1cecfa34fe366b3a938ddd872.stf' cannot be found, FFmpeg execution probably failed
at org.serviio.delivery.resource.transcode.FileBasedTranscodingDeliveryStrategy.createInputStream(FileBasedTranscodingDeliveryStrategy.java:45)
at org.serviio.delivery.resource.transcode.AbstractTranscodingDeliveryEngine.retrieveTranscodedResource(AbstractTranscodingDeliveryEngine.java:131)
at org.serviio.delivery.resource.AbstractDeliveryEngine.deliver(AbstractDeliveryEngine.java:108)
at org.serviio.delivery.MediaResourceRetrievalStrategy.retrieveResource(MediaResourceRetrievalStrategy.java:120)
at org.serviio.delivery.GETMethodProcessor.retrieveResource(GETMethodProcessor.java:120)
at org.serviio.delivery.GETMethodProcessor.buildDeliveryContainer(GETMethodProcessor.java:48)
at org.serviio.delivery.AbstractMethodProcessor.handleRequest(AbstractMethodProcessor.java:132)
at org.serviio.delivery.ResourceDeliveryProcessor.deliverContent(ResourceDeliveryProcessor.java:80)
at org.serviio.upnp.webserver.ResourceTransportRequestHandler.handleRequest(ResourceTransportRequestHandler.java:85)
at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:61)
at org.apache.http.protocol.HttpService.doService(HttpService.java:293)
at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:77)
at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:212)
at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:192)
2013-05-08 19:19:02,573 INFO [DiscoveryAdvertisementNotifier] Leaving DiscoveryAdvertisementNotifier
2013-05-08 19:19:02,573 INFO [WebServer] WebServer shutting down
2013-05-08 19:19:02,574 INFO [DiscoverySSDPMessageListener] Leaving DiscoverySSDPMessageListener
2013-05-08 19:19:02,574 INFO [EventSubscriptionExpirationChecker] Leaving EventSubscriptionExpirationChecker, removing all event subscriptions
2013-05-08 19:19:02,574 INFO [EventDispatcher] Leaving EventDispatcher
2013-05-08 19:19:02,577 INFO [WebServer] WebServer starting on port 8895
2013-05-08 19:19:02,579 INFO [EventSubscriptionExpirationChecker] Starting EventSubscriptionExpirationChecker
2013-05-08 19:19:02,580 INFO [DiscoverySSDPMessageListener] Starting DiscoverySSDPMessageListener using interface en0 (en0) and address 192.168.25.100, timeout = 0
2013-05-08 19:19:02,580 INFO [EventDispatcher] Starting EventDispatcher
2013-05-08 19:19:02,583 INFO [DiscoveryAdvertisementNotifier] Starting DiscoveryAdvertisementNotifier
2013-05-08 19:19:02,588 INFO [RendererSearchSender] Searching for Renderer devices
2013-05-08 19:19:03,235 INFO [RendererManager] Stored a new renderer: uuid='ca979ce7-11e4-4433-9bee-561f54eb0ee2', name = 'LG TV / player', ipAddress='192.168.25.4', profile = '8'
2013-05-08 19:19:16,614 ERROR [ActionNode] Cannot retrieve results of action command: Cannot execute library command for single item: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
org.serviio.upnp.service.contentdirectory.command.CommandExecutionException: Cannot execute library command for single item: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItem(AbstractCommand.java:153)
at org.serviio.upnp.service.contentdirectory.definition.ActionNode.executeRetrieveItemAction(ActionNode.java:179)
at org.serviio.upnp.service.contentdirectory.definition.ActionNode.retrieveDirectoryObject(ActionNode.java:82)
at org.serviio.upnp.service.contentdirectory.ContentDirectoryEngine.browse(ContentDirectoryEngine.java:105)
at org.serviio.upnp.service.contentdirectory.ContentDirectory.Browse(ContentDirectory.java:152)
at sun.reflect.GeneratedMethodAccessor191.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeOperation(ServiceInvoker.java:253)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeService(ServiceInvoker.java:93)
at org.serviio.upnp.webserver.ServiceControlRequestHandler.handleRequest(ServiceControlRequestHandler.java:66)
at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:61)
at org.apache.http.protocol.HttpService.doService(HttpService.java:293)
at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:77)
at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:212)
at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:192)
Caused by: java.lang.NumberFormatException: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
at java.lang.Long.parseLong(Long.java:419)
at java.lang.Long.parseLong(Long.java:468)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.getFolderId(AbstractListObjectsByFSHierarchyCommand.java:224)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.retrieveSingleItem(AbstractListObjectsByFSHierarchyCommand.java:166)
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItem(AbstractCommand.java:148)
... 15 more
2013-05-08 19:19:16,636 ERROR [ActionNode] Cannot retrieve results of action command: Cannot execute library command for single item: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
org.serviio.upnp.service.contentdirectory.command.CommandExecutionException: Cannot execute library command for single item: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItem(AbstractCommand.java:153)
at org.serviio.upnp.service.contentdirectory.definition.ActionNode.executeRetrieveItemAction(ActionNode.java:179)
at org.serviio.upnp.service.contentdirectory.definition.ActionNode.retrieveDirectoryObject(ActionNode.java:82)
at org.serviio.upnp.service.contentdirectory.ContentDirectoryEngine.browse(ContentDirectoryEngine.java:105)
at org.serviio.upnp.service.contentdirectory.ContentDirectory.Browse(ContentDirectory.java:152)
at sun.reflect.GeneratedMethodAccessor191.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeOperation(ServiceInvoker.java:253)
at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeService(ServiceInvoker.java:93)
at org.serviio.upnp.webserver.ServiceControlRequestHandler.handleRequest(ServiceControlRequestHandler.java:66)
at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:61)
at org.apache.http.protocol.HttpService.doService(HttpService.java:293)
at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:77)
at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:212)
at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:192)
Caused by: java.lang.NumberFormatException: For input string: "400/Tsurube No Kazoku Ni Kanpai Yae No Sakura SP - 2013.01.14.H264.378p.mkv"
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
at java.lang.Long.parseLong(Long.java:419)
at java.lang.Long.parseLong(Long.java:468)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.getFolderId(AbstractListObjectsByFSHierarchyCommand.java:224)
at org.serviio.upnp.service.contentdirectory.command.AbstractListObjectsByFSHierarchyCommand.retrieveSingleItem(AbstractListObjectsByFSHierarchyCommand.java:166)
at org.serviio.upnp.service.contentdirectory.command.AbstractCommand.retrieveItem(AbstractCommand.java:148)
... 15 more
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16480

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu May 09, 2013 4:23 pm

Re: mp4 no playback

These error logs are caused by the LG player sending invalid requests, but should not affect playback.

Are you on Windows? Are you using the correct profiles?
<<

pjimmy74

Serviio newbie

Posts: 13

Joined: Wed Jul 17, 2013 3:17 pm

Post Wed Jul 17, 2013 3:30 pm

Re: mp4 no playback

Hello everyone. I'm new to the forum. I started using serviio recently and it seems much better than most of the dlna servers I used (WMP and Mezzmo). One issue I ran into from time to time is that it will play some avi files but not others. It does the same with mkv files too. For one particular mkv file it'll play and stop in the middle of the movie. But the same file will play fine with WMP or mezzmo. I'm not sure what the problem could be. Please help. Also it does play subtitles in some videos but not others. The subs and videos have same name.

Return to Toshiba

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.