FAQ  •  Register  •  Login

Philips 55POS9002 (with synology DS218+)

<<

Meelis

User avatar

Serviio lover

Posts: 50

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Mon Oct 22, 2018 5:29 pm

Philips 55POS9002 (with synology DS218+)

Hello Serviio team,

I have been for years a serviio payd license user and had no problems at all. All works fine. But for now i had to replace my tv and choise was Philips. (maybe it was wrong brand to choice). And seems now came my time to ask for help here... I even don,t know from where to start exactly...

Just a bit about history to get clear picture. I had two Samsung tv's and Synology DS218+ installed. All working fine. Also time by time i used serviio what was installed in laptop before i got NAS. (mostly it turned off and i use it sometimes in hotell while i travel). All ok so fare.

Now i replaced one tv to Philips 55POS9002 and got a problems. Seems like videos from one folder i cant play. All my videos are *.mkv with muxed subtitles. Tv say that unable to open or read file. From serviio console i see that video started actually to play. I was thinking to turn on debug mode but seems i am unable to do because don't know linux so well. I tryed to google and find a guides but no success. Even when i will be enable that i have no idea how to fix it and can copy only here for help. Yes i enabled everything for use Putty program and got access and logged in but on the that point my knowledge ends.

A bit from the folders in NAS:
CARTOONS (no muxed subtitles) working fine. About 20 mkv files.
MOVIES (90% with muxe subtitles) Non of them don't work. About 100+ mkv files.
MOVIES TEST (To this folder i copied one movie from MOVIES folder for testing. Same file with muxed subtitle and separetly second file with subtitle str file) 2 mkv files + sub.srt (still same result and files not working)
MP3 Working perfect.

So i copy for test my MOVIES TEST folder to laptop serviio and can run both files from laptop. Subtitles working only with muxed file in Philips 55POS9002 tv. Separated file subtitles wont work.

Seems like from windows serviio to Philips 55POS9002 in some case it works but not from the nas to Philips 55POS9002. And in the same time when i look nas from second samsung tv all ok with NAS :)

What i can do to fix it? :)
Is there any guide step by step how i can turn on that debugging mode in Synology?
What is the correct profile for this Philips model? (maybe issue in that but i tryed all of them. Still same problem.)
Or some moderator should move my post under Synology topic. :)

I will be glad if someone will can help me step by step go forward with solving the problem.
<<

atc98092

User avatar

DLNA master

Posts: 2836

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Mon Oct 22, 2018 8:24 pm

Re: Philips 55POS9002 (with synology DS218+)

What profile is being assigned in the Serviio console to your TV? There's only a couple of Philips profiles, and perhaps the wrong one is being assigned. You can try different profiles to see what might work. The Generic profile transcodes nothing, so the TV will only play what's supported. The DirecTV profile transcodes virtually everything, and is a good way to see if the files will play that way. Your Synology should have enough power for transcoding. The Roku TV profiles will play most videos without transcoding, but will transcode audio that most TVs can't handle.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

Meelis

User avatar

Serviio lover

Posts: 50

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Mon Oct 22, 2018 9:29 pm

Re: Philips 55POS9002 (with synology DS218+)

Tnx for replay atc98092,

Now i started to try from beginning different profiles and.... 8-) Panasonic Viera (2013) Profile worked for me. I didnt tryed any others more after i found working one. Found small issue in my test folder where is same movie with muxed and separated srt file. With srt file subtitles not work. But thats not problem for me. I am not sure about muxed file subtitles size but maybe they are just a bit smaller then they should be. But anyway tnx a lot man!

Maybe it needs to be created new profile for serviio Philips. If i can help somehow or be useful just feel free to ask.
<<

atc98092

User avatar

DLNA master

Posts: 2836

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Mon Oct 22, 2018 11:22 pm

Re: Philips 55POS9002 (with synology DS218+)

Glad to help! :D
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

Meelis

User avatar

Serviio lover

Posts: 50

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Mon Oct 29, 2018 7:17 pm

Re: Philips 55POS9002 (with synology DS218+)

Hello again,

Seems i celebrating too early... 4K videos don't work at all. I able to run them only with Samsung J series profile. With that profile won't work a HD videos. So i have to swap all the time profiles and that is not all. Something wrong with 4K videos playback. Sound is strange like cutted and video buffering or cuts sometimes as well.
As remark i have to add that i just changed my NAS to bit powerful one. From DS218+ to DS718+. LAN between TV and NAS is 1000 (I am not sure how fast is the tv lan card)
4K movie size for one is 16gb and second one is 36gb. Same problem with both of them.

Can i have more help or correct profile for my tv?
<<

atc98092

User avatar

DLNA master

Posts: 2836

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Mon Oct 29, 2018 8:05 pm

Re: Philips 55POS9002 (with synology DS218+)

Video buffering is usually one of two issues: network speed/connectivity or a server is transcoding and can't keep up. With 4K video, transcoding requires a lot of horsepower. I don't know enough about the abilities of the various NAS products to know if they can handle it. Your set can handle 4K HDR, so transcoding the video shouldn't be necessary. Depending on the profile you are using, it might still be transcoding. Assuming your video has H.265 video, you might only need to transcode audio, as few TVs can handle anything higher than DD+, and most can't take even the standard DTS. But audio transcoding requires very little CPU power. The Roku 4K TV profile will let all H.264 and H.265 video passthough without transcoding, but will transcode any audio that isn't DD. Try that profile to see if your 4K buffering goes away. If it does, we've likely isolated the issue. The J-Series profile does have some matches lines to capture H.264 video with a profile level higher than 4.2, and H.264 4K is likely level 5.1. So that might be the issue. It doesn't appear to have a capture line for H.265, so any 4K material with that codec should't be transcoded.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

Meelis

User avatar

Serviio lover

Posts: 50

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Mon Oct 29, 2018 8:36 pm

Re: Philips 55POS9002 (with synology DS218+)

I tryed all profiles. HD only works with Panasonic Viera and 4K somehow with Samsung J.
<<

atc98092

User avatar

DLNA master

Posts: 2836

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Mon Oct 29, 2018 10:16 pm

Re: Philips 55POS9002 (with synology DS218+)

See my PM to you, and we'll start working on a better profile.

According to the user manual I found online, these are the supported codecs:

Video Codecs : AVI, MKV, H264/MPEG-4 AVC,MPEG-1, MPEG-2, MPEG-4, WMV9/VC1, HEVC
Audio Codecs : AAC, MP3, WAV, WMA (v2 up tov9.2), WMA-PRO (v9 and v10)

Limitations :
Maximum supported total bit rate for a media file is30Mbps
Maximum supported video bit rate for a media file is 20Mbps
MPEG-4 AVC (H.264) is supported up to HighProfile @ L5.1
H.265 (HEVC) is supported upto Main / Main 10Profile up to Level 5.1
VC-1 is supported up to Advanced Profile @ L3

It doesn't identify supported containers, although it does mention MKV in the video line. Based on the codecs listed, I would guess that it supports AVI, MKV, MPG, WMV, MP4 and possibly TS (both .TS and .M2TS). But that's just a guess.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

DenyAll

DLNA master

Posts: 2187

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Tue Oct 30, 2018 2:11 am

Re: Philips 55POS9002 (with synology DS218+)

Meelis wrote:I tryed all profiles. HD only works with Panasonic Viera and 4K somehow with Samsung J.

The Viera profiles will transcode all 4K video (anything where the frame width is greater than 1920 pixels)
The Samsung J profile does not.

Does the Generic Profile also play your 4K video? If so, the simplest answer may be to remove the <Matches container="*" widthGreaterThan="1920" /> from the Viera 2013 profile (and restart your PC). If a better approach is needed, then you will need to provide MediaInfo details of trouble files - starting with a 4K file, and of a couple of MKV files that needs the Viera Profile, in order to go any deeper.
DenyAll
Panasonic Viera FX800A | Panasonic Viera CS610A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.10 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

Meelis

User avatar

Serviio lover

Posts: 50

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Tue Oct 30, 2018 10:58 pm

Re: Philips 55POS9002 (with synology DS218+)

Here is files information....
Generetic profile not working with these videos. Server is Synology DS718+ serviio 1.9.2
HD videos from server works without problems in other Samsung tv. Only in current Philips TV i have a problems. Mostly tv says unable to open or find file when i click on some movie. It starts to load and then failure. But in server i see in that time that video are playing :roll:
I wish i could use debug logger but its linux and without any guide i am unable to do that. I googled and tryed out some guides but these not worked out for me.
Can it be one solution to get debug log if i will use windows pc with philips tv to see what will happent then?
Attachments
ace ventura.png
HD Works only with Panasonic viera 2013 profile normaly.
ace ventura.png (23.74 KiB) Viewed 390 times
john wick 4k.png
4K wont run smoothly, hanging, buffering. Working only with Samsung J series profile.
john wick 4k.png (28.06 KiB) Viewed 390 times
black panther 4k.png
4K wont run smoothly, also sound cutting. Works only with Samsung J series profile.
black panther 4k.png (29.35 KiB) Viewed 390 times
<<

Meelis

User avatar

Serviio lover

Posts: 50

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Tue Oct 30, 2018 11:17 pm

Re: Philips 55POS9002 (with synology DS218+)

I tryed in windows server now Generetic profile for same videos. It play all of them with that profile but 4k have a same issues. Seems it has something to do with NAS system and profiles.
<<

DenyAll

DLNA master

Posts: 2187

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Wed Oct 31, 2018 7:44 am

Re: Philips 55POS9002 (with synology DS218+)

Is the Windows Server version the same version of Serviio (ie.1.9.2)?
On that version do all non-4K files play on the Generic profile?
DenyAll
Panasonic Viera FX800A | Panasonic Viera CS610A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.10 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

Meelis

User avatar

Serviio lover

Posts: 50

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Wed Oct 31, 2018 8:12 am

Re: Philips 55POS9002 (with synology DS218+)

DenyAll wrote:Is the Windows Server version the same version of Serviio (ie.1.9.2)?
On that version do all non-4K files play on the Generic profile?


In windows server is the latest serviio 1.10 version. I have hundreds of files. I tryed some of non 4K files generetic profile and they works. Also 4K was working but with the same problematic issues.
<<

DenyAll

DLNA master

Posts: 2187

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Wed Oct 31, 2018 10:17 am

Re: Philips 55POS9002 (with synology DS218+)

Well here's the thing - if a file plays using the Generic Profile on the Windows box it should also play on the NAS using the Generic Profile (the Generic Profile is simply streaming the file natively, there should be nothing else really happening. Then its only up to your network to transport it - are both your Windows box and NAS wired or wireless?).

There are other settings that can force transcoding, notaby the "Enable burned-in subtitles" setting in Delivery, Subtitles. Make sure that is off on the NAS in particular.

On the Windows box does the Samsung J profile fix the playback of 4K files as it did on the NAS? I'm struggling to see why it is impacting at all - the profile hasnt anything that affects hevc files. It should therefore do exactly as the generic Profile does.
DenyAll
Panasonic Viera FX800A | Panasonic Viera CS610A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.10 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

Meelis

User avatar

Serviio lover

Posts: 50

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Wed Oct 31, 2018 7:32 pm

Re: Philips 55POS9002 (with synology DS218+)

Well here's the thing - if a file plays using the Generic Profile on the Windows box it should also play on the NAS using the Generic Profile (the Generic Profile is simply streaming the file natively, there should be nothing else really happening. Then its only up to your network to transport it - are both your Windows box and NAS wired or wireless?).

4K movies play with generic profile in the same poor way in Nas and win 10 (hanging and cutted sound ).
Nas , Win 10 and TV is connected by wires to same switch 10/100/1000 and use 1000 speed.

There are other settings that can force transcoding, notaby the "Enable burned-in subtitles" setting in Delivery, Subtitles. Make sure that is off on the NAS in particular.

Yes, it was on... I turned it off and save. Also restarted server. Cant see any difference. Same problem stays. Tryed in Nas and Win 10.

On the Windows box does the Samsung J profile fix the playback of 4K files as it did on the NAS? I'm struggling to see why it is impacting at all - the profile hasnt anything that affects hevc files. It should therefore do exactly as the generic Profile does.


For me...
Panasonic Viera 2013 profile play ok only regular HD movies and wont play 4K ones. In NAS and Win 10.
Samsung J series profile play 4K movies with problems and play ok regular HD movies. In NAS and Win 10.
Generic profile play 4K movies with problems and play ok regular HD movies. In NAS and Win 10.
So seems i mixed up earlyer something a bit. This information is correct now.

Seems problem with 4K movies. TV should support 4k and LAN is ok for traffic. I have no ideas.

For final i copyed that movie to usb stick and attached to tv. And exactly the same problem :twisted: I am afraid that this is a tv problem. In PC vlc player it works fine.
Totally unbelievable :twisted: Ill try TV updates but as much i remmember it was up to date.
<<

DenyAll

DLNA master

Posts: 2187

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Wed Oct 31, 2018 10:10 pm

Re: Philips 55POS9002 (with synology DS218+)

Thanks. It was the info on the Samsung J profile that was throwing me. While playing via a USB doesn’t necessarily tell you what can play via streaming, it’s a very good indication of won’t play (without transcoding).

You’re correct, it seems to be a limitation of the TV. This limitation though may not be playing 4K files - there may be a maximum bit rate supported, or it might be another factor (eg. Audio type in the file). Check the specs and see if there is discussion on the web that helps. Play as many 4K files as you have to see if there is a pattern if any of them work. If you find this out we may be able to tweak a profile to make the others playable.
DenyAll
Panasonic Viera FX800A | Panasonic Viera CS610A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.10 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

atc98092

User avatar

DLNA master

Posts: 2836

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Wed Oct 31, 2018 10:58 pm

Re: Philips 55POS9002 (with synology DS218+)

I see two of the three media files you posted the codecs for have Dolby TrueHD as the primary audio track. If the audio codec is unsupported, some players will play the video and not provide any audio, while others will fail to play them at all. I know of no TV that supports lossless audio, so that could be the cause of the playback failure. The Roku TV profiles (and I'm certain there are others) will play the video but transcode the audio to AC3 (Dolby Digital), which all TVs support.

Also, the first one (MPEG-4 part 10) might also be outside the supported codecs. The other two have HEVC (H.265) which they say is supported. But as DenyAll said the TV might not support the video bitrate. Note the specs that I quoted before: video bitrate can't exceed 20 Mbps, and the entire media bitrate (video and audio) can't exceed 30 Mbps. I exceed those bitrates with normal 1080p material, so any UHD material is most certainly going to exceed those bitrates. You may need to transcode them all with a bitrate limit added to the profile.

One test you can do is to use tsMuxeR (https://www.videohelp.com/software/tsMuxeR) and change the TrueHD audio to be the second audio track, and move the AC3 track to be first. That might make them playable. It doesn't alter anything else, so works quite fast.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

Meelis

User avatar

Serviio lover

Posts: 50

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Thu Nov 01, 2018 7:23 am

Re: Philips 55POS9002 (with synology DS218+)

Also, the first one (MPEG-4 part 10) might also be outside the supported codecs.

HD (ace ventura.png) This one is works fine. Its a regular HD movie for me. Around 1.5gb file size.
4K (jon wick.png) This one dont run smoothly. Video buffering and hanging. Sound seems ok. Around 36gb file size.
4K (black panter.png) And this one have sound problem. Sometimes video playback hangs as well. Around 15gb file size.

Note the specs that I quoted before: video bitrate can't exceed 20 Mbps, and the entire media bitrate (video and audio) can't exceed 30 Mbps.

What you mean under cant exceed 20 Mbps... If it exceed then serviio not able to play it?
I played with vlc player (john wick.png) and seems bitrate is around 50Mbps.

I found from internet a bit information. Maybe it is useful. See attached picture.
Source is https://www.flatpanelshd.com/review.php?subaction=showfull&id=1505461623
Attachments
POS9002.png
4K playback
POS9002.png (62.17 KiB) Viewed 359 times
<<

Meelis

User avatar

Serviio lover

Posts: 50

Joined: Mon Aug 13, 2012 6:00 pm

Location: Estonia

Post Thu Nov 01, 2018 9:02 am

Re: Philips 55POS9002 (with synology DS218+)

I went to tv shop and tested there the same movie from usb stick. Works fine. So tv will be replaced today evening. Seems more like it is a tv issue. I hope that will finish my problems. But still will be good to have correct profile in serviio. Later with new one i can test again movies and then give feedback here.
<<

atc98092

User avatar

DLNA master

Posts: 2836

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Thu Nov 01, 2018 12:03 pm

Re: Philips 55POS9002 (with synology DS218+)

Let us know if replacing the TV resolves the issue. Certainly sounds possible.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
Next

Return to Philips

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.