FAQ  •  Register  •  Login

serviio disappears from my TV after few minutes

<<

ColDadJet

Serviio newbie

Posts: 2

Joined: Mon Jun 04, 2012 6:11 pm

Post Mon Jun 04, 2012 7:21 pm

serviio disappears from my TV after few minutes

Can anyone please help me:

Got a Philips 40PFL9606k / 02 TV and try to stream videos from my PC (XP Prof SP3, AMD Dual Core) with serviio. I also stream with TVersity with no problems - except that it doesn't allow any fast foreward or rewind with the videos, which works fine with serviio - as long as it works. That's my problem: When I have started serviio servicing, switch on my TV and go into the "Browse PC" mode, the serviio server is visible on the TV and I can play the shared videos from my PC on it. But after a few minutes the serviio server disappears from the TV display (which does not happen with the TVersity server if it is active). I can only make serviio appear again on my TV by switching it off and on again. Has anybody any idea why?
<<

ColDadJet

Serviio newbie

Posts: 2

Joined: Mon Jun 04, 2012 6:11 pm

Post Tue Jun 05, 2012 6:00 pm

Re: serviio disappears from my TV after few minutes

Seems I have found the source of my problem myself.

Recently got a BOSD STOP errror pointing to tcpip6.sys as the driver causing this fault. Deinstalled the TCP/IP V6 protokoll, which earlier already had caused problems. Since then serviio is running stable on my TV.
<<

punkid

Serviio newbie

Posts: 3

Joined: Tue Sep 11, 2012 4:35 pm

Post Tue Sep 11, 2012 4:48 pm

Re: serviio disappears from my TV after few minutes

I have a similar problem with my 40PFL5507k /12. After a couple of minutes serviio stops streaming and disappears from my TV. The TV is connected via cable to the router (Vodafone EasyBox) and my Notebook (Thinkpad Edge 420s) has a static IP. This problem occurs with every movie I try to watch.

I tried the following:

- Disabled the setting that Windows is allowed to 'save energy' by shutting down the ethernet card.
- Disabled the screensaver
- Bound Serviio to IP (in the Serviio Console)

I'm running Serviio 1.0.1 on a Windows 7 64bit.

Help is appreciated! Thank you
<<

therebel22

Serviio newbie

Posts: 5

Joined: Sun Mar 11, 2012 9:40 am

Post Sun Oct 14, 2012 2:32 pm

Re: serviio disappears from my TV after few minutes

Hi,

same problem here with Philips TV.

I hav isolated problem : I hav installed minidlna to test : same problem but after modifying notify_interval to 90000 it worked : no disappears !!!

Conclusion : for working with my Philips TV, DLNA Server must serve SSDP queries with Cache-Control : max-age very high.

Zip, could it be possible to indicate in serviio configuration the value of notify interval (max-age) ?
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16851

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Oct 23, 2012 4:14 pm

Re: serviio disappears from my TV after few minutes

I will have a look for the max-age. Currently you can change the duration of notify requests using serviio.advertisementDuration property: http://www.serviio.org/index.php?option ... icle&id=43
<<

therebel22

Serviio newbie

Posts: 5

Joined: Sun Mar 11, 2012 9:40 am

Post Tue Oct 23, 2012 5:25 pm

Re: serviio disappears from my TV after few minutes

Thanks !!

Since my last post, i hav found true origin of problem : my ADSL router had a firmware update by provider. Ethernet port where my switch was plugged was a special port named TV (for plug TV IP adapter) : it seems that it filtered some uPNP requests but i can't say when and how (i hav tested with ethereal).

I hav changed port to a no name port and now everything is right !! Serviio no disappear from TV at all after hours !!
<<

alism

Serviio newbie

Posts: 2

Joined: Wed Nov 28, 2012 1:03 pm

Post Wed Nov 28, 2012 1:15 pm

Re: serviio disappears from my TV after few minutes

Hello,
i have the same problem like you. I am watching a transcoded movie and the serviio-server disappear in my TV, pfl9606, after some minutes.
Here are a lot of different reasons mentioned. Did anybody find the "correct reason" in the last month? Or could anybody explain to me, what i have to do to solve the problem?

@zip: What do you mean with "max-age"?

Please excuse this mass of questions, but I'm not a specialist on this field.

Kind regards,
alism
<<

alism

Serviio newbie

Posts: 2

Joined: Wed Nov 28, 2012 1:03 pm

Post Fri Dec 07, 2012 8:53 am

Re: serviio disappears from my TV after few minutes

Hello,
i have located the problem now. I called the philips support and he told me, the "Fritzbox" has a securitysystem, which is called IPS. This system locates active wlan-connections (multicast) by asking any device, which is connected in the wlan. Philips-TVs don't answer at this IPS-requests. So the Fritzbox cut the connection while the stream is running.

The Solution is now connect every streaming device over lan or to get a router, where you can deactivate the IPS-System.

Kind regards,
alism
<<

Leif H

Serviio newbie

Posts: 2

Joined: Sun Mar 10, 2013 4:59 pm

Post Sun Mar 10, 2013 5:38 pm

Re: serviio disappears from my TV after few minutes

Hello,
I have the same problem as the other people in this thread, Serviio disappears after a few minutes from my Philips 32pfl5507 TV, but none of the suggested solutions help for me.
I attach a detailed log, showing that "EventSubscriptionExpirationChecker" removes the expired subscription 0ab7cd7d..., after which the connection is reset. I guess that is where the picture freezes and Serviio disappears.
But why does the subscription expire so quickly? From the log, I see that the TV requests a renewal every 5 seconds since the subscription was registered, and it is renewed by "ServiceEventSubscriptionRequestHandler", but just before the subscription is removed, it seems like a renewal request is missing (maybe because of disturbance in the WLAN link?) for more than 5 seconds, and then it is regarded as expired.
I don't know if I have interpreted the log file correctly, but to me this seems to be the reason for my problem. I have tried different values for serviio.advertisementDuration but that doesn't solve the problem.
Do you have any suggestions what I can try to solve the problem?

Best regards,
Leif
<<

Leif H

Serviio newbie

Posts: 2

Joined: Sun Mar 10, 2013 4:59 pm

Post Sun Mar 10, 2013 5:46 pm

Re: serviio disappears from my TV after few minutes

Hello again,

I tried to upload a log file by browsing for the file and klicking "Add the file" under "Upload attachment", but I can't see any sign of it being uploaded. Have I missed anything?

/Leif
<<

Joan Murt

Streaming enthusiast

Posts: 25

Joined: Tue Aug 20, 2013 8:51 am

Post Sun Sep 15, 2013 10:03 am

Re: serviio disappears from my TV after few minutes

Take a look at this post: http://forum.serviio.org/viewtopic.php?f=27&t=687&p=78533#p78533

I had the same problem until I added a switch, removed ipv6 support and solved a vmware issue...

Return to Philips

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.