FAQ  •  Register  •  Login

Serviio on Debian 8

<<

AQUSTIQ

Serviio newbie

Posts: 6

Joined: Sun Dec 29, 2013 1:07 am

Post Sat Sep 17, 2016 2:39 am

Serviio on Debian 8

Hi
I have installed Serviio 1.7 on Debian 8 and when I start serviio.sh I'm getting this error.

  Code:
Exception in thread "Thread-31" java.lang.NullPointerException
        at de.timroes.axmlrpc.serializer.SerializerHandler.serialize(SerializerHandler.java:220)
        at de.timroes.axmlrpc.Call.getXMLParam(Call.java:88)
        at de.timroes.axmlrpc.Call.getXML(Call.java:64)
        at de.timroes.axmlrpc.XMLRPCClient$Caller.call(XMLRPCClient.java:659)
        at de.timroes.axmlrpc.XMLRPCClient.call(XMLRPCClient.java:461)
        at org.serviio.delivery.subtitles.OpenSubtitlesClient.makeUnauthorisedRpcCall(OpenSubtitlesClient.java:203)
        at org.serviio.delivery.subtitles.OpenSubtitlesClient.logOut(OpenSubtitlesClient.java:98)
        at org.serviio.delivery.subtitles.OpenSubtitlesService.shutdown(OpenSubtitlesService.java:135)
        at org.serviio.MediaServer$ShutdownHook.run(MediaServer.java:360)


Any help will be much appreciated.

My details: FFMPEG installed from deb-multimedia.org v2.8.7
  Code:
serviio@mediaserver:~$ ffmpeg -v
ffmpeg version 2.8.7 Copyright (c) 2000-2016 the FFmpeg developers
  built with gcc 4.9.2 (Debian 4.9.2-10)
  configuration: --prefix=/usr --extra-cflags='-g -O2 -fstack-protector-strong -Wformat -Werror=format-security ' --extra-ldflags='-Wl,-z,relro' --cc='ccache cc' --enable-shared --enable-libmp3lame --enable-gpl --enable-nonfree --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libtheora --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libspeex --enable-nonfree --disable-stripping --enable-libvpx --enable-libschroedinger --disable-encoder=libschroedinger --enable-version3 --enable-libopenjpeg --enable-librtmp --enable-avfilter --enable-libfreetype --enable-libvo-aacenc --disable-decoder=amrnb --enable-libvo-amrwbenc --enable-libaacplus --libdir=/usr/lib/x86_64-linux-gnu --disable-vda --enable-libbluray --enable-libcdio --enable-gnutls --enable-frei0r --enable-openssl --enable-libass --enable-libopus --enable-fontconfig --enable-libpulse --disable-mips32r2 --disable-mipsdspr1 --disable-mipsdspr2 --enable-libvidstab --enable-libzvbi --enable-avresample --disable-htmlpages --disable-podpages --enable-libutvideo --enable-libfdk-aac --enable-libx265 --enable-libbs2b --enable-libilbc --enable-libopenh264 --enable-libkvazaar --enable-libiec61883 --enable-vaapi --enable-opencl --enable-libdc1394 --disable-altivec --shlibdir=/usr/lib/x86_64-linux-gnu
  libavutil      54. 31.100 / 54. 31.100
  libavcodec     56. 60.100 / 56. 60.100
  libavformat    56. 40.101 / 56. 40.101
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 40.101 /  5. 40.101
  libavresample   2.  1.  0 /  2.  1.  0
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  2.101 /  1.  2.101
  libpostproc    53.  3.100 / 53.  3.100


Java installed from webupd8.org
  Code:
serviio@mediaserver:~$ java -version
java version "1.8.0_101"
Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.101-b13, mixed mode)
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16256

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sat Sep 17, 2016 7:02 pm

Re: Serviio on Debian 8

Hi, the error is not relevant and is actually happening when serviio shuts down. I will fix it anyway.

I'm not sure if the serviio.sh works correctly on your OS as in that the process is staying open of if it immediately shuts down. That should be apparent from the logs.
<<

AQUSTIQ

Serviio newbie

Posts: 6

Joined: Sun Dec 29, 2013 1:07 am

Post Mon Sep 19, 2016 3:51 am

Re: Serviio on Debian 8

With stability of the system is problem now. When I restart serviio service I'm able to watch a movie on my both LG TV's (both recognized in serviio and use LG TV/player profile). After some time if I want to watch the movie - it playing 1 min and it show "disconnect from network" or "Unstable connection" and after 5 sec "Disconnected from network".
On my Android tablet I don't have a problems.

P.S. I have used these TV's with previous versions of serviio installed on Ubuntu 14.04 and was rock stable. There is any tricks to do with Debian which maybe I don't know about?

My start script is:

  Code:
[Unit]
Description=Serviio Media Server
After=syslog.target local-fs.target network.target

[Service]
Type=simple
User=serviio
Group=serviio
ExecStart=/myfiles/apps/serviio/bin/serviio.sh
ExecStop=/myfiles/apps/serviio/bin/serviio.sh -stop
KillMode=none
Restart=on-abort

[Install]
WantedBy=multi-user.target
<<

AQUSTIQ

Serviio newbie

Posts: 6

Joined: Sun Dec 29, 2013 1:07 am

Post Tue Sep 20, 2016 3:53 pm

Re: Serviio on Debian 8

Never-mind. I solved my issue by moving serviio transcoding temporary folder other then /tmp folder :).
My system /tmp is a 200M tmpfs folder and got full quickly.
<<

AQUSTIQ

Serviio newbie

Posts: 6

Joined: Sun Dec 29, 2013 1:07 am

Post Sat Oct 01, 2016 6:51 am

Re: Serviio on Debian 8

Seems to not be the solution.
After server restart everything works fine. After a couple of hours I'm still getting "unstable connection" message and drop of connection after 1 min of movie play.
<<

AQUSTIQ

Serviio newbie

Posts: 6

Joined: Sun Dec 29, 2013 1:07 am

Post Mon Nov 14, 2016 3:25 am

Re: Serviio on Debian 8

So for those who have the same issue: I was unable to get work serviio on debian 8. I have moved to Centos 7 and server works without any issue a couple of days already. Seems debian 8 not working well with Java.
<<

tstrike

Serviio lover

Posts: 79

Joined: Fri May 10, 2013 5:03 am

Post Sun Dec 18, 2016 2:35 pm

Re: Serviio on Debian 8

AQUSTIQ wrote:So for those who have the same issue: I was unable to get work serviio on debian 8. I have moved to Centos 7 and server works without any issue a couple of days already. Seems debian 8 not working well with Java.



I am confirming this issue with Version 1.8 on Centos 7 running a recent Java version: openjdk version 1.8.0_111 . I am gonna try to go with a lower version of Open Java.

Return to General discussion

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.