FAQ  •  Register  •  Login

Play Muted by Default

<<

aspenny

Serviio newbie

Posts: 14

Joined: Wed Feb 12, 2014 9:24 pm

Post Fri Oct 26, 2018 3:41 pm

Play Muted by Default

Whenever I stream music in the Serviio Media Browser on my iPhone (Safari, Chrome of Firefox) the play is always muted by default when I initially start a new album or switch to another album later on. Is this by design in Serviio or is there something doing this on my phone? It is tough to un-mute because the icons are absolutely microscopic. I have tried to fix the microscopic icon issue by changing the font size on my phone but that does not do anything. Any thoughts?
<<

atc98092

User avatar

DLNA master

Posts: 2906

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Fri Oct 26, 2018 3:47 pm

Re: Play Muted by Default

I don't have music on my server, but I tried playing a movie on my iPhone 6S. Using Chrome, the audio was not muted. I didn't try Safari. I don't believe it's a MediaBrowser setting, but I have no idea where such a setting might be in the iOS.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Insignia Roku TV, Roku 4, Ultra and Stick, Yamaha RX-V583 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

HOWTO: Enable debug logging HOWTO: Identify media file contents
<<

DenyAll

DLNA master

Posts: 2210

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Sun Oct 28, 2018 1:02 pm

Re: Play Muted by Default

Can confirm the issue for audio files (IOS, Chrome, iPad Air 2). Hadn’t noticed this before but I’m not a big music user.

To emulate select an Album, then a song. Media starts playing but is muted.

Some observations:

  • After un-muting you can navigate in the playlist for the album and it works as it should - next song starts unmuted
  • if you don’t unmute, navigating to another sone remains muted
ps. @aspenny = it wil also unmute if you pause and unpause. This can be done easily by double tapping on the player frame (saves you trying to hit the small mute button until the issue is resolved).

@zip: potential issue? Am running iOS 12.0.1 so may also have arisen after the latest upgrade?

Issue logged: https://bitbucket.org/xnejp03/serviio/i ... diabrowser
DenyAll
Panasonic Viera FX800A | Panasonic Viera CS610A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.10.1 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16880

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Oct 28, 2018 2:33 pm

Re: Play Muted by Default

I'd say this is expected, no? Recent browser versions start all media files muted, unless you change that setting in the browser. Safari definitely does this, Chrome may as well.
<<

aspenny

Serviio newbie

Posts: 14

Joined: Wed Feb 12, 2014 9:24 pm

Post Sun Oct 28, 2018 5:51 pm

Re: Play Muted by Default

Bummer. I checked everywhere for a setting in the browsers and cannot find anything. I thought YouTube used to start muted as well but everything I pulled up today began streaming unmuted. I guess I have to accept the fact I will need to unmute every time music starts then. Any way to consider making the unmute more user friendly in the future? Compare size of volume button on YouTube vs MediaBrowser when in portrait orientation. The MediaBrowser icon is very difficult to press. I am using Serviio 1.10 and latest iOS.
<<

DenyAll

DLNA master

Posts: 2210

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Tue Oct 30, 2018 1:47 am

Re: Play Muted by Default

zip wrote:I'd say this is expected, no?
No, I didn't expect it.

I checked using MediaBrowser on Windows 10 platform both with Chrome and Edge browsers and the file starts playing normally (ie. un-muted). So it may be an iOS only issue?

On the iOS platform there is nothing in Chrome or Safari settings that can be enabled to allow media to be started unmuted that I could find.
DenyAll
Panasonic Viera FX800A | Panasonic Viera CS610A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.10.1 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16880

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Nov 01, 2018 9:37 am

Re: Play Muted by Default

<<

DenyAll

DLNA master

Posts: 2210

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Thu Nov 01, 2018 11:51 am

Re: Play Muted by Default

Yes, I had seen other references on the web as well, however this and everything I've seen refers to playback of video files. I haven't found a reference to this being the case for audio files (doesn't mean its not the case, I just haven't found it)

Irrespective... if it is an iOS limitation then for audio files it doesn't make a lot of sense to auto play the songs muted (the user has to un-mute and then rewind to get to the beginning of the song). Perhaps it would be better when transitioning from the Album screen (or other pre-player pages) to the player page that the Audio file appears with a big "play" icon over the album art - the same way it is done for Video's in Mediabrowser. The user then presses the big icon to start playing the song. The use of the big play icon makes it obvious that the user needs to take action (the current situation isn't obvious that the file is actually playing).

If this path is taken, then some other things to consider:

  • When you are in the Player page, once you've unmuted the first song, navigating the Play List on the right hand frame should auto-play the new song (ie. without the big "play" icon. This is the case now for audio). ps. The fact that this works now doesn't make sense to me - how does this currently work ie the newly selected song starts un-muted from the PlayList and yet not when starting from the other pages?
  • The use of the big play icon on audio files only need to be there for iOS devices (and maybe Android). Its not needed on PC platforms as these auto-play un-muted now.
Your thoughts?
DenyAll
Panasonic Viera FX800A | Panasonic Viera CS610A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.10.1 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16880

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Nov 02, 2018 10:51 am

Re: Play Muted by Default

On OSX Safari, you can enable this by default by going to Preferences -> Websites -> Autoplay

I didn't find that in iOS. So maybe I'll have to look into it.

Return to General discussion

Who is online

Users browsing this forum: No registered users and 2 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.