Post Mon Sep 07, 2015 9:41 pm

Re: Solution to 30 minute disconnect problem (v1.2.1)

I have the same problem, exactly every 30 minutes serviio dissconects from my samsung tv.

However and this is driving me insane, it does not disconnect on a wired connection, only on a wireless one.

I use a Draytek 2850VN router which are extremely complicated to use, I've been using it for a few years now and I have a good understanding of the hundreds if not thousands of settings available to me, although most settings I just do not touch for fear of messing stuff up :lol:

Anyway, I use windows 10 and have eset smart security as my firewall and antivirus.
Serviio was working fine via wireless until friday, then all of a sudden it started to dissconnect exactly every half hour.

This is what I have done to try to and rectify the problem.

First I uninstalled serviio and then reinstalled, it still had the same problem, then I downgraded to version 1.5.1 and still the same, serviio would lose connection exactly every 30 minutes and although the TV was still physically signed into samsung and I could still go online with it and every other wireless device thats connected to my router, 14 in all, serviio just wouldnt reconnect. When it did disconnect, I opened up the console and pushed refresh and my tv was still there listed as green, I could press the button 20 times and it would remain green but in reality it was not connected to my tv, however if I deleted my tv from the list and then pushed refresh it would not appear in the list, only turning off the TV and turning it back on again would I get serviio to pick up the TV as green again, but as we all know it would bum out at the 30 min mark.

I have bound the TV to its own internal ip in my router, ( was already done when serviio was working ok for years and for weeks in windows 10 ) I have added serviio to the software firewall and my routers firewall, so that its allowed to travel through my internal network without any problems. IGMP snooping is enabled and always has been, UPNP is disabled and always has been, even when serviio was working ok via wireless .

Router firewall options that are enabled and always have been are;
Dos defence
Syn, udp and icmp flood and port scan defence are all enabled with a 200 packets a second threshold before kicking in and blocking the ip that is doing it.
Block; IP Options, Land, Smurf, Trace Route, Syn Fragment, Fraggle Attack, TCP Flag Scan, Tear Drop, Ping of Death, ICMP Fragment and also Block Unassigned Numbers, all those options are blocked.
Strict Security Firewall is enabled and Accept large incoming fragmented UDP or ICMP packets ( for some games, ex. CS )
is also enabled, also tried it with disabled, no go, but it was working ok previously with it enabled.

All the firewall options mentioned above have always been enabled even when serviio was working perfectly.
I also disabled both soft and hardware firewalls just to rule them out but to no avail.
Wireless freq is 5ghz and the TV gets the strongest signal possible according to the bars also long preamble is disabled since their is no need for it since the wireless connection is very good all throughout the house.

This is a very annoying problem, one that I've suffered from on and off for a number of years, when I say that its only happened a couple of times over the years but at the moment I am stuck using a wired connection to the tv, it works fine that way but its not a solution having a 5 metre cat6a cable crossing the living room floor.

Does anyone have any solutions ? As my next course of action is factory resetting the router yet again, but instead of loading up one of the different backup files to the router, I will do it all manually which I REALLY DONT wanna do as it will take a few hours in itself and then if it still doesnt work I will format windows 10 as it only takes about 10 minutes to do a clean install.

Is this a problem with our equipment or is it a problem with serviios code or is it an OS problem ?

Sorry for the long post but I was just describing what my settings are and what I have done to try and fix it.