FAQ  •  Register  •  Login

Problem with Playlists in 1.5.1

<<

cisop

Streaming enthusiast

Posts: 20

Joined: Tue Aug 06, 2013 12:41 pm

Post Wed Mar 25, 2015 2:44 pm

Problem with Playlists in 1.5.1

The automatic updater in Servioo 1.5.1 will no longer add playlists (.m3u files). It gives the following error.

"The process cannot access the file because it is being used by another process"

At first I thought it had attempted to add the file while I was copying it. But it gives the same error for the m3u file on all subsequent runs. As a test I added a couple of video files to the directory. The updater ran automatically and added them to the library but still gave the same error for the m3u file.

If you force a library refresh the m3u files are added with no error.

In a nutshell the auto updater will not add m3u files. The manual updater will.

-
cisop
<<

dazzknowles

Serviio newbie

Posts: 4

Joined: Sun Aug 28, 2016 1:31 pm

Post Sun Aug 28, 2016 1:32 pm

Re: Problem with Playlists in 1.5.1

In version 1.6.1 I get exactly the same issue.
<<

dazzknowles

Serviio newbie

Posts: 4

Joined: Sun Aug 28, 2016 1:31 pm

Post Fri Jan 20, 2017 10:54 pm

Re: Problem with Playlists in 1.5.1

... And still in 1.8.0 - is no one else getting this problem?

java.io.FileNotFoundException: D:\Playlists\Primal Scream - Give Out But Don't Give Up.m3u (The process cannot access the file because it is being used by another process)
at java.io.FileInputStream.open0(Native Method)
at java.io.FileInputStream.open(FileInputStream.java:195)
at java.io.FileInputStream.<init>(FileInputStream.java:138)
at java.io.FileInputStream.<init>(FileInputStream.java:93)
at org.serviio.library.playlist.PlaylistParser.getPlaylistBytes(PlaylistParser.java:84)
at org.serviio.library.playlist.PlaylistParser.parse(PlaylistParser.java:59)
at org.serviio.library.local.indexing.PlaylistFileIndexer.addNewPlaylistFile(PlaylistFileIndexer.java:66)
at org.serviio.library.local.indexing.DefaultLibraryMonitor.fileAdded(DefaultLibraryMonitor.java:53)
at org.serviio.library.local.indexing.pipe.PipeManager$PipeProcessingConsumer.lambda$run$27(PipeManager.java:174)
at java.util.Optional.ifPresent(Optional.java:159)
at org.serviio.library.local.indexing.pipe.PipeManager$PipeProcessingConsumer.run(PipeManager.java:169)
at java.lang.Thread.run(Thread.java:745)
<<

atc98092

User avatar

DLNA master

Posts: 1905

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sat Jan 21, 2017 1:58 am

Re: Problem with Playlists in 1.5.1

My playlists are in pls format, so are not the same as yours. Mine seem to work fine.
Panasonic ST30 Plasma, Samsung JU7100 4K TV, Samsung UN24H4500 TV, Sony BDP-S3500, Insignia Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16234

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Jan 23, 2017 11:03 pm

Re: Problem with Playlists in 1.5.1

This would be cause by something having the read lock on the file. Not sure what it could be on your system.
<<

dazzknowles

Serviio newbie

Posts: 4

Joined: Sun Aug 28, 2016 1:31 pm

Post Sun Feb 12, 2017 3:11 pm

Re: Problem with Playlists in 1.5.1

zip wrote:This would be cause by something having the read lock on the file. Not sure what it could be on your system.


Yes, I understand the error, but the reason why I was getting this with just Playlists was odd. However, I've worked out the cause. I use Playlist Creator to make my playlists and for convenience was having it save them straight into the folder that Serviio has mapped as a library. By saving the playlists into a different directory and moving them I don't have the issue.

It's strange though as I rip the CDs the playlists relate to straight into a library folder with no issue but I guess there is something about how Playlist Creator creates its file locks that causes Serviio to fail.
<<

atc98092

User avatar

DLNA master

Posts: 1905

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Mon Feb 13, 2017 1:58 am

Re: Problem with Playlists in 1.5.1

Strange, I use Playlist Creator and save the files into a Serviio media folder. haven't had any issues with locked files. Aren't computers fun? :lol:
Panasonic ST30 Plasma, Samsung JU7100 4K TV, Samsung UN24H4500 TV, Sony BDP-S3500, Insignia Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging
<<

dazzknowles

Serviio newbie

Posts: 4

Joined: Sun Aug 28, 2016 1:31 pm

Post Sun Mar 05, 2017 11:43 am

Re: Problem with Playlists in 1.5.1

For anyone else stumbling into this issue I've found that setting the library folder I have for my playlist files to use Serviio's poller mechanism works fine so I have enabled this which then removes the need for me to manually force a refresh each time.

Return to Serviio Support & Help

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 12 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.