FAQ  •  Register  •  Login

Serviio 1.6 not updating playlists in library

<<

Paul C

DLNA master

Posts: 130

Joined: Wed Feb 17, 2016 3:46 pm

Location: Essex, UK

Post Mon Mar 07, 2016 8:17 pm

Serviio 1.6 not updating playlists in library

Serviio 1.6 seems more robust in automatically updating audio files in the library than the previous version.
However I still have a problem with playlist updating which existed in the earlier version.
If I add additional files to an existing playlist it does not update but if I create a new playlist by changing the playlist filename, i.e.Sounds-1 to Sounds-2, the new playlist immediately appears.
Serviio 1.9.2 (Pro), DBpoweramp & Asset UPnP (registered), Acer Aspire One netbook, HP Elitebook, Windows 10 Pro, Denon DNP-730AE, NEET AirstreamPro renderer, Naim NAC72/NAP140 (x2), Celestion Ditton 25 and Spendor A5 speakers, WD TV Media Player (x2), Panasonic Blu-ray DMP-BDT360, Panasonic TV, Amazon Fire 7 HDX, BubbleUPnP control app, Mezzmo Android control App, Qobuz streaming.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16748

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Mon Mar 07, 2016 8:43 pm

Re: Serviio 1.6 not updating playlists in library

Post detailed log of when you edit a playlist. Are you sure the audio file already exists in your Serviio library?
<<

Paul C

DLNA master

Posts: 130

Joined: Wed Feb 17, 2016 3:46 pm

Location: Essex, UK

Post Mon Mar 07, 2016 9:35 pm

Re: Serviio 1.6 not updating playlists in library

I will try out the logging (not done it before).
In the meantime I enclose screenshots. The last file was removed and an additional file added at end of playlist.
The change (Good-sounds-1) was made at 17.49 and still not updated after 3 1/2 hours.
The audio file has been there for 9 months (also other server updated OK) - see screenshot. (Files are selected from pull-down list in M3U Creator).
I have now noted that new file Good-sounds-2 has not appeared (it used to under earlier versions - that is how I got around the issue previously).
Attachments
playlist-issue-1.jpg
playlist-issue-1.jpg (408.45 KiB) Viewed 1026 times
playlist-issue-4.jpg
playlist-issue-4.jpg (335.9 KiB) Viewed 1028 times
playlist-issue-3.jpg
playlist-issue-3.jpg (241.88 KiB) Viewed 1028 times
Last edited by Paul C on Mon Mar 07, 2016 10:09 pm, edited 5 times in total.
Serviio 1.9.2 (Pro), DBpoweramp & Asset UPnP (registered), Acer Aspire One netbook, HP Elitebook, Windows 10 Pro, Denon DNP-730AE, NEET AirstreamPro renderer, Naim NAC72/NAP140 (x2), Celestion Ditton 25 and Spendor A5 speakers, WD TV Media Player (x2), Panasonic Blu-ray DMP-BDT360, Panasonic TV, Amazon Fire 7 HDX, BubbleUPnP control app, Mezzmo Android control App, Qobuz streaming.
<<

Paul C

DLNA master

Posts: 130

Joined: Wed Feb 17, 2016 3:46 pm

Location: Essex, UK

Post Mon Mar 07, 2016 9:38 pm

Re: Serviio 1.6 not updating playlists in library

Screenshot of the Serviio console.
Attachments
playlist-issue-5.jpg
playlist-issue-5.jpg (223.61 KiB) Viewed 1028 times
Serviio 1.9.2 (Pro), DBpoweramp & Asset UPnP (registered), Acer Aspire One netbook, HP Elitebook, Windows 10 Pro, Denon DNP-730AE, NEET AirstreamPro renderer, Naim NAC72/NAP140 (x2), Celestion Ditton 25 and Spendor A5 speakers, WD TV Media Player (x2), Panasonic Blu-ray DMP-BDT360, Panasonic TV, Amazon Fire 7 HDX, BubbleUPnP control app, Mezzmo Android control App, Qobuz streaming.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16748

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Mar 10, 2016 9:10 pm

Re: Serviio 1.6 not updating playlists in library

need that detailed log file at the point of you making a change to the playlist.
Also the edited playlist file would be helpful (the actual m3u file, not a screenshot)
<<

Paul C

DLNA master

Posts: 130

Joined: Wed Feb 17, 2016 3:46 pm

Location: Essex, UK

Post Wed Jun 06, 2018 8:17 pm

NOT SOLVED - Re: Serviio 1.6 not updating playlists in libra

I thought the developer has resolved this issue or by setting the "Use the poller mechanism for monitoring this folder" option under shared folders/edit for the shared folder of the the playlist folder as at 1.9.1.

I updated one existing playlist RS-2 by adding two tracks (worked OK) and then removed a track (worked OK).
I then created a new playlist RS-3 but this was not recognised.
I re-edited it and changed its' name to RS-3a and it was recognised.
So still have an issue.
Serviio 1.9.2 (Pro), DBpoweramp & Asset UPnP (registered), Acer Aspire One netbook, HP Elitebook, Windows 10 Pro, Denon DNP-730AE, NEET AirstreamPro renderer, Naim NAC72/NAP140 (x2), Celestion Ditton 25 and Spendor A5 speakers, WD TV Media Player (x2), Panasonic Blu-ray DMP-BDT360, Panasonic TV, Amazon Fire 7 HDX, BubbleUPnP control app, Mezzmo Android control App, Qobuz streaming.

Return to Serviio Support & Help

Who is online

Users browsing this forum: No registered users and 4 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.