FAQ  •  Register  •  Login

Serviio Service Crash After starting

<<

don544

Serviio newbie

Posts: 5

Joined: Sun Mar 12, 2017 5:42 pm

Post Sun Mar 12, 2017 7:32 pm

Serviio Service Crash After starting

Hello:
Have not had a problem with Serviio at all other than the small learning curve until I updated to 1.8, since then it no longer works.
Running it on a Win7 64 bit 8 core machine with 16 Gb Memory and it has worked fine until now. The log shows this after each attempt to start the service and any pointers as to what is going wrong or where to correct it would be appreciated:

2017-03-12 13:38:41,596 INFO [Device] Created UPnP Device with UUID: 8c1b3806-7c77-3dbe-871c-774ccd38003a, bound address: 165.254.1.25
2017-03-12 13:38:42,064 ERROR [XmlUtils] XML Profiles.xsd didn't pass validation, reason: cvc-enumeration-valid: Value 'mpegts' is not facet-valid with respect to enumeration '[*, mp4, asf, mp3, mp2, lpcm, flac, ogg, flv, rtp, rtsp, adts, wavpack, mpc, ape]'. It must be a value from the enumeration.
2017-03-12 13:38:42,064 ERROR [MediaServer] An unexpected error occured. Ending the application. Message: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.
java.lang.RuntimeException: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.
at org.serviio.profile.ProfileManager.parseProfilesFromFile(ProfileManager.java:183)
at org.serviio.profile.ProfileManager.loadProfiles(ProfileManager.java:156)
at org.serviio.MediaServer.main(MediaServer.java:127)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:62)
at com.exe4j.runtime.WinLauncher$2.run(WinLauncher.java:96)
Caused by: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.
at org.serviio.profile.ProfilesDefinitionParser.validateXML(ProfilesDefinitionParser.java:961)
at org.serviio.profile.ProfilesDefinitionParser.parseDefinition(ProfilesDefinitionParser.java:152)
at org.serviio.profile.ProfileManager.parseProfilesFromFile(ProfileManager.java:181)
... 8 more
2017-03-12 13:38:42,079 WARN [IndexedDiskCache] Region [thumbnails] Disk cache not shutdown properly, shutting down now.
2017-03-12 13:38:42,079 WARN [IndexedDiskCache] Region [tokens] Disk cache not shutdown properly, shutting down now.
2017-03-12 13:38:42,079 WARN [IndexedDiskCache] Region [online_technical_metadata] Disk cache not shutdown properly, shutting down now.
--------------------------------------------------------------------------------------------------

After restart atempt

------------------------------------------------------------------------
2017-03-12 13:53:30,084 INFO [Device] Created UPnP Device with UUID: 8c1b3806-7c77-3dbe-871c-774ccd38003a, bound address: 165.254.1.25
2017-03-12 13:53:30,552 ERROR [XmlUtils] XML Profiles.xsd didn't pass validation, reason: cvc-enumeration-valid: Value 'mpegts' is not facet-valid with respect to enumeration '[*, mp4, asf, mp3, mp2, lpcm, flac, ogg, flv, rtp, rtsp, adts, wavpack, mpc, ape]'. It must be a value from the enumeration.
2017-03-12 13:53:30,552 ERROR [MediaServer] An unexpected error occured. Ending the application. Message: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.
java.lang.RuntimeException: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.
at org.serviio.profile.ProfileManager.parseProfilesFromFile(ProfileManager.java:183)
at org.serviio.profile.ProfileManager.loadProfiles(ProfileManager.java:156)
at org.serviio.MediaServer.main(MediaServer.java:127)
Caused by: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.
at org.serviio.profile.ProfilesDefinitionParser.validateXML(ProfilesDefinitionParser.java:961)
at org.serviio.profile.ProfilesDefinitionParser.parseDefinition(ProfilesDefinitionParser.java:152)
at org.serviio.profile.ProfileManager.parseProfilesFromFile(ProfileManager.java:181)
... 2 more
2017-03-12 13:53:30,552 WARN [IndexedDiskCache] Region [tokens] Disk cache not shutdown properly, shutting down now.
2017-03-12 13:53:30,552 WARN [IndexedDiskCache] Region [thumbnails] Disk cache not shutdown properly, shutting down now.
2017-03-12 13:53:30,552 WARN [IndexedDiskCache] Region [online_technical_metadata] Disk cache not shutdown properly, shutting down now.
<<

atc98092

User avatar

DLNA master

Posts: 2009

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sun Mar 12, 2017 8:01 pm

Re: Serviio Service Crash After starting

Did you edit something in one of the profiles? The log indicates there's an error on one of the profile entries. Check the config folder and see if there's a backup profiles file and rename it profiles.xml. Then see if it will start.

Also, if you were perhaps saving your old profiles file and reusing it after an upgrade, be aware that sometimes Zip makes a change to the profiles file that doesn't work with different versions. If you were trying to use (for example) a profiles file from Serviio v1.6, it might be causing the error.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Samsung UN24H4500 TV, Sony BDP-S3500, Insignia Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging
<<

don544

Serviio newbie

Posts: 5

Joined: Sun Mar 12, 2017 5:42 pm

Post Tue Mar 14, 2017 12:37 am

Re: Serviio Service Crash After starting

atc98092 wrote:Did you edit something in one of the profiles? The log indicates there's an error on one of the profile entries. Check the config folder and see if there's a backup profiles file and rename it profiles.xml. Then see if it will start.

Also, if you were perhaps saving your old profiles file and reusing it after an upgrade, be aware that sometimes Zip makes a change to the profiles file that doesn't work with different versions. If you were trying to use (for example) a profiles file from Serviio v1.6, it might be causing the error.



Thanks for the response, will try those hints. As I did not change anything or edit anything other than doing the update to 1.8 I did not see a reason for this.
<<

don544

Serviio newbie

Posts: 5

Joined: Sun Mar 12, 2017 5:42 pm

Post Thu Mar 16, 2017 10:35 pm

Re: Serviio Service Crash After starting

atc98092 wrote:Did you edit something in one of the profiles? The log indicates there's an error on one of the profile entries. Check the config folder and see if there's a backup profiles file and rename it profiles.xml. Then see if it will start.

Also, if you were perhaps saving your old profiles file and reusing it after an upgrade, be aware that sometimes Zip makes a change to the profiles file that doesn't work with different versions. If you were trying to use (for example) a profiles file from Serviio v1.6, it might be causing the error.



Ended up doing an uninstall and reinstall for third time and that seems to have cleared problem, as I did not modify anything do not know why or what happened.
Now other issues I have to look for as in multiple displays of single folder as if I have 10 and it shows movies that do not and never have existed on machine in mediabrowser app.
<<

DenyAll

DLNA master

Posts: 2026

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Sun Mar 19, 2017 7:46 am

Re: Serviio Service Crash After starting

don544 wrote:Now other issues I have to look for as in multiple displays of single folder as if I have 10 and it shows movies that do not and never have existed on machine in mediabrowser app.
Not sure of the multiple folders issue, but for the movies that don't exist I suspect Serviio is grabbing the wrong metadata for the movie (or series).

Serviio uses the file name of the movie to get metadata from themoviedb.com. For that to work you need to name your files according to the schema from here: http://www.serviio.org/component/conten ... extraction - for movies its generally as simple as "movie name.ext" (or "movie name (year).ext" if there are movies with the same name but different years). For series it's generally as simple as "series name sxx exx.ext"

Filebot is a useful tool for matching file names for movies to the themoviedb.com and series to thetvdb.com. If all else fails, you can add the IMDB id to the file name eg. "movie name (year) [tt99999].ext" where tt99999 is the IMDB id.
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 7 | Serviio 1.8 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.

Return to Serviio Support & Help

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 6 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.