FAQ  •  Register  •  Login

Unable to add NAS folders to library, file format issues

<<

rward1953

Serviio newbie

Posts: 15

Joined: Mon Sep 15, 2014 10:07 pm

Post Mon Apr 10, 2017 11:34 pm

Unable to add NAS folders to library, file format issues

I am running Windows 7 Ultimate, and I have a number of NAS drives, both USB 2 and USB 3, on this system, and have recently experienced a system crash. I've written to you before about this, but I seem to be unable to add some of the NAS drives back to the library because of the ludicrous security issues connected to Windows 7. This may be a Microsoft question, but I am not completely certain if this is the server being stopped by the Windows system or what.

Previous to the system crash, I appeared to be able to add NAS sources without and issue, but with the set-up I have now, even going through the permission/security crap that is suggested by Microsoft, the library doesn't seem to go through the entire directory and sub-directory layout I had in the old Windows 7 setup I had before the system crash. I can add folder by folder, but that seems to be insane, as I have well over 5 Tb of movies etc, over 5 drives. There has to be a more sensible way to add material to the library. I suspect this is the permission/security thing, but I can't be certain.

Is there something I should know about this software that might cause this? I'm particularly frustrated with not being able to access sub-directories that are more than 3-4 levels in, as I was trying to organize my library for easy access. Even when I can get access to a previous source the maximum scan seems to stop at about 3 "deep". This is particularly annoying with music folders, as the "depth" can easily reach 4-5 levels in.

Lastly, when I first set-up my library, there was a lot of "avi" files, and it appears that many of these files, even when accessible are not transcoding to a playable format. I realize certain formats are more compatible than others, but is there something going on here that I am missing? Obviously mp4 files appear to work the best. Should I be converting these files to this format?
<<

atc98092

User avatar

DLNA master

Posts: 2113

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Tue Apr 11, 2017 12:08 am

Re: Unable to add NAS folders to library, file format issues

The simplest way to resolve network file access permissions is to change the user account that the Serviio service runs under. By default, it runs under the local service account, which has few network permissions. Change the user account for the service to your personal user account and Serviio can then access anything on the network that your user account can access.

If you have media files that aren't showing, it usually means the wrong profile is selected for the playback device. Serviio does a pretty good job of identifying the device type, but some devices don't identify themselves accurately. Once you select a profile, it should stick.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Samsung UN24H4500 TV, Sony BDP-S3500, Insignia Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging

Return to Serviio Support & Help

Who is online

Users browsing this forum: Bing [Bot] and 8 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.