FAQ  •  Register  •  Login

Bug Report: Serviio not detecting added srt file

<<

ami289

Streaming enthusiast

Posts: 37

Joined: Sat Aug 15, 2015 8:36 am

Post Tue Jul 04, 2017 8:16 pm

Bug Report: Serviio not detecting added srt file

Hey guys,

I don't know if this is the correct place, but this is more of a bug report for future releases, then a request for help, as I've managed to get around this issue.


Long story short (bottom line)-
Serviio does not detect when I've added an srt file to already in-library folder.
Forced refresh, or restarting of both server and client, did not help either.
Video file and srt file names are exactly the same (copy-pasted video file name).
I am not using transcoding (so no cached/'old' transcoded video with no subtitles).


Long story long (more details about my situation)-
I had a video file for a couple of months now, and I've played it several times successfully (still had no subtitles file for it).
Few days ago, I've downloaded subtitles for that video.
I've put it in the same directory as the video file, copy-pasted the video file name to the subtitles file name, to make sure they both have the same name, and tried to play the video file.
Subtitles did not work.
I've tried force-refreshing the library, tried resetting my server, my client, my PC.
Nothing helped.
Serviio kept playing the file without the subtitles.

Eventually, what I did do is, I've renamed both files, causing Serviio to treat this video file as if it was new.
Serviio played video file with subtitles.
I thought perhaps there was a problem with the file names (as they were very long),
So I've restored the original file names to both the video and the subtitle,
Serviio still plays the video file with subtitles.
I'm not using transcoding, so it can't be an issue of 'old'/cached transcoded file, the was transcoded without subtitles.



Anyway, it seems to me that for some reason Serviio had failed to detect the change in that monitored directory, so it wasn't aware that a subtitle had been added.

Not a big issue,
But thought perhaps I might be able to share information that could help in future releases.

Do you need any more details/information?


Cheers.
<<

DenyAll

DLNA master

Posts: 2071

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Wed Jul 05, 2017 11:05 am

Re: Bug Report: Serviio not detecting added srt file

I'm not at home so a cant be specific, but their is a setting in Serviio Console regarding updating existing files. Is yours checked?
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

ami289

Streaming enthusiast

Posts: 37

Joined: Sat Aug 15, 2015 8:36 am

Post Thu Jul 06, 2017 8:04 pm

Re: Bug Report: Serviio not detecting added srt file

DenyAll wrote:I'm not at home so a cant be specific, but their is a setting in Serviio Console regarding updating existing files. Is yours checked?


If you refer to 'Automatic Library Refresh', it is on mate.
<<

DenyAll

DLNA master

Posts: 2071

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Thu Jul 06, 2017 8:54 pm

Re: Bug Report: Serviio not detecting added srt file

What about the "Search for updates for currently shared files" setting above it. Otherwise I'll test when I get home on the weekend.
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

ami289

Streaming enthusiast

Posts: 37

Joined: Sat Aug 15, 2015 8:36 am

Post Fri Jul 07, 2017 6:47 am

Re: Bug Report: Serviio not detecting added srt file

DenyAll wrote:What about the "Search for updates for currently shared files" setting above it. Otherwise I'll test when I get home on the weekend.


On as well.
<<

freaknik

User avatar

DLNA master

Posts: 107

Joined: Thu Mar 27, 2014 2:05 pm

Post Sun Jul 09, 2017 12:22 am

Re: Bug Report: Serviio not detecting added srt file

Is it named the same as the file it goes with? On mine it has to be

somefile.avi
somefile.srt

good luck
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16499

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Jul 16, 2017 5:49 pm

Re: Bug Report: Serviio not detecting added srt file

subtitles are looked for at playback time, so name change doesn't have to be registered anywhere.
<<

ami289

Streaming enthusiast

Posts: 37

Joined: Sat Aug 15, 2015 8:36 am

Post Sat Jul 29, 2017 12:41 am

Re: Bug Report: Serviio not detecting added srt file

zip wrote:subtitles are looked for at playback time, so name change doesn't have to be registered anywhere.


Kinda late reply, but I was away for a while.

Well, obviously this is not the case for me,
But I've noticed that you've mentioned 'fixed detection and displaying of Hebrew subtitles' in version 1.9 changelog.

Maybe this was related somehow.

Anyway,
I'll try the new version and report back if I still encounter the same situation.


Thanks.
<<

ami289

Streaming enthusiast

Posts: 37

Joined: Sat Aug 15, 2015 8:36 am

Post Sat Aug 12, 2017 3:58 pm

Re: Bug Report: Serviio not detecting added srt file

Hey guys,

Just wanted to report that this issue is not resolved in version 1.9

I could easily reproduce it if needed.

Will debug logs help?
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16499

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Aug 15, 2017 12:16 pm

Re: Bug Report: Serviio not detecting added srt file

yes, thanks
<<

ami289

Streaming enthusiast

Posts: 37

Joined: Sat Aug 15, 2015 8:36 am

Post Sat Sep 09, 2017 6:01 pm

Re: Bug Report: Serviio not detecting added srt file

Sorry for the late reply,
I was away for a while.

Anyway, here is what I did-
1) Added the movie 'The Mummy' to my library.
2) Played it without subtitles.
3) About a day later, added subtitles file (made sure that file names are match).
4) Played the movie - Subtitles weren't detected.
5) Changed the folder name (added '11111' at the end), so Serviio will recognize it as new folder, and re-scan it.
6) Played the movie again - Subtitles worked flawlessly.


Untouched log file is attached.


Cheers.
Attachments
serviio.log
Debug Log
(315.62 KiB) Downloaded 10 times
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16499

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Sep 10, 2017 4:22 pm

Re: Bug Report: Serviio not detecting added srt file

Thanks, it looks like the response is cached and a new subtitle file doesn't invalidate the cache.

Created a ticket: https://bitbucket.org/xnejp03/serviio/i ... -to-cached
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16499

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Sun Sep 10, 2017 6:17 pm

Re: Bug Report: Serviio not detecting added srt file

.. and fixed
<<

atc98092

User avatar

DLNA master

Posts: 2221

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state) - temporary assignment to Washington DC

Post Sun Sep 10, 2017 10:31 pm

Re: Bug Report: Serviio not detecting added srt file

zip wrote:.. and fixed


Sounds like you're getting close to a new beta. Or did you just update the available 1.9 install file?
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging Identify video file contents
<<

ami289

Streaming enthusiast

Posts: 37

Joined: Sat Aug 15, 2015 8:36 am

Post Mon Sep 11, 2017 6:20 am

Re: Bug Report: Serviio not detecting added srt file

Man, you are quick!

Keep up the awesome work!

Thank you.

Return to Serviio Support & Help

Who is online

Users browsing this forum: Bing [Bot] and 10 guests

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.