FAQ  •  Register  •  Login

Timeout problem because of large file ammount

<<

vespa

Serviio newbie

Posts: 5

Joined: Thu Dec 28, 2017 12:02 pm

Post Thu Dec 28, 2017 12:13 pm

Timeout problem because of large file ammount

High to all,

I use servio for a long time without any problems, but now my number of files in the server has increased (about 350000 files in music section). So I have problems to open this music section, because I get a timeout.
There is a possibility to increase the default 60sec in the serviio.onlineContentTimeout file, but I dont have so much experience to understand the rules of the changing process. Can somebody please explain me how to increase the default setting to 180 sec please ?
A example string of the setting would be helpful and how to put it in the console.
I'm using windows 10 for the servio server.

Thanks a lot ! :D
<<

Paul C

DLNA master

Posts: 120

Joined: Wed Feb 17, 2016 3:46 pm

Location: Essex, UK

Post Sat Dec 30, 2017 12:11 pm

Re: Timeout problem because of large file ammount

I have not used the option serviio.onlineContentTimeout but I have recently been experimenting with other serviio system processes, namely serviio.socketBuffer and serviio.hdThumbnailResolution, which are configured in the same manner.
Relevant support info is found in http://serviio.org/index.php?option=com ... icle&id=43 and http://serviio.org/index.php?option=com ... e&id=21#q3

BEFORE YOU START however I wonder if serviio.onlineContentTimeout only applies to online (external) content and not to your local library.
So not sure if it will have the impact you desire.

The procedure is (if you are using Windows Service) go to Program Files/serviio/bin directory.
Open file ServiioService.exe.vmoptions with a text editor such as notepad.

Add new line -Dserviio.onlineContentTimeout=180 (180 being the value you suggested)

Close/save the file.

I stopped the server before the change and then restarted after. I then rebooted the PC to make sure the change had been activated.
Serviio 1.9.1 (PRO), DBpoweramp & Asset UPnP (registered), Acer Aspire One netbook, Windows 10 Pro, Denon DNP-730AE, NEET AirstreamPro renderer, Naim NAC72/NAP140 (x2), Celestion Ditton 25 and Spendor A5 speakers, WD TV Media Player (x2), Panasonic Blu-ray DMP-BDT360, Panasonic TV, Amazon Fire 7 HDX, BubbleUPnP control app, Mezzmo Android control App, Linn Mimik CD Player (now unused).
<<

vespa

Serviio newbie

Posts: 5

Joined: Thu Dec 28, 2017 12:02 pm

Post Sun Dec 31, 2017 10:18 am

Re: Timeout problem because of large file ammount

Thanks Paul, for your easy understandable description. Like you thought is has no effekt on my problem. There must be another reason wich delays the answer from the servio server and cuts after a short time the request ! :oops:
<<

Paul C

DLNA master

Posts: 120

Joined: Wed Feb 17, 2016 3:46 pm

Location: Essex, UK

Post Sun Dec 31, 2017 11:15 am

Re: Timeout problem because of large file ammount

You might have a look at whether serviio.socketBuffer would help the problem of the data throughput with your large library.
(I thought mine was getting big with 12,000 !).

See my conversation about it at
viewtopic.php?f=5&t=24222

Setup would be as I previously indicated but
-Dserviio.socketBuffer=131070 (this is double the default)

I am going to try 196605 but not done so yet.
Serviio 1.9.1 (PRO), DBpoweramp & Asset UPnP (registered), Acer Aspire One netbook, Windows 10 Pro, Denon DNP-730AE, NEET AirstreamPro renderer, Naim NAC72/NAP140 (x2), Celestion Ditton 25 and Spendor A5 speakers, WD TV Media Player (x2), Panasonic Blu-ray DMP-BDT360, Panasonic TV, Amazon Fire 7 HDX, BubbleUPnP control app, Mezzmo Android control App, Linn Mimik CD Player (now unused).
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16652

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Jan 02, 2018 9:37 am

Re: Timeout problem because of large file ammount

I assume the timeout is controlled by the device / TV. There might be some reasons for the timeout:
- the number of records make the DB queries slow
- the TV makes requests without limiting the results count (ie without pagination), which would bring possibly all your 350k records in one response
- the DB size is too much for your IO/CPU power of the server

To further limit the scope, you could enable detailed logging and see what queries take ages on the server side, and what requests does the TV make.
<<

vespa

Serviio newbie

Posts: 5

Joined: Thu Dec 28, 2017 12:02 pm

Post Wed Jan 10, 2018 4:23 pm

Re: Timeout problem because of large file ammount

Hi Paul,

Your hint to set the buffer to 196605 is working, thanks a lot for your help.
How is the buffer number increased, because 196605 is not a round number, I had chosen maby 190000 or something else ?
<<

vespa

Serviio newbie

Posts: 5

Joined: Thu Dec 28, 2017 12:02 pm

Post Wed Jan 10, 2018 4:29 pm

Re: Timeout problem because of large file ammount

To Petr,

When I open the video section there is no delay at all (about 5000) files. With the higher buffer of 196605, the reaction on TV is about 3 times longer, but works stable.
I don't suppose it is a TV problem, because the Android App of servio, and other UPNP apps off third party, are also not able to open the servio data of 350000 music files with standard buffer !
Just for info the library file of servio is at the moment 8.8 Gb big.
<<

Paul C

DLNA master

Posts: 120

Joined: Wed Feb 17, 2016 3:46 pm

Location: Essex, UK

Post Thu Jan 11, 2018 11:19 am

Re: Timeout problem because of large file ammount

vespa wrote:Hi Paul,

Your hint to set the buffer to 196605 is working, thanks a lot for your help.
How is the buffer number increased, because 196605 is not a round number, I had chosen maby 190000 or something else ?

Petr said "Default is 65535 (64kB). It's only used for the DLNA part at the moment." i.e. not the Media Browser.
viewtopic.php?f=5&t=24222

I thought the number was strange too being an odd number! Maybe it was a typo.
I just based it upon what Petr said.

Anyway I doubled it and have now tripled it to 196605, but I am not sure that there needs to be a relationship to the default - maybe any higher value is valid.
It seemed a logical basis.

Added note: 64kb is 65,536 bytes so maybe Petr's response was wrong. Double would then be 131072 and triple 196608.
Serviio 1.9.1 (PRO), DBpoweramp & Asset UPnP (registered), Acer Aspire One netbook, Windows 10 Pro, Denon DNP-730AE, NEET AirstreamPro renderer, Naim NAC72/NAP140 (x2), Celestion Ditton 25 and Spendor A5 speakers, WD TV Media Player (x2), Panasonic Blu-ray DMP-BDT360, Panasonic TV, Amazon Fire 7 HDX, BubbleUPnP control app, Mezzmo Android control App, Linn Mimik CD Player (now unused).
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16652

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Jan 11, 2018 8:12 pm

Re: Timeout problem because of large file ammount

With this large library, you might want to increase the memory for Serviio as well - it might make it faster. Look at the -Xmx value in the ServiioService.exe.vmoptions file
<<

vespa

Serviio newbie

Posts: 5

Joined: Thu Dec 28, 2017 12:02 pm

Post Tue Jan 16, 2018 9:28 pm

Re: Timeout problem because of large file ammount

Hi Petr,

I tried to increase the -Xmx value, but there is no positive effect on this. But at the moment servio works, a little slow for the first time to load the folder struckture, but after that I have no problems. When I have a little time I will read more about servio in this forum. Thanks for this great software, it is the only one I found thats works stable on my LG TV ! :P :D :P

Return to Serviio Support & Help

Who is online

Users browsing this forum: No registered users and 12 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.