Page 1 of 1

Bug Report Indexing of Audio Genres and missing album tracks

PostPosted: Thu Jan 11, 2018 4:49 pm
by Paul C
I have noted a category under Audio/Genres of "Unknown".

Examining the metadata (outside Serviio) for these tracks it is correct.
This appears to be an occasional error in the indexing process.

By editing the metadata say by adding a space in the comment field results in the track being re-indexed and classified in its correct genres category (without any change having been made to the Genres).

Usually there may be just one or two tracks from an album (bearing in mind an album usually has the same genres set for all tracks) in the "Unknown" category.
I can see no pattern and the tracks come from differing Genres.

IMPORTANTLY I have just discovered that these tracks are not in the Artist/Album lists !!!!!! i.e. THEY ARE MISSING FROM THE ALBUMS in the Control App.

(this is not a new issue as I have used my workaround that clears them up in the past. I was not aware they were missing from the albums).
Force Refresh does not appear to resolve this issue. Also if you do not have Genres enabled as a display option you may never know the tracks are missing.
I think this is an urgent bug.

Re: Bug Report Indexing of Audio Genres and missing album tr

PostPosted: Fri Jan 12, 2018 4:30 pm
by lagunaa
You would turn on detailed logging, see what's the cause and create issue.
Cheers.

Re: Bug Report Indexing of Audio Genres and missing album tr

PostPosted: Fri Jan 12, 2018 7:45 pm
by Paul C
lagunaa wrote:You would turn on detailed logging, see what's the cause and create issue.
Cheers.


Surely that would not be easy as the problem is only occasional and not able to detect in advance?

Re: Bug Report Indexing of Audio Genres and missing album tr

PostPosted: Sat Jan 13, 2018 12:58 am
by freaknik
Force refresh library and it should reindex then watch the log. I use baretail in windows.

Re: Bug Report Indexing of Audio Genres and missing album tr

PostPosted: Sat Jan 20, 2018 12:25 pm
by Paul C
freaknik wrote:Force refresh library and it should reindex then watch the log. I use baretail in windows.


Force Refresh (as I indicated) does not clear these items.
I have tried it again twice.

Having updated some tracks with amended artwork I now have some more "Unknown" genres items.
Again they do not appear in the Artist, album, or album artist indexes.
Example Nilsson tracks 1, 5, 11,12 and 15 are in unknown genres AND are all missing from indexes (see attachments).

Added to BitBucket - #1043: Indexing of Audio Genres and missing album tracks

Re: Bug Report Indexing of Audio Genres and missing album tr

PostPosted: Mon Jan 22, 2018 8:58 am
by zip
can you enable detailed log and try to add some more with the same result? I won't be able to reproduce it otherwise

Re: Bug Report Indexing of Audio Genres and missing album tr

PostPosted: Mon Jan 22, 2018 6:52 pm
by Paul C
zip wrote:can you enable detailed log and try to add some more with the same result? I won't be able to reproduce it otherwise

I enclose log files that trapped items going into the genres/unknown category.

I amalgamated three folders of "The Very Best of Legends" (Disc 1, Disc 2, Disc 3) into a single album folder.
This involved changes to the metadata for album name, disc no , track names and track numbers.

A number of the files (13 of 65) went into genres/unknown.
The 13 do not appear in the Album/Artist indexes.

The meta data is correct.

Serviio created 5 logs (of 501k) which are zipped.

Re: Bug Report Indexing of Audio Genres and missing album tr

PostPosted: Mon Jan 22, 2018 7:08 pm
by Paul C
I have discovered a different audio metadata indexing issue. It is covered by the same logs I attached.

I changed an album title from "Fleetwood Mac (remaster 2004)" to "Fleetwood Mac (Remaster 2004)".
It has not taken effect despite Force Refresh.

I then tried altering to "Fleetwood Mac (2004 Remaster 2004)" and then back to "Fleetwood Mac (Remaster 2004)" all with no effect.

It occurred to me I had also altered the album folder name to "Fleetwood Mac (Remaster 2004)" at the same time I made the initial change - could this be a factor.

UPDATE: I removed the folder from the media library and then re-added it (without metadata change) and it now indexed perfectly OK.

Re: Bug Report Indexing of Audio Genres and missing album tr

PostPosted: Mon Jan 22, 2018 10:32 pm
by zip
ok, for some reason Serviio doesn't see any metadata in the file

  Code:
2018-01-22 17:35:43,464 DEBUG [MetadataExtractionCoordinator] Metadata found via extractor EMBEDDED: AudioMetadata [container=FLAC, codec=FLAC, duration=182, bitrate=864, channels=2, sampleFrequency=44100, fileSize=19711932, filePath=E:\digital-music-server\music\Various Artists\The Very Best of Legends, Disc 1\01 Queen - We Are the Champions.flac, title=01 Queen - We Are the Champions, date=Mon Jan 22 17:35:31 GMT 2018, ]


Any chance you can send me this updated flac file to have a look?

Re: Bug Report Indexing of Audio Genres and missing album tr

PostPosted: Mon Jan 22, 2018 10:47 pm
by Paul C
zip wrote:ok, for some reason Serviio doesn't see any metadata in the file

  Code:
2018-01-22 17:35:43,464 DEBUG [MetadataExtractionCoordinator] Metadata found via extractor EMBEDDED: AudioMetadata [container=FLAC, codec=FLAC, duration=182, bitrate=864, channels=2, sampleFrequency=44100, fileSize=19711932, filePath=E:\digital-music-server\music\Various Artists\The Very Best of Legends, Disc 1\01 Queen - We Are the Champions.flac, title=01 Queen - We Are the Champions, date=Mon Jan 22 17:35:31 GMT 2018, ]


Any chance you can send me this updated flac file to have a look?

How can I send it due to file size?

Re: Bug Report Indexing of Audio Genres and missing album tr

PostPosted: Mon Jan 22, 2018 11:23 pm
by Paul C
file is at (zipped)
removed

Subsequently I updated them without metadata change and they all indexed correctly !

Re: Bug Report Indexing of Audio Genres and missing album tr

PostPosted: Tue Jan 23, 2018 8:16 pm
by zip
Yes, this file indexes correctly.

Is it the same version that indexed with Unknown genre? I wonder if it can be something to do with the metadata tool and how it stores data. Maybe it makes the updates in phases, Serviio detect the initial step (with missing data), and then ignores the other phases (when it fill the metadata back in) ... totally guessing though.

Re: Bug Report Indexing of Audio Genres and missing album tr

PostPosted: Wed Jan 24, 2018 1:43 am
by Paul C
zip wrote:Yes, this file indexes correctly.

Is it the same version that indexed with Unknown genre? I wonder if it can be something to do with the metadata tool and how it stores data. Maybe it makes the updates in phases, Serviio detect the initial step (with missing data), and then ignores the other phases (when it fill the metadata back in) ... totally guessing though.

It is the same file version that identified as unknown.
It did clear when I reran later as did the other 12 files.
The metadata tool is dBpoweramp Edit ID Tag (in this case Multiple Files version).
I was running it over the network to the library files so your theory about timing and phases may be correct.

However I currently have three files in unknown that were edited and then uploaded as files so timing and phases may not be true in this case.
I can send these files if you wish.
Also "Force Refresh" appears not to see these "missing" files so they stay missing.