FAQ  •  Register  •  Login

Disable check for external port mapping?

<<

SteveDinn

Serviio newbie

Posts: 13

Joined: Mon Nov 24, 2014 9:13 pm

Post Mon Feb 05, 2018 3:17 pm

Disable check for external port mapping?

This error is in my logs hundreds and hundreds of times. Is there a way I can just stop it from doing this check? My router doesn't let me hit the external IP from inside the NAT so it's never going to succeed.

  Code:
2018-02-05 10:53:58,281 INFO  [PortMappingChecker] Running a check for external mapping of port 23524 on '[REDACTED]'
2018-02-05 10:54:18,445 WARN  [UserDataUpdater] There was an error updating user data
java.net.SocketTimeoutException: connect timed out
        at java.net.PlainSocketImpl.socketConnect(java.base@9-internal/Native Method)
        at java.net.AbstractPlainSocketImpl.doConnect(java.base@9-internal/AbstractPlainSocketImpl.java:405)
        at java.net.AbstractPlainSocketImpl.connectToAddress(java.base@9-internal/AbstractPlainSocketImpl.java:248)
        at java.net.AbstractPlainSocketImpl.connect(java.base@9-internal/AbstractPlainSocketImpl.java:230)
        at java.net.SocksSocketImpl.connect(java.base@9-internal/SocksSocketImpl.java:402)
        at java.net.Socket.connect(java.base@9-internal/Socket.java:591)
        at sun.net.NetworkClient.doConnect(java.base@9-internal/NetworkClient.java:175)
        at sun.net.www.http.HttpClient.openServer(java.base@9-internal/HttpClient.java:432)
        at sun.net.www.http.HttpClient.openServer(java.base@9-internal/HttpClient.java:527)
        at sun.net.www.http.HttpClient.<init>(java.base@9-internal/HttpClient.java:211)
        at sun.net.www.http.HttpClient.New(java.base@9-internal/HttpClient.java:308)
        at sun.net.www.http.HttpClient.New(java.base@9-internal/HttpClient.java:326)
        at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(java.base@9-internal/HttpURLConnection.java:1172)
        at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(java.base@9-internal/HttpURLConnection.java:1108)
        at sun.net.www.protocol.http.HttpURLConnection.plainConnect(java.base@9-internal/HttpURLConnection.java:1002)
        at sun.net.www.protocol.http.HttpURLConnection.connect(java.base@9-internal/HttpURLConnection.java:936)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(java.base@9-internal/HttpURLConnection.java:1511)
        at sun.net.www.protocol.http.HttpURLConnection.getInputStream(java.base@9-internal/HttpURLConnection.java:1439)
        at java.net.HttpURLConnection.getResponseCode(java.base@9-internal/HttpURLConnection.java:480)
        at org.serviio.util.HttpClient.retrieveStreamFromConnection(HttpClient.java:173)
        at org.serviio.util.HttpClient.getStreamFromURL(HttpClient.java:103)
        at org.serviio.util.HttpClient.retrieveTextFileFromURL(HttpClient.java:42)
        at org.serviio.upnp.service.contentdirectory.rest.access.TuqPortCheckerProvider.isPortOpen(TuqPortCheckerProvider.java:20)
        at org.serviio.upnp.service.contentdirectory.rest.access.PortMappingChecker.isPortOpen(PortMappingChecker.java:39)
        at org.serviio.upnp.service.contentdirectory.rest.access.UserDataUpdater.isSSLPortOpen(UserDataUpdater.java:178)
        at org.serviio.upnp.service.contentdirectory.rest.access.UserDataUpdater.doUpdateUserData(UserDataUpdater.java:101)
        at org.serviio.upnp.service.contentdirectory.rest.access.UserDataUpdater.access$200(UserDataUpdater.java:32)
        at org.serviio.upnp.service.contentdirectory.rest.access.UserDataUpdater$UserDataUpdaterRunner.run(UserDataUpdater.java:193)
        at java.util.concurrent.Executors$RunnableAdapter.call(java.base@9-internal/Executors.java:514)
        at java.util.concurrent.FutureTask.runAndReset(java.base@9-internal/FutureTask.java:307)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(java.base@9-internal/ScheduledThreadPoolExecutor.java:300)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(java.base@9-internal/ThreadPoolExecutor.java:1158)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(java.base@9-internal/ThreadPoolExecutor.java:632)
        at java.lang.Thread.run(java.base@9-internal/Thread.java:804)
<<

DenyAll

DLNA master

Posts: 2169

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Mon Feb 05, 2018 9:59 pm

Re: Disable check for external port mapping?

Try
Turn off: Automatically configure your router to allow incoming Internet connections in Serviio Console, Remote tab.
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

SteveDinn

Serviio newbie

Posts: 13

Joined: Mon Nov 24, 2014 9:13 pm

Post Tue Feb 06, 2018 3:05 am

Re: Disable check for external port mapping?

That option has never been on in my installation. If only it were that simple.
<<

freaknik

User avatar

DLNA master

Posts: 178

Joined: Thu Mar 27, 2014 2:05 pm

Post Thu Feb 08, 2018 12:48 pm

Re: Disable check for external port mapping?

Capture.JPG
Capture.JPG (44.04 KiB) Viewed 470 times


You need 1.9 then I guess.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16749

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Feb 08, 2018 8:57 pm

Re: Disable check for external port mapping?

It's not related actually. This is to keep the public IP up-to-date for the incoming Alexa skill. 1.9.1 should fix this error message though
<<

SteveDinn

Serviio newbie

Posts: 13

Joined: Mon Nov 24, 2014 9:13 pm

Post Fri Feb 09, 2018 5:32 am

Re: Disable check for external port mapping?

freaknik wrote:You need 1.9 then I guess.


What I mean to say is that this option has never been checked in my installation. I am running v1.9.

Return to Serviio Support & Help

Who is online

Users browsing this forum: No registered users and 8 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.