FAQ  •  Register  •  Login

UPnP interface is gone while Web interface still is visible

<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16714

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Feb 21, 2018 10:30 am

Re: UPnP interface is gone while Web interface still is visi

So localhost works because it's a loopback address and Serviio skips some steps if the client is a loopback address.

  Code:
Incoming request from /127.0.0.1:19422


In the IP case, it looks like

  Code:
Incoming request from /192.168.64.4:19452


It resolves to the server's IP (in both cases), because you're making the request from the same machine (I assume).

Then, in the IP case, it takes 5 minutes, because that piece of code is blocked by another renderer processing (when Serviio is looking for new renderers), which actually times out

  Code:
Error while retrieving renderer description: Read timed out


So you have to solve this - why Serviio cannot connect to the renderers. For example, is this accessible for Serviio?

  Code:
http://192.168.64.83:52525/root_XXYY.xml
<<

rhoyer78

Serviio newbie

Posts: 7

Joined: Thu Feb 15, 2018 10:30 am

Post Wed Feb 21, 2018 2:49 pm

Re: UPnP interface is gone while Web interface still is visi

DEBUG [RendererManager] Retrieve device description from http://192.168.64.83:52525/root_XXYY.xml


192.168.64.83 is a "Renkforce IR 1" InternetRadio

The internal Webserver on Port 52525 cashed, after rebooting the "Renkforce IR 1" Serviio showed up again on all devices...

Thanks a lot!

Maybe the RendererManager should not constantly try to poll faulty clients and indicate/block faulty clients at the status page..?
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16714

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Feb 22, 2018 2:22 pm

Re: UPnP interface is gone while Web interface still is visi

yeah, I just removed the blocking around the call, so if some are blocking, other clients can still be served
<<

rhoyer78

Serviio newbie

Posts: 7

Joined: Thu Feb 15, 2018 10:30 am

Post Thu Feb 22, 2018 5:33 pm

Re: UPnP interface is gone while Web interface still is visi

Wow that was fast! Thanks a lot and keep up the good work!

Image
Previous

Return to Serviio Support & Help

Who is online

Users browsing this forum: No registered users and 6 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.