FAQ  •  Register  •  Login

Bug - Force terminating the TCP socket causes 100% CPU usage

<<

yegor

Serviio newbie

Posts: 1

Joined: Thu May 10, 2018 2:32 pm

Post Thu May 10, 2018 2:35 pm

Bug - Force terminating the TCP socket causes 100% CPU usage

1. Run Serviio server
2. Force terminate the TCP socket with this app: https://www.nirsoft.net/utils/cports.html
3. ServiioService.exe now consumes 100% of the CPU

This happens on any Windows 7-10 machine.

Windscribe VPN terminates all TCP sockets when the connection is established to prevent leaks, which makes the computer unusable when Serviio is running.
<<

jaqual

Serviio newbie

Posts: 1

Joined: Fri May 11, 2018 8:45 pm

Post Fri May 11, 2018 8:50 pm

Re: Bug - Force terminating the TCP socket causes 100% CPU u

+1

I've been seeing this bug for a couple of weeks now but I never suspected the TCP issue. I use Windscribe also, and can verify that as soon as the firewall is activated, ServiioService.exe CPU usage goes straight to 99%.
<<

storex

Serviio newbie

Posts: 1

Joined: Sat May 12, 2018 6:49 am

Post Sat May 12, 2018 6:59 am

Re: Bug - Force terminating the TCP socket causes 100% CPU u

i have the same issue, hoping to for a fix in this thread; windscribe + serviio = 100 cpu
hmm maybe the subject line should be changed so others who also has this problem might find the thread ?
<<

randomcamden

Serviio newbie

Posts: 1

Joined: Mon May 28, 2018 8:42 am

Post Mon May 28, 2018 8:46 am

Re: Bug - Force terminating the TCP socket causes 100% CPU u

Another victim here of the Windscribe/Serviio combo. Great catch for whoever found the link between the two. This thread came up as #1 on a Google search for "Serviio Windscribe CPU" so was easy to come across.
Looking forward for a fix!

Return to Serviio Support & Help

Who is online

Users browsing this forum: No registered users and 12 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.