FAQ  •  Register  •  Login

After upgrade to Serviio 1.6 online plugins stopped to work

<<

qanatoz

User avatar

Serviio lover

Posts: 64

Joined: Sun Feb 19, 2012 8:33 pm

Post Sat Jan 23, 2016 9:37 pm

After upgrade to Serviio 1.6 online plugins stopped to work

Hi,

I facing some issues with playing online resources after upgrade to Serviio 1.6
Serviio is not able to retrieve any online item from web resource plugins.
The same plugins was working fine with version 1.5.2

inside error serviio.log I can see a lot messages like in example below:

  Code:
016-01-23 23:25:47,237 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: Cover image for feed item 10000011130007954 cannot be found
2016-01-23 23:25:47,242 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: Cover image for feed item 10000011130005455 cannot be found
2016-01-23 23:25:47,243 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: Cover image for feed item 10000011130008129 cannot be found
2016-01-23 23:25:47,243 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: Cover image for feed item 10000011130006396 cannot be found
2016-01-23 23:25:47,244 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: Cover image for feed item 10000011130007954 cannot be found
2016-01-23 23:25:47,250 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: Cover image for feed item 10000011130001741 cannot be found
2016-01-23 23:25:47,251 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: Cover image for feed item 10000011130008129 cannot be found
2016-01-23 23:25:47,253 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: Cover image for feed item 10000011130001741 cannot be found
2016-01-23 23:25:47,265 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: Cover image for feed item 10000011130001741 cannot be found
2016-01-23 23:25:47,269 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: Cover image for feed item 10000011130001741 cannot be found
2016-01-23 23:25:47,283 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: Cover image for feed item 10000011130001741 cannot be found
2016-01-23 23:25:47,285 WARN  [ResourceDeliveryProcessor] Error while processing resource, sending back 404 error. Message: Cover image for feed item 10000011130001741 cannot be found


There is also many warn messages related to fails retrieving online item information
For example:
  Code:
2016-01-23 23:26:36,589 WARN  [FeedUpdaterWorker] Failed to retrieve online item information for http://..................mp4. It might not play.
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.online.metadata.FeedUpdaterWorker.retrieveMetadata(FeedUpdaterWorker.java:324)
   at org.serviio.library.online.metadata.FeedUpdaterWorker.retrieveTechnicalMetadata(FeedUpdaterWorker.java:243)
   at org.serviio.library.online.metadata.FeedUpdaterWorker.run(FeedUpdaterWorker.java:122)
   at java.lang.Thread.run(Thread.java:745)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.metadata.FFmpegMetadataRetriever.validateMandatoryMetadata(FFmpegMetadataRetriever.java:467)
   at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:100)
   at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveOnlineMetadata(FFmpegMetadataRetriever.java:138)
   at org.serviio.library.online.metadata.FeedUpdaterWorker.retrieveMetadata(FeedUpdaterWorker.java:303)
   ... 3 more
2016-01-23 23:32:38,716 WARN  [FeedUpdaterWorker] Failed to retrieve online item information for http://...........mp4. It might not play.
java.io.IOException: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.online.metadata.FeedUpdaterWorker.retrieveMetadata(FeedUpdaterWorker.java:324)
   at org.serviio.library.online.metadata.FeedUpdaterWorker.retrieveTechnicalMetadata(FeedUpdaterWorker.java:243)
   at org.serviio.library.online.metadata.FeedUpdaterWorker.run(FeedUpdaterWorker.java:122)
   at java.lang.Thread.run(Thread.java:745)
Caused by: org.serviio.library.local.metadata.extractor.InvalidMediaFormatException: Unknown video file type.
   at org.serviio.library.metadata.FFmpegMetadataRetriever.validateMandatoryMetadata(FFmpegMetadataRetriever.java:467)
   at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveMetadata(FFmpegMetadataRetriever.java:100)
   at org.serviio.library.metadata.FFmpegMetadataRetriever.retrieveOnlineMetadata(FFmpegMetadataRetriever.java:138)
   at org.serviio.library.online.metadata.FeedUpdaterWorker.retrieveMetadata(FeedUpdaterWorker.java:303)
   ... 3 more

*I removed the actual links for resources from the log above but all them is valid and ffmpeg is able to fetch them then running from command line.

Any ideas??
<<

jhb50

DLNA master

Posts: 2854

Joined: Thu Jun 30, 2011 9:32 pm

Post Sat Jan 23, 2016 10:59 pm

Re: After upgrade to Serviio 1.6 online plugins stopped to w

I have never seen an on line link of the form http://..................mp4. AFAIC the http streaming protocol requires a playlist of the form http://..................m3u and other streams use protocols like rtmp:
Without being able to test your plugin to analyse the failure there is little I can do. All my many plugins work fine in 1.6
<<

qanatoz

User avatar

Serviio lover

Posts: 64

Joined: Sun Feb 19, 2012 8:33 pm

Post Sat Jan 23, 2016 11:13 pm

Re: After upgrade to Serviio 1.6 online plugins stopped to w

jhb50 wrote:I have never seen an on line link of the form http://..................mp4. AFAIC the http streaming protocol requires a playlist of the form http://..................m3u and other streams use protocols like rtmp:
Without being able to test your plugin to analyse the failure there is little I can do. All my many plugins work fine in 1.6


I just removed the actual links for resources from the log to not put links fro video files in the forum.

Newer mind, I figured out. Uninstalled Serviio and installed it again from scratch and now all works fine. Seems like some issue with Serviio DB after upgrade.

Return to User experiences

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.