FAQ  •  Register  •  Login

Panasonic UHD TV 2016 DXW780 Series

<<

84stangman

Serviio newbie

Posts: 3

Joined: Fri Apr 15, 2016 4:49 pm

Post Fri Apr 15, 2016 4:53 pm

Panasonic UHD TV 2016 DXW780 Series

Hello Guys,


I have a newbie question for my TV which is a Panasonic TX-58DXW784 (European 58" 4K Viera)

- I have limited options to select from the profiles the closest to my needs is good with the audio but stretches most of the videos (I presume where transcoding is needed? ) leaving no bar at the top and bottom...

Is there any setting I can change to be able to play AC3/DTS and so on with a normal Aspect Ratio?

Thanks in advance..
<<

DenyAll

DLNA master

Posts: 2071

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Fri Apr 15, 2016 10:57 pm

Re: Panasonic UHD TV 2016 DXW780 Series

Which profile are you using?
Have you tried adjusting using the Aspect Ratio button on your remote?
As a test, what happens if you play the movie after setting your tv to use the Generic DLNA profile?
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

84stangman

Serviio newbie

Posts: 3

Joined: Fri Apr 15, 2016 4:49 pm

Post Sun Apr 17, 2016 10:10 am

Re: Panasonic UHD TV 2016 DXW780 Series

DenyAll wrote:Which profile are you using?
Have you tried adjusting using the Aspect Ratio button on your remote?
As a test, what happens if you play the movie after setting your tv to use the Generic DLNA profile?



Hey There,

adjusting with the button did not help, it just makes the picture smaller, but there is no smart adjustment like in Samsung Devices

As for the Generic DLNA, the aspect ratio is just fine, but then the audio is not playing in most of the cases.... hence I tried the Panasonic profiles :S

Any suggestion I could do?
<<

84stangman

Serviio newbie

Posts: 3

Joined: Fri Apr 15, 2016 4:49 pm

Post Sun Apr 17, 2016 11:04 am

Re: Panasonic UHD TV 2016 DXW780 Series

Hi,

so I chose the 2013 Panasonic profile, and at first the video is good but no audio.

So i change this line, and after this I have audio, but the aspect ratio is wrong.... I don't find it how to set it right DAR does not help either

</Video>
<!-- remux FLAC/TrueHD in MKV/MP4 to AC3, DTS (MP4) to AC3 -->
<Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384" forceInheritance="true">
<!-- Matches container="matroska" vCodec="h264" aCodec="dca" / --> <!-- Uncomment this line if DTS is not supported natively --> -------------------------------->>>> This one to have sound.
<Matches container="matroska" vCodec="h264" aCodec="dts-hd" />
<Matches container="matroska" vCodec="h264" aCodec="flac" />
<Matches container="matroska" vCodec="h264" aCodec="truehd" />
<Matches container="mp4" vCodec="h264" aCodec="dca" /> <!-- E6 support??, remove this line -->
<<

DenyAll

DLNA master

Posts: 2071

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Mon Apr 18, 2016 1:45 am

Re: Panasonic UHD TV 2016 DXW780 Series

Try the Panasonic Viera 2010 to see if it fixes the aspect ratio issue.

If it does - you have two choices:

In the Panasonic 2013 profile, keep the change you made (un-commenting that line) and remove the three lines:

  Code:
</Video>
<!-- remux FLAC/TrueHD in MKV/MP4 to AC3, DTS (MP4) to AC3 -->
<Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384" forceInheritance="true">
This will force the both the video and audio to be transcoded, and should fix the aspect ratio. Remember after changing the profiles.xml file to restart your PC/Serviio service.

OR

Use something like mkvmerge or XMedia Recode to move/add an AC-3 audio track to the file as the first audio stream. This will enable the video to be played natively (without transcoding, which is always better).
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

herby88

Serviio newbie

Posts: 10

Joined: Sun Jan 08, 2017 2:33 pm

Post Mon Jan 09, 2017 12:19 pm

Re: Panasonic UHD TV 2016 DXW780 Series

Hi :)
i'm currently facing the same Problem.
Changing the line in 2013 profile fixed the DTS transcode for me.
Starting a 4k/10bit DTS will also start Video trancode which Ends in to high CPU load :(

found this Profile in some Posts here, but wont get it to work (Validation error).
could i get some help? or add additional lines to the 2013?

Profile:
  Code:
   <Profile id="vieratx55" name="Panasonic Viera (TX-55)" extendsProfileId="1">
      <!-- Panasonic Viera TX 2015 Models:
      Supports native streaming of mainstream MP4, MKV and XVid files -->
      <ContentDirectoryMessageBuilder>org.serviio.upnp.service.contentdirectory.PacketVideoDLNAMessageBuilder</ContentDirectoryMessageBuilder>
      <Transcoding>
         <!-- Transcode h264 videos with profile level > 4.1 to mpegts with ac3 audio -->
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" DAR="16:9" targetACodec="ac3" aBitrate="384" forceInheritance="true">
            <Matches container="*" vCodec="h264" profile="high_10" />
            <Matches container="mp4" vCodec="mjpeg" />
            <Matches container="mpeg" vCodec="mpeg1video" />
            <Matches container="matroska" vCodec="vp8" />     
            <Matches container="matroska" vCodec="vp9" />
            <Matches container="ogg" />
            <Matches container="rm" />
         </Video>
         <!-- remux FLAC/TrueHD in MKV/MP4 to AC3, DTS (MP4) to AC3 -->
         <Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384" forceInheritance="true">
            <Matches container="*" vCodec="h264" aCodec="dca" /> <!-- Uncomment this line if DTS is not supported natively -->
            <Matches container="*" vCodec="h264" aCodec="dts-hd" />
            <Matches container="*" vCodec="h265" aCodec="dts-hd" />
            <!--Matches container="matroska" vCodec="h264" aCodec="flac" / -->
            <Matches container="*" vCodec="h264" aCodec="truehd" />
         </Video>
         <Audio targetContainer="lpcm" forceInheritance="true">
            <Matches container="ogg" />
            <Matches container="asf" />
            <Matches container="adts" />
            <Matches container="mpc" />
            <Matches container="ape" />
            <Matches container="dsf" />
         </Audio>
      </Transcoding>
      <GenericTranscoding>
         <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" DAR="16:9" aBitrate="384" />
      </GenericTranscoding>
      <Subtitles>
         <SoftSubs mime-type="text/srt" />
      </Subtitles>
      <ThumbnailsResolution>HD</ThumbnailsResolution>
   </Profile>


already removed the Detection part, but now Log Reports
  Code:
2017-01-08 15:52:55,476 ERROR [XmlUtils] XML Profiles.xsd didn't pass validation, reason: cvc-complex-type.2.3: Element 'Video' darf keine Zeichen [untergeordnete Elemente] haben, da der Contenttyp des Typs 'element-only' ist.
2017-01-08 15:52:55,477 ERROR [MediaServer] An unexpected error occured. Ending the application. Message: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.
java.lang.RuntimeException: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.
   at org.serviio.profile.ProfileManager.parseProfilesFromFile(ProfileManager.java:183)
   at org.serviio.profile.ProfileManager.loadProfiles(ProfileManager.java:156)
   at org.serviio.MediaServer.main(MediaServer.java:134)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
   at java.lang.reflect.Method.invoke(Method.java:498)
   at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:62)
   at com.exe4j.runtime.WinLauncher$2.run(WinLauncher.java:96)
Caused by: org.serviio.profile.ProfilesDefinitionException: Profiles XML file is not valid (according to the schema). Check the log.
   at org.serviio.profile.ProfilesDefinitionParser.validateXML(ProfilesDefinitionParser.java:1036)
   at org.serviio.profile.ProfilesDefinitionParser.parseDefinition(ProfilesDefinitionParser.java:162)
   at org.serviio.profile.ProfileManager.parseProfilesFromFile(ProfileManager.java:181)
   ... 8 more

Kind Regards
Herby
<<

herby88

Serviio newbie

Posts: 10

Joined: Sun Jan 08, 2017 2:33 pm

Post Tue Jan 17, 2017 2:48 pm

Re: Panasonic UHD TV 2016 DXW780 Series

Hi there,
any working Profile for Pana 2015-16 out there?
Many Posts and views on this and other threads, but no final answer :(
Kind regards 
<<

DenyAll

DLNA master

Posts: 2071

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Mon Apr 17, 2017 10:00 am

Re: Panasonic UHD TV 2016 DXW780 Series

DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.

Return to Transcoding

Who is online

Users browsing this forum: No registered users and 5 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.