FAQ  •  Register  •  Login

No embedded TX3G Subtitles in MP4's

<<

freaknik

User avatar

DLNA master

Posts: 107

Joined: Thu Mar 27, 2014 2:05 pm

Post Sun Dec 18, 2016 6:46 pm

No embedded TX3G Subtitles in MP4's

Hey I have a lot of mp4 videos with TX3G subtitles. FFMPEG detects them and they show in vlc but not media player classic or on serviio. I used ffmpeg to extract them to .srt format and named them the same as the MP4 and that fixed it.

Just wondering why it can't natively pick up the subtitle unless it's in an external file? It didn't take that long but I thought I would post here in case someone else has the same problem:

  Code:
ffmpeg -i Movie.mp4 -map 0:s:0 Movie.srt


I love serviio 1.8 so far, keep up the good work!
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16497

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Wed Dec 21, 2016 8:42 pm

Re: No embedded TX3G Subtitles in MP4's

this subtitle type is not supported by Serviio. If you want to be able to extract them for you by Serviio, create a bitbucket ticket and attach ffmpeg -i of a file incl. the subs.

I doubt any player will support them natively (ie embedded without Serviio either extracting them to srt or burning in).
<<

freaknik

User avatar

DLNA master

Posts: 107

Joined: Thu Mar 27, 2014 2:05 pm

Post Thu Dec 22, 2016 5:39 pm

Re: No embedded TX3G Subtitles in MP4's

ok will do and thanks for the info.

Return to Transcoding

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.