FAQ  •  Register  •  Login

MPEG2 files return Audio Format Not Supported

<<

Belgarion

Serviio newbie

Posts: 8

Joined: Sat Dec 03, 2016 4:10 pm

Post Fri Mar 17, 2017 10:00 pm

MPEG2 files return Audio Format Not Supported

Hi.
I hope this is the correct forum for this. I upgraded to 1.8 for the Synology NAS. Whenever I try to play files which show on screen as having an MPEG2 audio format, I get AUDIO FORMAT NOT SUPPORTED. I get the picture with no sound. This seems to be new with my 1.8 upgrade.

I haven't figured out how to downgrade to 1.61 yet. Is there something I can check or some modification I can make (to the transcoding?) that will correct this problem? I am also trying how to access the Serviio logs on the NAS from a Windows PC. Haven't found them yet, but I know they are there.

I would really appreciate any suggestions. BTW, the same problem occurs regardless of the set on which I try to view the files.

TIA.
Bel
<<

atc98092

User avatar

DLNA master

Posts: 2269

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state) - temporary assignment to Washington DC

Post Fri Mar 17, 2017 11:45 pm

Re: MPEG2 files return Audio Format Not Supported

What are you trying to play the video on? What is the video and audio codec contained in the video file, and what container (what is the file extension, i.e. mpg, m2ts, mp4, avi, etc.)? What profile is set in the Serviio console for your player?
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging Identify video file contents
<<

Belgarion

Serviio newbie

Posts: 8

Joined: Sat Dec 03, 2016 4:10 pm

Post Sun Mar 19, 2017 7:15 pm

Re: MPEG2 files return Audio Format Not Supported

I have tried to play the video on an LG 32 " TV. VLC reports the following:
Stream 0:
Codec: MPEG-H Part2/HEVC(H.265) (hevc)
Decoded format: Planar 4:2:0 YUV

Stream 1:
Type: Audio
Codec: A52 Audio (aka AC3) (a52)

The filetype is MKV. Castle Season 7 Episode 1. However, the same applies for the entirety of Season 7 (23 episodes). The top left of the screen shows MPEG2 | UNKNOWN | 1276X716.

How can I tell what profile is set in the Serviio console? I looked in the Transcoding section of the console, but all it shows is a filepath (transcoded files location: /volume1/@tmp) and number of cores to use (Optimal). I am wondering if the filepath is the default. When I first had problems I changed it (the problem at that time was the wrong release of Java).
<<

DenyAll

DLNA master

Posts: 2074

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Mon Mar 20, 2017 12:11 am

Re: MPEG2 files return Audio Format Not Supported

The renderer profile is listed against your devices IP address on the Status page of Serviio Console - under Connected Devices.
I'm surprised that you NAS has the power to transcode H265 files. Try setting the profile to Generic DLNA if not already.
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

Belgarion

Serviio newbie

Posts: 8

Joined: Sat Dec 03, 2016 4:10 pm

Post Mon Mar 20, 2017 8:30 pm

Re: MPEG2 files return Audio Format Not Supported

Hi.
I tried your suggestion, but the profile was already set to Generic. I tried switching it to LG, but that had no effect - I still didn't get audio. And I noticed that the video halted a lot after the first 15-20 seconds. I found information elsewhere on the forum on getting the log files from a NAS. I took a look after trying to play the files again, but nothing that seemed to be an error appeared. I am now wondering if "power" is the problem and my NAS just is not strong enough to stream the files.
<<

atc98092

User avatar

DLNA master

Posts: 2269

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state) - temporary assignment to Washington DC

Post Mon Mar 20, 2017 9:19 pm

Re: MPEG2 files return Audio Format Not Supported

If your LG supports H.265 video (i.e. it's a UHD set), then that file should play without transcoding. Since you are getting an error specifically about the audio, I don't think anything is being transcoded. Yes, your NAS probably doesn't have the power to transcode H.265, but again your TV doesn't appear to need it. Since the error is specific to audio, my guess is there's something amiss with your audio track. But if it played with 1.6.1, then I really don't understand what the issue might be.

If you still have the install files for 1.6.1, you should be able to replace your current installation. I'm not familiar with setup procedures with a NAS, so someone else will have to step in there.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging Identify video file contents
<<

DenyAll

DLNA master

Posts: 2074

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Tue Mar 21, 2017 10:19 am

Re: MPEG2 files return Audio Format Not Supported

Before reverting back - it's easy to tell if the file is being transcoded in 1.8. While the file is playing either:

  • in Serviio Console there will be a small Play icon next to the device on the Status tab. If you click on it it will show give you info on what is playing. The icon is orange when transcoding and blue when playing the file natively; or
  • In your browser type "http://NAS IP Address:23423/rest/playback-status". On the resulting screen check the <itemTranscoded> tag for your device. It's true when transcoding and false when not
If it is being transcoded try disabling subtitles (and Save, and test for transcoding again after restarting the playback. You may need to restart Serviio/your NAS).
DenyAll
Panasonic Viera CS610A | Panasonic Viera V20A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.9 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

Belgarion

Serviio newbie

Posts: 8

Joined: Sat Dec 03, 2016 4:10 pm

Post Tue Mar 21, 2017 9:18 pm

Re: MPEG2 files return Audio Format Not Supported

Hi.
I've been looking for the 1.61 files. No luck. :(

I will try the things DenyAll suggested and let you know how it goes. Thanks!!

Bel

[EDIT]
It worked! It was transcoding, so I disabled subtitles as suggested. Fantastic!! :D :o

Thanks everyone for your help!!

Bel
<<

atc98092

User avatar

DLNA master

Posts: 2269

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state) - temporary assignment to Washington DC

Post Wed Mar 22, 2017 12:18 am

Re: MPEG2 files return Audio Format Not Supported

Wahoo! :lol:
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Sony BDP-S3500, Sharp 4K Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging Identify video file contents

Return to Transcoding

Who is online

Users browsing this forum: No registered users and 3 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.