FAQ  •  Register  •  Login

Audio out of sync

<<

Pompasmurf

Serviio newbie

Posts: 2

Joined: Sun May 07, 2017 6:40 pm

Post Sun May 07, 2017 6:55 pm

Audio out of sync

Hi,

I'm new to the Serviio community, and I'm very much a beginner.

I have a Samsung PN51D550 TV. I like to stream movies via ethernet over my home network from my PC to my TV.

Most movies play with no problem. But some movies, the audio starts going out of sync after a couple minutes, and it gets worse as the movie goes on, to the point of being unwatchable. If I play the same movie on WMP on my PC, it plays fine and audio stays in sync.

I was using Samsung Allshare as my DLNA server, but at this point, I uninstalled and decided to try Serviio, but this didn't fix the problem.

I tested a few dozen movies and narrowed it down to movies that use HE-AAC for the audio stream. I guess the TV only supports regular AAC. (user manual: http://downloadcenter.samsung.com/conte ... 151140457/[ENG_US]PX5ATSCA-1020.pdf) (page 181-182)
(Edit: this forum doesn't seem to make a correct hyperlink out of the URL above due to the brackets; you'll need to manually copy/paste if you want to check out the user manual)

My problem is, in Serviio, even when I have the Samsung D-series profile selected, and have transcode turned on, the audio still goes out of sync.

How can I make this work? Is it a problem with the D-series profile? Is there a way to get transcode to fix this on the fly? Do I need to use Handbrake or something to alter the audio stream?

Thanks for your time.
<<

atc98092

User avatar

DLNA master

Posts: 2077

Joined: Fri Aug 17, 2012 10:22 pm

Location: Washington (the state)

Post Sun May 07, 2017 8:53 pm

Re: Audio out of sync

While I will admit I rarely use the DLNA app in my Samsung sets for viewing any longer, I never encountered any audio sync issues. I will say that Samsung does a lousy job of supporting DLNA on their Smart TVs. I suspect they broke something in a firmware update. Wouldn't be the first time for them.
Dan

Panasonic ST30 Plasma, Samsung JU7100 4K TV, Samsung UN24H4500 TV, Sony BDP-S3500, Insignia Roku TV, Roku 2 XS, 4, Ultra and Stick, Yamaha RX-V679 AVR.
Primary server: Intel i5-6400, 8 gig ram, Windows 10 Pro, 18 TB hard drive space | Test server Windows 7 Home Premium, AMD Phenom II X4 965, 8 gig ram

Enable debug logging
<<

Pompasmurf

Serviio newbie

Posts: 2

Joined: Sun May 07, 2017 6:40 pm

Post Mon May 08, 2017 3:49 am

Re: Audio out of sync

I may have found a solution.

I found this link : https://www.youtube.com/watch?v=a0PKW6sr06Q

...which said that not only has my audio been out of sync, it hasn't been surround sound either.

I used ffmpeg to convert the audio stream like the video said, and my movie was in sync!!!

It will take some time to convert all my movies, and the size of the files are increasing about 10%, but after over a year with no solution, it's nice to finally have a working one.

Return to Transcoding

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.