FAQ  •  Register  •  Login

Setup to play media on Android devices ... working

<<

pur_berger

Streaming enthusiast

Posts: 47

Joined: Sun Apr 17, 2011 7:01 pm

Post Wed Jun 08, 2011 9:55 pm

Setup to play media on Android devices ... working

Just found out cause got one of these Xoom tabs not able playing avi and looking for a solution to make it possible ...

There is a setup for playing mkv with subtitles ... on Android ....

What is needed:

Serviio of course
UpnPlay (availible on the market)
MoboPlayer (also available on the market) together with the MoboCodec (you are going to be prompted when starting Mobo the first time if it is required)

Setup: Basically ... nothing but in Mobo to set to ""Default using soft-decoding" in the "Playback" section and set the subtitle size. Everything else is default (assuming Serviio is working correct).

When you start UpnPlay you see servio to select with all options, when selecting a File take Mobo as player ... that's it :-)

Note hat using Not the setting in Mobo "Default using soft-decoding" caused mobo to crash (or better to become unresponsive)

Have Fun!
<<

moltra

DLNA master

Posts: 1867

Joined: Thu Mar 24, 2011 11:00 pm

Location: Ohio USA

Post Thu Jun 09, 2011 3:34 pm

Re: Setup to play media on Android devices ... working

You can also try Skifta. I use it on my droid X
Mark
Beta Tester Group
http://www.serviidb.com Online media resource repository

Netgear EVA2000 | Samsung BD-D5300 | XBOX 360 | Windows 7 | Mint Debian 12 | Raxz Maxx
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

pur_berger

Streaming enthusiast

Posts: 47

Joined: Sun Apr 17, 2011 7:01 pm

Post Thu Jun 09, 2011 9:24 pm

Re: Setup to play media on Android devices ... working

Tried it but it seemed a little unstable to ma as when switching around it started to show only empty folders. UpnPlay is ... not that handsome - but it stayed stable and much faster in Terms of Loading ...

but basically what I'm happy about is the possibility to stream all the Anime content to my tab without going through the trouble and extracting the subs and letting my girlfriend sleep next to me while enjoying my shows :)
Last edited by pur_berger on Fri Jun 10, 2011 9:29 am, edited 1 time in total.
<<

moltra

DLNA master

Posts: 1867

Joined: Thu Mar 24, 2011 11:00 pm

Location: Ohio USA

Post Thu Jun 09, 2011 10:45 pm

Re: Setup to play media on Android devices ... working

I will have to try Upnplay.
Mark
Beta Tester Group
http://www.serviidb.com Online media resource repository

Netgear EVA2000 | Samsung BD-D5300 | XBOX 360 | Windows 7 | Mint Debian 12 | Raxz Maxx
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

pur_berger

Streaming enthusiast

Posts: 47

Joined: Sun Apr 17, 2011 7:01 pm

Post Fri Jun 10, 2011 9:28 am

Re: Setup to play media on Android devices ... working

wow - should read bevor posting ;) .... call me Mr. Typo ...
<<

rgalverson

Serviio newbie

Posts: 3

Joined: Tue Jun 14, 2011 12:19 am

Post Fri Jun 17, 2011 6:42 pm

Re: Setup to play media on Android devices ... working

Hey, this is great, especially since it can play wtv files now. However, my poor android phone (Mytouch 4g) can't keep up with a 1080i wtv video and it plays in slow motion. I thought I would use ffmpeg to scale the size to my screen (800x480), but it doesn't seem Serviio gives that option for some reason. Is the suggested thing to use the maxVbitrate option to scale down the data rate and still have my phone rescale the video size? If so, what bitrate max makes sense for a wifi situation where I seem to usually connect at 65 Mbps (according to my phone).
<<

Illico

User avatar

DLNA master

Posts: 4339

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Sat Jun 18, 2011 8:55 am

Re: Setup to play media on Android devices ... working

rgalverson wrote:... I thought I would use ffmpeg to scale the size to my screen (800x480), but it doesn't seem Serviio gives that option for some reason. Is the suggested thing to use the maxVbitrate option to scale down the data rate and still have my phone rescale the video size? If so, what bitrate max makes sense for a wifi situation where I seem to usually connect at 65 Mbps (according to my phone).


Feature request exist about screen format: https://bitbucket.org/xnejp03/serviio/i ... n-renderer

The video bitrate option had sense only with transcoded media, you can add the option into the profile and try different value...
Illico
Sony 2010 KDL-46EX501 | BDP-S373 | SMP-N100 | Windows 8-i7 | Network DD HD-CE1.5TLU2 | Livebox2-UHD86 | ServiiDroid | ServiiGo | BubbleUPnP
Serviio beta tester - Moderator
<<

hohum

Serviio newbie

Posts: 1

Joined: Mon Jun 20, 2011 5:34 am

Post Mon Jun 20, 2011 5:40 am

Re: Setup to play media on Android devices ... working

I have a Windows Home Server (WHS) and am running Serviio on it.

I have a Droid X and have UPnPlay and MoboPlayer. This set up works beautifully for virtually everything.

However, there are a few videos that I would like Serviio to transcode for my Droid X so it can actually play it. Unfortunately, I have no programming skill and was hoping someone knew how to write up a profile for me. I don't mean to hijack this thread; however, it seemed as if this is the crowd I need to be talking to. :)
<<

powerfuljackson

Serviio newbie

Posts: 3

Joined: Wed Jun 22, 2011 5:26 am

Post Mon Aug 08, 2011 2:33 am

Re: Setup to play media on Android devices ... working

have you tried the following method http://www.bigasoft.com/articles/how-to-play-wtv-files.html? with it, you can easily Play WTV File on Mac, Windows XP/Vista, iPad, iPhone, PS3, android phone, blackberry and more
<<

ronsmits

Serviio newbie

Posts: 1

Joined: Fri Aug 26, 2011 7:10 am

Post Fri Aug 26, 2011 7:14 am

Re: Setup to play media on Android devices ... working

Late to this topic, but I thought I would post my setup anyway.

To play all content on my samsung galaxy tab 10.1v I use BubbleUpnp and mobyplayer. To make my android play everything I set the profile for bubbleUpnp to "Toshiba Rezga". All 720p and higher mkv's get transcoded to mpeg and gets played without any problem.

just my 0.02 cts

Ron
<<

Cerberus

User avatar

DLNA master

Posts: 4123

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Fri Aug 26, 2011 6:43 pm

Re: Setup to play media on Android devices ... working

wait on 0.6 of serviio and then use (rockplayer/skifta) for best performance on android devices, all files work with the standard generic profile, so no quality loss ;).
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

lfventura

Serviio newbie

Posts: 1

Joined: Fri Nov 11, 2011 5:11 am

Post Fri Nov 11, 2011 5:13 am

Re: Setup to play media on Android devices ... working

Hi...

I tried the proposed setup (upnp + moboplayer) but I still not able to get any subtitles in my android devices. I tried in a Motorola Atrix and in a Galaxy Tab 10.1. In Both no subtitles.

In my LG TV and my Samsung TV subtitles are fine.
Which profile are you using? Does it need any other special setup to get it working on android?

thanks in advance
Regards
<<

iMcRabbi

User avatar

Serviio newbie

Posts: 13

Joined: Sun Aug 07, 2011 5:22 am

Post Fri Nov 11, 2011 5:28 am

Re: Re: Setup to play media on Android devices ... working

lfventura wrote:Hi...

I tried the proposed setup (upnp + moboplayer) but I still not able to get any subtitles in my android devices. I tried in a Motorola Atrix and in a Galaxy Tab 10.1. In Both no subtitles.

In my LG TV and my Samsung TV subtitles are fine.
Which profile are you using? Does it need any other special setup to get it working on android?

thanks in advance
Regards

I can't get subs on any device.

Sent from my LG-P999 using THE FORCE
<<

Heffaklump

Serviio newbie

Posts: 14

Joined: Sat Jan 14, 2012 3:31 pm

Post Tue Jan 17, 2012 7:33 pm

Re: Setup to play media on Android devices ... working

I have serviio running but after downloading and installing UpnPlay on my phone I can´t get it to connect to anything but my local files. My serviio server does not show up on my phone :( I use a HTC Gratia btw.

I use windows 7 and its firewall and I also have avast!

Any suggestions on how I can make this work?
<<

Cerberus

User avatar

DLNA master

Posts: 4123

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Tue Jan 17, 2012 9:09 pm

Re: Setup to play media on Android devices ... working

Heffaklump wrote:I have serviio running but after downloading and installing UpnPlay on my phone I can´t get it to connect to anything but my local files. My serviio server does not show up on my phone :( I use a HTC Gratia btw.

I use windows 7 and its firewall and I also have avast!

Any suggestions on how I can make this work?


http://wiki.serviio.org/doku.php?id=androidtools
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

Heffaklump

Serviio newbie

Posts: 14

Joined: Sat Jan 14, 2012 3:31 pm

Post Wed Jan 18, 2012 6:24 pm

Re: Setup to play media on Android devices ... working

Thank you for the reply Cerberus. But does this mean that I also need to get the Skifta desktop software? I thought this would work through using the Serviio program?
<<

moltra

DLNA master

Posts: 1867

Joined: Thu Mar 24, 2011 11:00 pm

Location: Ohio USA

Post Wed Jan 18, 2012 6:26 pm

Re: Setup to play media on Android devices ... working

no you do not have to use skifta. You can use upnplay or skifta. You are connecting to your home wi-fi network for these to work, right?

Can anything else on your network see serviio?
Mark
Beta Tester Group
http://www.serviidb.com Online media resource repository

Netgear EVA2000 | Samsung BD-D5300 | XBOX 360 | Windows 7 | Mint Debian 12 | Raxz Maxx
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

Heffaklump

Serviio newbie

Posts: 14

Joined: Sat Jan 14, 2012 3:31 pm

Post Wed Jan 18, 2012 6:33 pm

Re: Setup to play media on Android devices ... working

Using skifta I managed to view videos from my phone on my TV. What I really want is to do the opposite. Watch moives from my computer on my phone.
I´m using a Netgear CG3100 modem/router and also the windows firewall. I have enabled UPnP and streaming from my computer to my TV is working quite well, but that is using a network cable and not wireless.

So yes, my TV can see serviio. And I am using my home wi-fi network for this. At least that is what I want to do...

I also tried the upnplay and it looked like servviio picked it up, it said so in the console. But my phone never got connected to anything else than the local folders on my phone.
<<

moltra

DLNA master

Posts: 1867

Joined: Thu Mar 24, 2011 11:00 pm

Location: Ohio USA

Post Wed Jan 18, 2012 6:46 pm

Re: Setup to play media on Android devices ... working

did you open the upnplay app up on your phone after you are connected to your wifi network. After you do that in around 10-30 seconds the serviio server should show up, click on the serviio server and it should pop up your serviio presentation folders.
Mark
Beta Tester Group
http://www.serviidb.com Online media resource repository

Netgear EVA2000 | Samsung BD-D5300 | XBOX 360 | Windows 7 | Mint Debian 12 | Raxz Maxx
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

Heffaklump

Serviio newbie

Posts: 14

Joined: Sat Jan 14, 2012 3:31 pm

Post Wed Jan 18, 2012 6:56 pm

Re: Setup to play media on Android devices ... working

moltra wrote:did you open the upnplay app up on your phone after you are connected to your wifi network. After you do that in around 10-30 seconds the serviio server should show up, click on the serviio server and it should pop up your serviio presentation folders.


Using Skifta I can see in my Netgear router that my phones internal ip and ports are open and working. Once I switch to upnplay they disappear and I only see some other device (my TV or maybe Serviio, I´m not sure).

But for what ever reason none of these programs will let me connect my phone to serviio in any working way. I do see upnplay in the serviio window but it is marked red (inactive) Even though it is running on my phone. My best guess is that I need to open up ports in either my router or in windows firewall. But I´m not sure which ports or for what internal ip....
And in the UPnP settings for my router all I can do is turn it on or off, then only watch which devices connects and what ports, protocols and ips they use.
Next

Return to Transcoding

Who is online

Users browsing this forum: No registered users and 5 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.