FAQ  •  Register  •  Login

Metadata: Preferred language - issues

<<

andrusz

Serviio newbie

Posts: 5

Joined: Mon May 04, 2015 11:25 am

Post Mon May 04, 2015 3:02 pm

Metadata: Preferred language - issues

Hi,

I am using Serviio on Mac OS X 10.9 (Maverics). It is great but I have issues with Metadata/Preferred language option.

I found two issues:
1. metadata are not updated after changing "Preferred language"
2. when no metadata are found (in themoviedb) for selected language, original title is retrieved, regardless of "Use original title" is checked or not.

Testing:

My Library settings:
Search for updates of currently shared files - ON
Keep library automatically updated - ON

Metadata settings
Descriptive metadata:
- Online metadata sources
- Retrieve DVD cover image or poster if available - ON
- Preferred language: English
- Use original title - OFF

My test file name is "Mardock Scramble The First Compression (2010).mkv". Serviio found the right entry in themoviedb and updated local db with:
Title: Mardock Scramble: The First Compression
Basic data and description in English.

Good. Now I have changed "Prefered language" to Polski (Polish). Waited couple of minutes but the title nor description did not change. Clicking "Force refresh" in Library tab has no effect. Restarting Serviio server does not refresh the metadata. Even clicking 'Force refresh" again does not help.

I found a workaround how to force metadata to refresh by unchecking "Metadata" checkbox for specified folder and checking it again. It forces Serviio to retrieve metadata in the selected language. However when no data are found (in selected language), the original title is used (here in Japanese: マルドゥック・スクランブル 圧縮) including the basic metadata but with no description (which does exist in themoviedb.org).

My questions are:
- could you fix refreshing metadata after changing "Preferred language"?
- would it possible to retrieve a movie title and all the data in English, if no metadata exist in themoviedb? It should only work when "Use original title" is not selected, otherwise get all metadata in original language. Also get all metadata in original language if they do not exist in English.

Could it be possible?

Thanks again for the great application!

Regards,
andrusz
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16495

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue May 05, 2015 8:19 pm

Re: Metadata: Preferred language - issues

The change to preference only affects new files, or when the online db is checked again. You could force it by clicking Refresh video metadata on the Metadata tab.

Serviio uses your preferred language when retrieving the data. If the language is not there, it's up to the online DB to return something (Serviio doesn't control this), and they probably return the original language metadata.

The original title flag is used on the retrieved metadata (whatever the online DB returns) and if it's required, uses the Original title field, rather than Title.
<<

andrusz

Serviio newbie

Posts: 5

Joined: Mon May 04, 2015 11:25 am

Post Wed May 06, 2015 9:49 pm

Re: Metadata: Preferred language - issues

Hi zip,

Thanks for the reply. I would like to have a movie info in a local language and in English, if no data are found. Looks like it is not possible for non-english movies :cry: Ok, I understand you have no control what data are get in this case.

Unfortunately refreshing metadata does not work after changing a language and clicking 'Rescan video metadata' on Metadata tab. The following line appears in a log file:

2015-05-06 23:03:35,468 INFO [LocalLibraryManager] Forcing metadata update for 'VIDEO' media files

Waited about 30 minutes but nothing happened (nothing new in the log) and metadata had not changed.

Could you look at it, please?

Thanks,
andrusz
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 16495

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu May 07, 2015 8:10 pm

Re: Metadata: Preferred language - issues

Did you click Force refresh after that?
<<

andrusz

Serviio newbie

Posts: 5

Joined: Mon May 04, 2015 11:25 am

Post Thu May 07, 2015 10:03 pm

Re: Metadata: Preferred language - issues

Aaa… now it works! I did not know 'Force refresh' should be clicked, too - it is not obvious.

Thanks zip!

Regards,
andrusz

Return to Serviio Support & Help

Who is online

Users browsing this forum: Bing [Bot] and 8 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.