Page 1 of 1

[Can't be solved] Weird .ass subtitles

PostPosted: Wed Jan 18, 2017 7:17 pm
Hi everyone,

I'm currently trying to troubleshoot subtitles problems I have on my Samsung TV UE48HU7500.

Serviio setup : Serviio 1.8 on Ubuntu 14.04
Files : .mkv created with mkvtoolnix, including 1 VC1 video stream, 1 DTS audio stream and 1 .ass subtitles stream + same .ass stream saved as file in the same directory
Serviio settings : Device profile is Samsung TV H series, subtitles enabled, extraction of text based embedded subtitles is DISABLED (because I try to first troubleshoot using external file)
Video and audio are OK, subtitles appear on screen (wrong size and position but at least they appear) but, as soon as I have two lines of subtitle (coded as "line1_text\Nline2_text" in the .ass file), it's displayed as follows :

<font size="60" color="#ecebeb">line1_text

Yes...I see some font settings as subtitle on my TV screen :x

I don't know what can be wrong so if someone can help, I thank him in advance.


(I cannot use .srt, I NEED .ass format)

[Can't be solved] Re: Weird .ass subtitles

PostPosted: Sat Jan 21, 2017 6:47 pm
OK. Seems like a very poor .ass subtitles support from Samsung... I changed the subtitles font size to "16" and the color to "&H00FFFFFF" in the file and the formatting tags do not appear anymore on screen. My conclusion is that there is no real .ass subtitles support as the result is strictly the same as with an .srt file. All .ass tags are simply ignored (left justified dialogues are not justified, on top descriptions are on the bottom of the screen like any other subtitle,...).



Re: [Can't be solved] Weird .ass subtitles

PostPosted: Mon Jan 23, 2017 11:10 pm
by zip
Serviio will actually convert the .ass to .srt (srt is the only text based format Serviio supports as the output).

Re: [Can't be solved] Weird .ass subtitles

PostPosted: Tue Jan 24, 2017 6:53 am
OK. Thanks for the clarification. Then I'll keep my .ass formated files in case of a future full support ;)