Page 1 of 1

Samsung 2018

PostPosted: Fri Jul 13, 2018 4:35 pm
by RaymanDK
Hi there,

I own a Samsung NU8000 TV.

As you all know the 2018 Samsung TV's don't allow DTS.

I read on the forum here to transcode the audio into ac3 with a custom profile and it works. Thing is I can't get my subtitles to work when it transcodes the audio. Neither Embedded or srt works.
If I play the video without the profile it'll play with subtitles but without audio obviously.

Is there a way to make subtitles work when it transcodes audio?

Profile from here just added dts support:

Re: Samsung 2018

PostPosted: Fri Jul 13, 2018 4:53 pm
by atc98092
I'm not certain which post in that thread has the profile modification you used, but it appears they all transcode the video, along with the audio. I believe the only way to get your subtitles is to enable burned-in in the Serviio console. You of course then lose the ability to turn them off, and you end up transcoding every video you play.

While my Samsung is older than yours, I've given up ever using the built in player. It has too many things that in my opinion just don't work well, and the overall user experience is terrible. I use a Roku player while my wife prefers our Sony BD player. Although the Sony player UI isn't much of an improvement over the Samsung, I have the pleasure of everything just plain working.

Re: Samsung 2018

PostPosted: Fri Jul 13, 2018 6:13 pm
by RaymanDK
That's a bummer. I was hoping there was a simple fix to make it work on the fly without transcoding the video and only the sound on the fly.

I tried converting the movie before playing it to ac3 and it plays using the generic profile so no transcoding at all but still no embedded or srt subtitles.

What could it be? Files are named the same and work for other non DTS movies.

Re: Samsung 2018

PostPosted: Fri Jul 13, 2018 9:59 pm
by atc98092
It's been quite a while since I've used the Samsung player, so I'm going by memory. I could select embedded captions (VOBSUB) from ripped DVDs in a MKV container. But Blu Ray rips use a different type of caption (PGS), and the TV does not recognize and cannot play them. I can't explain why the SRT captions aren't being played. We would probably need you to enable detailed logging and then play a file. The detailed log should answer if Serviio is even recognizing the SRT file correctly.