Page 1 of 1

embedded subtitles not working

PostPosted: Tue Mar 26, 2019 10:27 pm
by ricobico
hello.
First off, love the software and it is working well with some minor issues. I have searched here for my question and I think this is just an issue that may not have an answer but I'll try anyway.

I have tons of MKV videos that have subtitles included/embeded in them; not hardcoded, not a separate subtitle like an SRT, but part of the original file. The subtitles just wont play on my samsung C630 TV. Prior to having serviio, I used WD TV Live and I could select the subs. now if I run serviio or even if I run WD TV LIVE through the serviio server, I cannot get any subs. for the few files I have that do have an SRT, those seem to work.

I have every box checked under the Serviio subtitles section except the hardcoding/transcending box.

Any thoughts?

Re: embedded subtitles not working

PostPosted: Sun Mar 31, 2019 12:35 am
by DenyAll
Firstly which problem are you trying to solve - for the Samsung TV or the WD TV Live box?

For the Samsung TV, it appears from the info you've provided it doesnt support subtitles (have you tried the Generic profile), so you will need to burn them in - you will need to enable "Enable extraction of text-based subtitles embedded in video files" and "Enable burned-in subtitles" in the Delivery, Subtitles areas of Serviio Console. Press Save.

The above may also fix the issue for the WD Live. It shouldn't however be needed - to see what's going on post MediaInfo details of one of the offending files.