Page 1 of 1

Samsung UA65KU6000WXXY Can't see Serviio

PostPosted: Mon Apr 06, 2020 7:25 am
by SS72
HI, longtiime user, first post. It's a long one, but trying to provide as much relevant information as possible . . .

- Most devices cannot see Serviio, and ones that cannot, will see it occasionally and work fine, and the next time the device is powered on, Serviio isnn't visble. However, in all cases, the devices are registered and shwoing as active in the Console.
- In some cases, will see the server and can play, and then randomly it'll stop playing and Serviio is no longer available as a source.
- Devices that can see Serviio are: Playstation 2/3 consoles, WD TV Live boxes
- Devices that cannot see Serviio are: Samsung TV (see below for model number), and Windows 10 computers on the workgroup network
- Nothing in my environment has changed, except I had to do a reinstallation of WHS20211 last week after the SSD died. The OS is reconfigured exactly the same as previously, without all the Windows updates, etc., installed.
- Everything is visble and plays without issue via the web Media Browser

Setup of my Environment:
- Router is a Netgear Nighthawk D7000v2 on the latest firmware (have tried several different versions, with no effect)
- Serviio is running on a HP NL40 ProLiant Microserver with WHS2011 as the OS
- Serviio version is 1.10.1 (have tried all version from 1.6), and have also tried version 2.0.
- TV is a Samsung UA65KU6000WXXY running firmware version 1242 (has been the case since Sept last year and everything was working fine)
- The server and TV are connected via Ethernet cable to the router
- All IP Addresses are static and on the same subnet, and all can access the Internet, ping each other with under 5ms latency
- The firewall is disabled in WHS2011, and there are no access controls on the routers
- The inbuilt UPnP server on the router is currently disabled (was enabled till recently, and alway in the past, wich never caused an issue)

Additional Info:
- I rebuilt the ProLiant server with Ubuntu 18.04 last week, configured as per the Serviio instructions, and the result was exactly the same as above. I've therefore uninstalled and rebuilt with WHS2011
- Have tried using various render profiles, but makes no difference (aware this should not impact client-server visibility). Transcoding is currently disabled
- I have tried connecting devices wirelessly, too, which makes no difference
- The server has only 1 NIC, and Serviio is bound to it (have tried with it set to auto detect)
- Each time I upgreade/downgrade Serviio to test, I remove all traces from Program Files, Windows Registry and reboot before reinstalling
- I tried renaming the server to a different name than the one it had prior to being rebuilt

I've been using Serviio in this setup since 2013 with zero issues. I have spent days reading through existing forum topics and tried everyting that may be relevant. I'm at a loss. I think the only thing left is to provide log files for analysis.

Appreciate any suggestions/help.

Re: Samsung UA65KU6000WXXY Can't see Serviio

PostPosted: Mon Apr 06, 2020 1:44 pm
by atc98092
Many users over the years have reported issues when using a Windows Server OS. I recognize you've been successful for a number of years. Since it suddenly changed, my guess is that Microsoft updated something that broke DLNA connectivity. It might be related to the ports that are necessary for communication, or something else I have no knowledge about. If sounds like your configuration is completely sufficient and correct for functionality, so that points solely at the computer itself.

As a test, install Serviio on one of your Windows 10 computers and see if there's any visibility or playback issues. You can just use your existing media on the server and map it as a NAS location. Just be aware that Serviio installs by default as a Local Service, with little network access permissions. Change the user account the service runs under to an actual user account with access to your NAS location. If that works, and I'm pretty certain it will, that again just points to whatever issue a Windows Server OS has with Serviio.

You mentioned that your Windows 10 computers aren't seeing Serviio. So you mean that they can't play anything through Media Player, or that they flat don't see your DLNA server at all? Windows Media Player will not work with Serviio, so just wanted to mention that. But something like VLC should work fine.

Re: Samsung UA65KU6000WXXY Can't see Serviio

PostPosted: Mon Apr 06, 2020 9:21 pm
by SS72
Thanks, Dan, for the suggestions. I've modified the service to run under the local Administrator account on WHS. That has made no difference.

I installed and tested on a WIN10 machine, with service set to run under an admin account, firewall and Antivirus softeware all disabled, and still no go.

Normally, if I open WIindows Explorer on a WIN10 computer, I can see the Serviio icon from all LAN clients. This is no longer the case, and that is what happens on all clients. At times it is visible, and I can select it and access/play content. But at some point the content stops playing and the icon has then disappeared. The same thing was happening when I installed Serviio on Ubuntu.

Also, I am currently running Serviio on a fresh build of WHS with zero updates, no antivirus and no firewall, and all drivers are from vendors, not Windows detected and downloaded.

Re: Samsung UA65KU6000WXXY Can't see Serviio

PostPosted: Mon Apr 06, 2020 11:44 pm
by atc98092
Yeah, that's puzzling. But I think I can point a finger at a potential issue. If installing on a Windows 10 PC is still not being seen by your players, there's something amiss with your network. I can't identify what it might be. But a Windows 10 PC with no firewall should be seen by everything on the network. Both of my Serviio boxes (I have one for testing purposes) are configured exactly that way, and everything on the network sees both just fine. I have Roku devices (TVs and players), several Samsung TVs, a Sony BD player, and two Nvidia Shield players. Everything works.

Now, is there any setting in the Nighthawk router that offers network privacy between devices? I know that Netgear has that in some of their devices. Almost sounds like something got switched on by mistake. One thing you could try is to connect your network to a separate switch, and only make a single connection from the switch to the router for Internet access. This would eliminate any possible function in the router blocking access between ports. I actually run my network in this manner, even though my Internet router is a simple Actiontec DSL modem, and has few if any controls for the inside network.

Re: Samsung UA65KU6000WXXY Can't see Serviio

PostPosted: Tue Apr 07, 2020 6:10 am
by SS72
Dan, initial tests indicate that is a good workaround. Connecting a switch to the Netgear router and all other Ethernet clients to the switch has make Serviio available on everything. Now, this has happened a number of time before, when everything was connecting via the router, so I'll give it some more time to know for sure.

The million-dollar question is, what changed to make it stop working all of a sudden? I've reinstalled every firmwar version on the router going back at least two years, performed factory resets and then configured from scratch each time. The TV's firmware has been updated, and Samsung refuses to provide access to downgrades (as discussed here in other posts), but that shouldn't prevent the other LAN clients that were seeing the server from not being able to see it anymore. And it was working for months after the firmware update.

Anyway, I'll close the loop here in a day or two to confirm if the workaround has held up.

Bloody annoying that this is happening with a $400 AUD router. I'll reach out to Netgear support to see what they have to say.

Thank you.

Re: Samsung UA65KU6000WXXY Can't see Serviio

PostPosted: Tue Apr 07, 2020 1:06 pm
by atc98092
I looked up the manual for the router. I see it's a DSL modem as well, so that explains some of the price. :D

Starting on page 94 of the manual, it discusses allowing or blocking access to your network. Most likely it's one of those settings that is mucking things up. But, if using the switch has cleared things up, then just stick with it. There's no penalty for having a switch in your network like this, as long as it's a Gigabit switch to match what the router offers.

Re: Samsung UA65KU6000WXXY Can't see Serviio

PostPosted: Tue Apr 07, 2020 9:45 pm
by SS72
I've always had access control disabled, and also tested enabling it and adding mac addresses for the devices, which didn't have an effect either way.
Will go with your advice and leave the switch in place. Thanks Dan.

Re: Samsung UA65KU6000WXXY Can't see Serviio

PostPosted: Wed Apr 08, 2020 9:22 am
by SS72
Finally found the fix. The Netgear d7000v2 router has a setting to enable IGMP Proxy. It's disabled by default, and I'm pretty sure it always has been on my network, but turning it on has made Serviio visible.

Enabling it shouldn't have an effect, as I only have one router and everything is in the same subnet. Nevertheless, it's been working solidly all day now.

In January, a Samsung technician replaced the motherboard on my TV because it was freezing at random times. The firmware and everything else was unchanged, but I can only assume it was that change. It fits in with the timing. Either that, or I did have IGMP Proxy enabled before and my memory is failing me.

Re: Samsung UA65KU6000WXXY Can't see Serviio

PostPosted: Wed Apr 08, 2020 12:37 pm
by atc98092

Re: Samsung UA65KU6000WXXY Can't see Serviio

PostPosted: Thu Apr 09, 2020 2:38 am
by SS72
My memory either aint what it used to be, or a Netgear firmware upate somewhere along the line has chagned the IGMP Proxy setting from enabled to disabled by default.

Enabling IGMP Proxy on the router not only resolved the Samsung-Serviio visibility issue, but all WIndows laptops, Kodi clients, etc., are able to see Serviio now, too, and before they could not. And running Serviion on Ubuntu is also working flawlessly.

Just wanted to mention this in case someone else comes across a similar issue.