Page 1 of 1

XBMC.nfo - problem displaying date

PostPosted: Fri Mar 18, 2011 12:13 pm
by Harvey
First off I think the product is excellent, keep up the good work...

I am just starting to set up Serviio and I want to use XBMC nfo files to manage the metadata for all my video content, MKV files and home videos. The nfo files are particularly attractive for naming and sorting my home movies.

However, I have created a test nfo for an MKV file and the date displayed on my Sony BDPS370 is the date the MKV file was modified not the <year> in the nfo which is what I expected. During metadata extraction where does Serviio pull the date information from? Do I need to add another date field to the nfo file?

When I changed the "Descriptive metadata" setting to "Online metadata sources" the date on the Sony BDPS370 was correctly displayed as the release date for the movie as on TMDb?

Thanks
Harvey

Re: XBMC.nfo - problem displaying date

PostPosted: Fri Mar 18, 2011 3:05 pm
by zip
You're right. ATM it uses the date file was created, which is not ideal. The online DB includes ReleaseDate element, which includes full date of the release. NFO files only include year, that's probably why I didn't add it.

I could make it use 1 Jan of the year to generate the full date, not ideal either but probably more useful to you.

Create a bitbucket ticket if you'd like this feature.

Re: XBMC.nfo - problem displaying date

PostPosted: Fri Mar 18, 2011 3:53 pm
by Harvey
Thanks for the quick response.

It would be better to have a <ReleaseDate> field in the XBMC .nfo, however, I have tried to locate an XBMC .nfo schema to see if this is allowed but I couldn't find anything. Do you know if this would be possible? If so this could be pulled directly from the .nfo and give more accurate info, particularly useful for home videos.

Thanks
Harvey

Re: XBMC.nfo - problem displaying date

PostPosted: Fri Mar 18, 2011 3:56 pm
by zip