FAQ  •  Register  •  Login

Info needed for Sony profiles

<<

ionutm80

Serviio newbie

Posts: 2

Joined: Thu Jun 02, 2016 6:35 am

Post Thu Jun 02, 2016 6:57 am

Info needed for Sony profiles

Hello,

I've been a long time HTPC user and went the whole path of tinkering with custom resolutions, constant updates for different pieces of the video chain ... but lately I've got a little fed-up and decided to check whether some of my devices can stream video directly from my server (J1900 4 core Atom PC, 8GB DDR3, 3 x USB 3.0 2TB HDD). To my surprise I found out that Sony BDP-S4500 and Sony TV 26EX320 (2011 model) are both DLNA enabled and can stream even mkv blu-ray rips (personal collection of blu-rays ripped with eac3to or makemkv and preserving original video stream, audio streams and yeah PGS subtitles) ... but only with Serviiio :) , I've also tried EMBY, PLEX but to no avail (for EMBY I get that format of the video file is not supported, for PLEX I get stuttering and freezing like hell). So I'm now quite decided to buy the PRO version after my trial expires, I'm convinced that it's the best server for SONY products.

However I do have some questions for which I need help:
- is there a better profile for my SONY BDP-S4500 other than the Sony BDP 2013 or generic DLNA? I've stumbled upon a thread of sploit which tweaked the profile for its BDP-S5100 (viewtopic.php?f=7&t=19278&p=106652&hilit=profile+sony#p106652) but I cannot manage to use this one, I replaced the generic profile.xml from config folder with his profile but the name does not appear on the list of profile when I try to edit the one for BDP-S4500 in the Status tab of the console. Do you have any idea why it does not show up?
- my Sony BDP-S4500 when playing from Serviio shows MPG for video stream instead as AVC in case of Plex, does this mean that the mkv is only remuxed to m2ts on the fly? Can you confirm that the video stream is not altered?
- when I rip my blu-rays to mkv I usually keep the DTS-HD MA stream, a insert another AC3 5.1 stream created with eac3to from the DTS-HD MA one and a 2 channel AAC stream. Normally the DTS-HD MA has a core DTS stream which can be decoded either by the BDP-S4500 or my AMP (Logitech z906) but I do see that Serviio is sending the AC3 stream instead, is this a convention specifically for Sony players or DLNA protocol used?
- I had no success in loading PGS subtitles but external SRT plays fine with one exception, I'm from Romania and we have special characters which do not display well even if the srt file is saved as UTF-8 encoding. Any solution for this?

Thanks a lot in advance for any info related to the above.
<<

DenyAll

DLNA master

Posts: 2248

Joined: Fri Mar 08, 2013 11:16 pm

Location: Adelaide, Australia

Post Fri Jun 03, 2016 4:55 am

Re: Info needed for Sony profiles

Glad your enjoying Serviio - welcome aboard.

I can answer some of your queries:

  1. The spoilt profile from the referenced post was for an earlier version of Serviio. It will need to be modified to use in the current release. Having said that the spoilt profile seems to transcode a lot of video based on the the audio only requiring changing... so it may need to be reviewed.
  2. "does this mean that the mkv is only remuxed to m2ts on the fly" - depends on the profile you are using and the media file, but if your source video (not container) is either h264 with a level of 4.1 or below, or mpeg2video then yes, the file will be remuxed only with no loss in video quality. Use MediaInfo to view the type of video in your MKV file.
  3. This is defined by the profile. We really need to see MediaInfo (see my signature) for your media file to tell what video and audio is contained within your file, which will then tell us why it is being transcoded.
  4. See http://serviio.org/component/content/article?id=21#q9.
DenyAll
Panasonic Viera FX800A | Panasonic Viera CS610A | Sony PS4 | Sony PS3 | Panasonic DMP-BD79 | Yamaha RX-V500D | iPad | Windows 10 | Serviio 1.10.1 Pro
WinHelper | MediaInfo

Beta Tester, Moderator
Please do not PM me for support as any solution cannot be shared with others.
<<

ionutm80

Serviio newbie

Posts: 2

Joined: Thu Jun 02, 2016 6:35 am

Post Fri Jun 03, 2016 5:55 am

Re: Info needed for Sony profiles

DenyAll wrote:Glad your enjoying Serviio - welcome aboard.

I can answer some of your queries:




Thanks a lot!
<<

Janiporo

Streaming enthusiast

Posts: 25

Joined: Mon Mar 19, 2012 2:05 pm

Post Sat Aug 27, 2016 1:26 pm

Re: Info needed for Sony profiles

ionutm80 wrote:...- I had no success in loading PGS subtitles but external SRT plays fine with one exception, I'm from Romania and we have special characters which do not display well even if the srt file is saved as UTF-8 encoding. Any solution for this?...


I am having the opposite problem with BDP-S4500, external subtitles do not work at all but PGS works fine. Strange. Did you have to do something special for SRT to work?

I also have profile file for serviio 1.6.1 to use with BDP-S4500 --> viewtopic.php?f=3&t=22122&p=109150#p110091

It changed mostly all mpegts to m2ts, since my S4500 player does not understand mpegts-stream for some reason, as my S4100 does. I have two players (S4100 with 5.1 system and S4500 for normal stereo tv), so I need two different profiles, since my amp does not decode AAC 5.1 audio, and some other 5.1-audio formats. The profile does not add any more codecs for profile, even S4500 plays more codecks than S4100.

Return to Sony

Who is online

Users browsing this forum: No registered users and 11 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.