Page 1 of 1

Serviio not working

PostPosted: Thu Jul 05, 2018 6:32 pm
by tanmaychhatbar
I have been using Serviio since a few days, on my desktop, and my father's laptop.
So far, it had been running great, streaming to two Sony TVs without a hitch.
However, a recent change in my router caused a failure in my TVs (or my mobile phone) to recognize the Serviio server from my desktop.
Note, the server of the laptop works fine.
Another service that fails to work on the desktop is Cast, whether it be from Google Chrome, or Videostream.
Cast works on all other devices, including other laptops and mobile phones.

This makes it almost certain that the problem is not the configuration of the router, but something related to the desktop.
So far, I have tried
1) Rebooting the desktop, the router, the TV.
2) Resetting the Network configuration, firewall settings, TV, router.
3) Disabling Windows Firewall, and the firewall from the Bitdefender Antivirus.

My best guess so far is that the network change caused a change in some setting, which was exclusive to the desktop.
The laptop is running Windows 7, and has no settings modified to make Serviio work. It was working from the word-go.
The desktop is on Windows 10, and I've tried a lot of things to try and make it work after the change, to no avail.
Any help is appreciated. Thanks.

Re: Serviio not working

PostPosted: Thu Jul 05, 2018 7:31 pm
by tanmaychhatbar
I reconnected the old router, and that allowed the TV to recognize the server.
However, this is a temporary solution as I do not have internet access through the old router.
Any assistance would be great.

Re: Serviio not working

PostPosted: Thu Jul 05, 2018 7:58 pm
by atc98092
The change of router is obviously the issue. So there's nothing to be done as far as Serviio is concerned.

Now, let's examine what might be the cause.

1. With the new router, your internal network addressing might have changed. If you have a static IP on your desktop computer, it would no longer be visible since it thinks it's connected to a different network.

2. Related to #1. If you aren't running a static IP, but had forced a network selection in the Serviio console (on the status tab near the bottom), it might be overriding the IP address binding and is set to the wrong IP address.

Most home network routers will assign IP addresses in the 192.168.0.x range. However, there are some that change it to 192.168.1.x, or even a different third number. For private networks, they could also begin with 10.x.x.x, or 172.x.x.x. But most commonly they are in the 192.168.x.x range. Check your settings on each device and make sure they are all use the same three numbers in the first three segments. The forth segment is required to be unique on each device, so if you find more than one using the same IP address, this could also cause an issue.

Re: Serviio not working

PostPosted: Wed Oct 10, 2018 1:01 pm
by Maxpower1
In windows open a command box, and type in " ipconfig /all, this will give you the ip information you are seeking.
Bring up the serviio app, and go to status, and remove all the entries, (ip) reboot all and hopefully serviio can refind them all,
sometimes serviio gets confused with old entries and keeps looking for them. Hope this helps.