FAQ  •  Register  •  Login

Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

<<

bh4bama

Serviio newbie

Posts: 3

Joined: Tue Jul 20, 2010 8:24 pm

Location: Montgomery, AL

Post Thu Jul 22, 2010 4:07 am

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

zip wrote:Can you post the log to see if your video files have been added to the library?

I was going to upload my log as an attachment but the forum would not allow me. I do see an exception down in the bottom of the log that is shown below. Let me know if you need me to do some additional debugging.

Here is part of the first time I ran Serviio:
2010-07-18 21:21:06,328 INFO [EventDispatcher] Starting EventDispatcher
2010-07-18 21:21:19,046 INFO [LibraryAdditionsCheckerThread] Added file 'Donald's Ducks.mpeg' to Library
2010-07-18 21:21:32,000 INFO [LibraryAdditionsCheckerThread] Added file 'Mickey Goes Fishing.mpeg' to Library
2010-07-18 21:21:45,031 INFO [LibraryAdditionsCheckerThread] Added file 'Pete's Beach Blanket Luau.mpeg' to Library
2010-07-18 21:21:57,906 INFO [LibraryAdditionsCheckerThread] Added file 'Pluto's Bubble Bath.mpeg' to Library
2010-07-18 21:22:09,250 INFO [LibraryAdditionsCheckerThread] Added file 'Mickey's Choo Choo Express.avi' to Library
2010-07-18 21:22:25,390 INFO [LibraryAdditionsCheckerThread] Added file 'Donald's Hiccups.mkv' to Library
2010-07-18 21:22:41,078 INFO [LibraryAdditionsCheckerThread] Added file 'Mickey's Great Clubhouse Hunt.mkv' to Library
2010-07-18 21:22:59,218 INFO [LibraryAdditionsCheckerThread] Added file 'DonaldTheFrogPrince.mkv' to Library
2010-07-18 21:23:16,015 INFO [LibraryAdditionsCheckerThread] Added file 'MinnieRedRidingHood.mkv' to Library
2010-07-18 21:23:33,343 INFO [LibraryAdditionsCheckerThread] Added file 'MinniesMystery.mkv' to Library
2010-07-18 21:23:49,265 INFO [LibraryAdditionsCheckerThread] Added file 'SleepingMinnie.mkv' to Library
2010-07-18 21:24:03,703 INFO [LibraryAdditionsCheckerThread] Added file 'Doctor Daisy.mkv' to Library
2010-07-18 21:24:18,125 INFO [LibraryAdditionsCheckerThread] Added file 'Goofy The Great.mkv' to Library
2010-07-18 21:24:33,265 INFO [LibraryAdditionsCheckerThread] Added file 'Mickey's Treat.mkv' to Library
2010-07-18 21:25:04,562 INFO [LibraryAdditionsCheckerThread] Added file 'Pluto To The Rescue.mp4' to Library
2010-07-18 21:25:36,328 INFO [LibraryAdditionsCheckerThread] Added file 'Pluto's Ball.mp4' to Library
2010-07-18 21:26:07,812 INFO [LibraryAdditionsCheckerThread] Added file 'Pluto's Playmate.mp4' to Library
2010-07-18 21:26:25,343 INFO [LibraryAdditionsCheckerThread] Added file 'CloneWarsS1V1.mkv' to Library
2010-07-18 21:26:32,890 INFO [LibraryAdditionsCheckerThread] Added file 'dts_experience.vob' to Library
2010-07-18 21:26:34,937 INFO [LibraryAdditionsCheckerThread] Added file 'dts_orchestra.vob' to Library
2010-07-18 21:26:37,093 INFO [LibraryAdditionsCheckerThread] Added file 'dts_piano.VOB' to Library
2010-07-18 21:26:40,375 INFO [LibraryAdditionsCheckerThread] Added file 'dts_sparks_(sprite_mix).vob' to Library
2010-07-18 21:26:43,359 INFO [LibraryAdditionsCheckerThread] Added file 'dts_sparks_(sprite_suite_mix).vob' to Library
2010-07-18 21:26:46,734 INFO [LibraryAdditionsCheckerThread] Added file 'dts_the_digital_experience.vob' to Library
2010-07-18 21:26:57,328 INFO [LibraryAdditionsCheckerThread] Added file 'hd_dts_sfx.m2ts' to Library
2010-07-18 21:27:02,578 INFO [LibraryAdditionsCheckerThread] Added file 'other_digital_cinema_sound.vob' to Library
2010-07-18 21:27:06,250 INFO [LibraryAdditionsCheckerThread] Added file 'other_meet_the_robinsons_handy_off.vob' to Library
2010-07-18 21:27:09,656 INFO [LibraryAdditionsCheckerThread] Added file 'thx_the_science.vob' to Library
2010-07-18 21:27:19,375 INFO [LibraryAdditionsCheckerThread] Added file 's04e07.avi' to Library
2010-07-18 21:27:27,640 INFO [LibraryAdditionsCheckerThread] Added file 's04e08.avi' to Library
2010-07-18 21:27:36,187 INFO [LibraryAdditionsCheckerThread] Added file 's04e09.avi' to Library
2010-07-18 21:27:45,390 INFO [LibraryAdditionsCheckerThread] Added file 's04e10.avi' to Library
2010-07-18 21:28:00,343 INFO [LibraryAdditionsCheckerThread] Added file 's01e01.mkv' to Library
2010-07-18 21:28:15,062 INFO [LibraryAdditionsCheckerThread] Added file 's01e02.mkv' to Library
2010-07-18 21:28:23,421 INFO [ContentDirectoryDefinitionParser] Parsing ContentDirectory definition
2010-07-18 21:28:33,312 INFO [LibraryAdditionsCheckerThread] Added file 's01e03.mkv' to Library
2010-07-18 21:28:48,281 INFO [LibraryAdditionsCheckerThread] Added file 's01e04.mkv' to Library
2010-07-18 21:29:02,625 INFO [LibraryAdditionsCheckerThread] Added file 's01e05.mkv' to Library
2010-07-18 21:29:19,296 INFO [LibraryAdditionsCheckerThread] Added file 's01e06.mkv' to Library
2010-07-18 21:29:34,343 INFO [LibraryAdditionsCheckerThread] Added file 's01e07.mkv' to Library
2010-07-18 21:29:48,921 INFO [LibraryAdditionsCheckerThread] Added file 's01e08.mkv' to Library
2010-07-18 21:30:03,656 INFO [LibraryAdditionsCheckerThread] Finished looking for newly added files
2010-07-18 21:30:08,000 INFO [LibraryUpdatesCheckerThread] Started looking for updates to currently shared files
2010-07-18 21:30:08,093 INFO [LibraryAdditionsCheckerThread] Started looking for newly added files
2010-07-18 21:30:11,375 INFO [LibraryAdditionsCheckerThread] Finished looking for newly added files
2010-07-18 21:30:11,546 INFO [LibraryAdditionsCheckerThread] Started looking for newly added files
2010-07-18 21:30:11,578 INFO [LibraryUpdatesCheckerThread] Started looking for updates to currently shared files
2010-07-18 21:30:13,750 INFO [LibraryAdditionsCheckerThread] Added file 'AbbyDedication.avi' to Library
2010-07-18 21:30:26,531 INFO [LibraryAdditionsCheckerThread] Added file 'VTS_01_1.VOB' to Library
2010-07-18 21:30:27,828 INFO [LibraryAdditionsCheckerThread] Added file 'backdrop.jpg' to Library
2010-07-18 21:30:36,406 INFO [LibraryAdditionsCheckerThread] Added file 'Blue Harvest.avi' to Library
2010-07-18 21:30:37,125 INFO [LibraryAdditionsCheckerThread] Added file 'folder.jpg' to Library
2010-07-18 21:30:37,390 INFO [LibraryAdditionsCheckerThread] Added file 'backdrop.jpg' to Library
2010-07-18 21:30:52,890 INFO [LibraryAdditionsCheckerThread] Added file 'Death at a Funeral.mkv' to Library
2010-07-18 21:30:53,578 INFO [LibraryAdditionsCheckerThread] Added file 'folder.jpg' to Library
2010-07-18 21:30:53,906 INFO [LibraryAdditionsCheckerThread] Added file 'backdrop.jpg' to Library
2010-07-18 21:30:54,000 INFO [LibraryAdditionsCheckerThread] Added file 'folder.jpg' to Library
2010-07-18 21:31:02,937 INFO [LibraryAdditionsCheckerThread] Added file 'TITLE01.avi' to Library
2010-07-18 21:31:19,171 INFO [LibraryAdditionsCheckerThread] Added file 'I Love To Conduct.mpeg' to Library
2010-07-18 21:31:31,796 INFO [LibraryAdditionsCheckerThread] Added file 'Origin Story.mpeg' to Library
2010-07-18 21:31:37,703 INFO [DiscoveryAdvertisementNotifier] Leaving DiscoveryAdvertisementNotifier
2010-07-18 21:31:37,703 INFO [WebServer] WebServer shutting down
2010-07-18 21:31:37,703 INFO [EventDispatcher] Leaving EventDispatcher

Here is the last time I ran Serviio from my PC:

2010-07-18 23:20:44,609 INFO [MediaServer] ------------------------------------------------------------------------
2010-07-18 23:20:44,609 INFO [MediaServer] Serviio DLNA media streaming server v 0.4.1 (rev. 41111e4c0a72)
2010-07-18 23:20:44,609 INFO [MediaServer] Petr Nejedly 2009-2010
2010-07-18 23:20:44,609 INFO [MediaServer] http://www.serviio.org
2010-07-18 23:20:44,609 INFO [MediaServer]
2010-07-18 23:20:44,609 INFO [MediaServer] Java 1.6.0_11-Sun Microsystems Inc.
2010-07-18 23:20:44,609 INFO [MediaServer] OS Windows XP x86 5.1
2010-07-18 23:20:44,609 INFO [MediaServer] File encoding: windows-1252
2010-07-18 23:20:44,609 INFO [MediaServer] ------------------------------------------------------------------------
2010-07-18 23:20:44,656 INFO [ORBServer] Starting Corba server exposed on localhost:23423
2010-07-18 23:20:44,656 INFO [NamingService] Starting Corba Naming service on port 23423
2010-07-18 23:20:45,562 INFO [DBSchemaUpdateExecutor] Checking if DB schema needs to be updated
2010-07-18 23:20:48,343 INFO [ProfilesDefinitionParser] Parsing Profiles definition
2010-07-18 23:20:48,734 INFO [ProfilesDefinitionParser] Added profile 'Generic DLNA profile' (id=1)
2010-07-18 23:20:49,031 INFO [ProfilesDefinitionParser] Added profile 'Samsung WiselinkPro (B-series)' (id=2)
2010-07-18 23:20:49,156 INFO [ProfilesDefinitionParser] Added profile 'XBox 360' (id=3)
2010-07-18 23:20:49,359 INFO [ProfilesDefinitionParser] Added profile 'Playstation 3' (id=4)
2010-07-18 23:20:49,437 INFO [ProfilesDefinitionParser] Added profile 'Samsung WiselinkPro (A-series)' (id=5)
2010-07-18 23:20:49,625 INFO [ProfilesDefinitionParser] Added profile 'DirecTV HD-DVR' (id=6)
2010-07-18 23:20:49,718 INFO [ProfilesDefinitionParser] Added profile 'Samsung WiselinkPro (C-series)' (id=7)
2010-07-18 23:20:49,750 INFO [ProfilesDefinitionParser] Added profile 'LG BD player' (id=8)
2010-07-18 23:20:50,031 INFO [ProfilesDefinitionParser] Added profile 'Sony BDP-S370' (id=9)
2010-07-18 23:20:52,734 INFO [VideoDeliveryEngine] Cleaning transcode engine and its data
2010-07-18 23:20:52,984 INFO [WebServer] WebServer starting on port 8895
2010-07-18 23:20:54,218 INFO [Device] Created UPnP Device with UUID: ee42199b-6787-3b82-bd84-f024ac5cda48, bound address: 192.168.0.102
2010-07-18 23:20:54,421 INFO [CompositeCacheManager] Creating cache manager from config file: /cache.ccf
2010-07-18 23:20:54,468 INFO [ThreadPoolManager] thread_pool.default PoolConfiguration = useBoundary = [true] boundarySize = [2000] maximumPoolSize = [150] minimumPoolSize = [4] keepAliveTime = [300000] whenBlockedPolicy = [RUN] startUpSize = [4]
2010-07-18 23:20:54,500 INFO [CompositeCacheConfigurator] Setting default auxiliaries to null
2010-07-18 23:20:54,500 INFO [CompositeCacheConfigurator] No special CompositeCacheAttributes class defined for key [jcs.default.cacheattributes], using default class.
2010-07-18 23:20:54,500 INFO [CompositeCacheConfigurator] setting defaultCompositeCacheAttributes to [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 100, maxSpoolPerRun = -1, diskUsagePattern = 0 ]
2010-07-18 23:20:54,500 INFO [CompositeCacheConfigurator] No special ElementAttribute class defined for key [jcs.default.elementattributes], using default class.
2010-07-18 23:20:54,500 INFO [CompositeCacheConfigurator] setting defaultElementAttributes to [ IS_LATERAL = true, IS_SPOOL = true, IS_REMOTE = true, IS_ETERNAL = true, MaxLifeSeconds = -1, IdleTime = -1, CreateTime = 1279513254500, LastAccessTime = 1279513254500, getTimeToLiveSeconds() = -1, createTime = 1279513254500 ]
2010-07-18 23:20:54,515 INFO [CompositeCacheConfigurator] No special ElementAttribute class defined for key [jcs.region.local_resetafterplay.elementattributes], using default class.
2010-07-18 23:20:54,562 INFO [LRUMemoryCache] initialized LRUMemoryCache for local_resetafterplay
2010-07-18 23:20:54,578 INFO [CompositeCache] Constructed cache with name [local_resetafterplay] and cache attributes [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 1000, maxSpoolPerRun = -1, diskUsagePattern = 0 ]
2010-07-18 23:20:54,578 INFO [CompositeCacheConfigurator] No special ElementAttribute class defined for key [jcs.region.local_default.elementattributes], using default class.
2010-07-18 23:20:54,578 INFO [LRUMemoryCache] initialized LRUMemoryCache for local_default
2010-07-18 23:20:54,578 INFO [CompositeCache] Constructed cache with name [local_default] and cache attributes [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 1000, maxSpoolPerRun = -1, diskUsagePattern = 0 ]
2010-07-18 23:20:54,578 INFO [CompositeCacheConfigurator] Parsed regions [local_resetafterplay, local_default]
2010-07-18 23:20:54,578 INFO [CompositeCacheConfigurator] Finished configuration in 110 ms.
2010-07-18 23:20:54,609 INFO [DiscoveryAdvertisementNotifier] Starting DiscoveryAdvertisementNotifier
2010-07-18 23:20:54,625 INFO [DiscoverySearchListener] Starting DiscoverySearchListener using interface 192.168.0.102
2010-07-18 23:20:54,625 INFO [EventSubscriptionExpirationChecker] Starting EventSubscriptionExpirationChecker
2010-07-18 23:20:54,625 INFO [EventDispatcher] Starting EventDispatcher
2010-07-18 23:21:07,984 INFO [ServiioConsole] Starting Serviio Console
2010-07-18 23:21:10,390 INFO [UpdateChecker] Checking if a new version is available
2010-07-18 23:21:14,625 INFO [LibraryAdditionsCheckerThread] Started looking for newly added files
2010-07-18 23:21:14,625 INFO [LibraryUpdatesCheckerThread] Started looking for updates to currently shared files
2010-07-18 23:21:52,796 INFO [LibraryUpdatesCheckerThread] Updating 'Pluto's Playmate' in Library
2010-07-18 23:22:25,453 INFO [LibraryUpdatesCheckerThread] Updating 'CloneWarsS1V1' in Library
2010-07-18 23:22:43,500 INFO [LibraryUpdatesCheckerThread] Updating 'dts_experience' in Library
2010-07-18 23:22:52,828 INFO [LibraryUpdatesCheckerThread] Updating 'dts_orchestra' in Library
2010-07-18 23:22:55,171 INFO [LibraryUpdatesCheckerThread] Updating 'dts_piano' in Library
2010-07-18 23:22:56,031 INFO [ContentDirectoryDefinitionParser] Parsing ContentDirectory definition
2010-07-18 23:22:58,890 INFO [LibraryUpdatesCheckerThread] Updating 'Bruce Lee: The Man, the Myth' in Library
2010-07-18 23:23:01,125 INFO [LibraryUpdatesCheckerThread] Updating 'Bruce Lee: The Man, the Myth' in Library
2010-07-18 23:23:03,281 INFO [LibraryUpdatesCheckerThread] Updating 'dts_the_digital_experience' in Library
2010-07-18 23:23:07,015 INFO [LibraryUpdatesCheckerThread] Updating 'hd_dts_sfx' in Library
2010-07-18 23:23:18,953 INFO [LibraryUpdatesCheckerThread] Updating 'other_digital_cinema_sound' in Library
2010-07-18 23:23:24,328 INFO [LibraryUpdatesCheckerThread] Updating 'other_meet_the_robinsons_handy_off' in Library
2010-07-18 23:23:27,687 INFO [LibraryUpdatesCheckerThread] Updating 'thx_the_science' in Library
2010-07-18 23:23:29,328 INFO [LibraryUpdatesCheckerThread] Updating 'Heavy Losses' in Library
2010-07-18 23:23:38,109 INFO [LibraryUpdatesCheckerThread] Updating 'Over and Out' in Library
2010-07-18 23:23:46,078 INFO [LibraryUpdatesCheckerThread] Updating 'New Orders' in Library
2010-07-18 23:23:54,437 INFO [LibraryUpdatesCheckerThread] Updating 'Trial & Error' in Library
2010-07-18 23:24:03,437 INFO [LibraryUpdatesCheckerThread] Updating 'The Train Job' in Library
2010-07-18 23:24:18,593 INFO [LibraryUpdatesCheckerThread] Updating 'Bushwhacked' in Library
2010-07-18 23:24:34,921 INFO [LibraryUpdatesCheckerThread] Updating 'Our Mrs. Reynolds' in Library
2010-07-18 23:24:52,578 INFO [LibraryUpdatesCheckerThread] Updating 'Jaynestown' in Library
2010-07-18 23:25:07,421 INFO [LibraryUpdatesCheckerThread] Updating 'Out of Gas' in Library
2010-07-18 23:25:08,343 INFO [ServiioConsole] Leaving Serviio Console
2010-07-18 23:25:09,406 INFO [AbstractModel] Remote exception occured, removing the listener: CORBA COMM_FAILURE 1398079696 Maybe; nested exception is:
org.omg.CORBA.COMM_FAILURE: vmcid: SUN minor code: 208 completed: Maybe
2010-07-18 23:25:09,500 INFO [DiscoveryAdvertisementNotifier] Leaving DiscoveryAdvertisementNotifier
2010-07-18 23:25:09,500 INFO [EventSubscriptionExpirationChecker] Leaving EventSubscriptionExpirationChecker, removing all event subscriptions
2010-07-18 23:25:09,500 INFO [EventDispatcher] Leaving EventDispatcher
2010-07-18 23:25:09,500 INFO [WebServer] WebServer shutting down
2010-07-18 23:25:09,500 INFO [DiscoverySearchListener] Leaving DiscoverySearchListener
2010-07-18 23:25:09,515 INFO [DatabaseManager] Shutting down database
2010-07-18 23:25:11,812 INFO [ORBServer] Stopped Corba server
2010-07-18 23:25:11,812 INFO [VideoDeliveryEngine] Cleaning transcode engine and its data
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17154

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Jul 22, 2010 8:46 am

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

No problems there. Does the player support MKVs? If not, you'll have to use the profile someone mentioned above (one that changes mime-type of mkv files to divx), that should be playable.

I'll add profile for this player into 0.4.2
<<

bh4bama

Serviio newbie

Posts: 3

Joined: Tue Jul 20, 2010 8:24 pm

Location: Montgomery, AL

Post Thu Jul 22, 2010 1:24 pm

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

Being that I'm in USA, I'm thinking there are some differences to each model released based on geography besides PAL/NTSC. I spoke to Sony Support and they said mine can view MKV files from a USB, not via DLNA. Which tells me that I would have to transcode it. I have tried different variations of the profile, but nothing seems to work yet. Per my manual, DIVX can be played by Canadian models only. Sony Support and the manual both state it will play MPEG files via DLNA. I have encoded various VOB and MKV files into MPEG and sometimes they work and sometimes they don't. I haven't found the perfect software combination for encoding. I've attached a snippet that shows the playable files from the North American manual.
Attachments
Playablefiles.JPG
Playablefiles.JPG (86.56 KiB) Viewed 16994 times
<<

Lowlander

DLNA master

Posts: 152

Joined: Wed Jun 16, 2010 12:01 pm

Location: Germany

Post Thu Jul 22, 2010 3:59 pm

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

Hi there,

I think that Sony is a bit careful here not to create - potentially false - hopes of playing formats/containers that are not part of the DLNA standard itself. And playback of the mkv container is AFAIK not part of the DLNA standard.

The (i.e. my European) S370 does play local mkv files, as long as it understands all contained audio/video formats. So why shouldn't it play the very same files when fed over the network? At first my S370 didn't list any mkv's from Serviio, but after the above modification to the profile, it instantly listed and played all of them (meaning all those it could play locally as well). Transcoding is disabled on my server.

If you consider the infinite wealth of commercial and open source AV formats, codecs, codec flavours and revisions, potentially wrong or inappropriately set codec parameters, the Sony does a pretty good job for a device where all codecs are stored in a firmware, opposed to a PC, where adding another codec to be able to watch video xyz is no problem whatsoever.
| Serviio Pro 1.6 (Win Server 2008 R2, Athlon 240e, 4GB RAM, 6TB HDD) |
| Sony KDL-42W829B | Sony KDL-24EX320 | Yamaha BD-S677 | assorted iDevices |
<<

Begall

Serviio newbie

Posts: 6

Joined: Wed Jul 21, 2010 7:49 pm

Post Thu Jul 22, 2010 8:33 pm

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

Here's the lowdown on MKV playing with the S370:

- It won't actually show MKV's natively. You need to either use the profile posted on the first page of this thread to make serviio display them as DivX files, or you need to go through and rename them all to avi's.

- This'll let you play most MKV's flawlessly.

- The ones that don't work are the ones encoded at a profile level > 4.0. This is an issue that it shares in common with the PS3, as such, there's quite a few guides on how to get around it. The one I used was http://tehparadox.com/forum/f41/how-con ... mp4-47815/ You can ignore all the stuff about converting to MP4, all you have to do is strip the h264 stream out of the file, put it into h264info and type '4' into the profile level box. You can then merge it back together with the audio stream no problems as an MKV file, which you then either rename to .avi or use the Serviio profile.

Hope this helps! :)

Edit: I suppose if you transcoded all MKV files then you could get around the problem, it just might have an unnecessary impact on the quality of most of them.
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17154

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Thu Jul 22, 2010 9:03 pm

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

Renaming means nothing to Serviio. The profile posted on the first page only changes the way they are server do the player, but it's still a native MKV - no quality loss there.
<<

Begall

Serviio newbie

Posts: 6

Joined: Wed Jul 21, 2010 7:49 pm

Post Thu Jul 22, 2010 9:12 pm

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

The renaming was actually something I used to get around the problem with other software - namely WMP, which won't even add MKV's to its library, but I included it here for completeness. My edited in point was that you could avoid all the fucking around with profile levels by setting serviio to transcode all mkvs to another, more compatible, more format. I'm aware that the profile on the 1st page is still sending native MKV :)
<<

Willems

Serviio newbie

Posts: 17

Joined: Sun Jul 25, 2010 5:36 am

Post Sun Jul 25, 2010 5:44 am

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

zip wrote:No problems there. Does the player support MKVs? If not, you'll have to use the profile someone mentioned above (one that changes mime-type of mkv files to divx), that should be playable.

I'll add profile for this player into 0.4.2


The player actually does not support MKVs over DLNA. (Why???) However the profile used is working great, unfortunately there are some glitches when playing files to my Sony (BDP-S470, which is exactly the same in the DLNA area). If I pause the movie and start it again, it starts shaking. And sometimes during a movie there is a few seconds pause and the image turns black. (Would be nice if this could be solved in the new version of Serviio)

That said! I think Serviio is great, of the many UPNP servers around this one won my tests.
<<

jackal

Serviio newbie

Posts: 9

Joined: Sun Jul 25, 2010 11:48 am

Post Mon Jul 26, 2010 12:15 am

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

I am running serviio-0.4.1 on (Linux weizen 2.6.32-23-generic-pae #37-Ubuntu SMP Fri Jun 11 09:26:55 UTC 2010 i686 GNU/Linux
) along with the BDP-S370 firmware M03.R.623. I am having the same problems others have mentioned. I can see the serviio server in Photos and Music, but not under Video.

Photos and Music can both be viewed and played. I have tried numerious combinations of rediscovering the server and restarting the serviio to no avail.

I have try both the generic profile along with the following for the Sony BDP-S370

  Code:

       <Profile id="9" name="Sony BDP-S370" extendsProfileId="1">
                 <Detection>
                 <X-AV-Client-Info>.*Blu-ray Disc Player.*</X-AV-Client-Info>
                 </Detection>
                 <MediaFormatProfiles>
                        <MediaFormatProfile mime-type="video/divx">MATROSKA</MediaFormatProfile>
                 </MediaFormatProfiles>

                 <Transcoding>
                     <Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3">
                           <Matches container="matroska" vCodec="h264" />
                           <Matches container="mpegts" vCodec="h264" />
                           <Matches container="avi" vCodec="h264" />
                     </Video>
                 </Transcoding>
                <AutomaticImageRotation>true</AutomaticImageRotation>
        </Profile>


<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17154

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Tue Jul 27, 2010 8:49 pm

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

Ok, let's try to come up with a working profile. From what Iread it can play MKV natively (with a proper mime type), it also seems to like h264 in mkv, ts & mp4. So this should be ok:

  Code:
<Profile id="7" name="Sony BDP-S370" extendsProfileId="1">
<Detection>
<X-AV-Client-Info>.*Blu-ray Disc Player.*</X-AV-Client-Info>
</Detection>
<MediaFormatProfiles>
  <MediaFormatProfile mime-type="video/divx">MATROSKA</MediaFormatProfile>
</MediaFormatProfiles>
</Profile>


There is no transcoding setup there. Can you confirm what file types you cannot play with this and supply result of:
  Code:
ffmpeg -i "<the_file>"
<<

Illico

User avatar

DLNA master

Posts: 4646

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Wed Jul 28, 2010 10:51 am

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

Hi,

If I have time, I would test that this evening with my BDP-S373 Blu-ray Disc Player

  Code:
    <Profile id="10" name="Sony BDP-S370" extendsProfileId="1">
        <Detection>
            <X-AV-Client-Info>.*Blu-ray Disc Player.*</X-AV-Client-Info>
        </Detection>
        <MediaFormatProfiles>
            <MediaFormatProfile mime-type="video/divx">MATROSKA</MediaFormatProfile>
        </MediaFormatProfiles>     
        <AutomaticImageRotation>true</AutomaticImageRotation>
    </Profile>


I use the same firmware version M03.R.623 of BDP-S370 / BDP-S373 models
Illico
Sony 2010 KDL-46EX501 | BDP-S373 | SMP-N100 | Windows 8-i7 | Network DD HD-CE1.5TLU2 | Livebox2-UHD86 | ServiiDroid | ServiiGo | BubbleUPnP
Serviio beta tester - Moderator
<<

Illico

User avatar

DLNA master

Posts: 4646

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Wed Jul 28, 2010 6:57 pm

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

I'm just trying this profile, and I think its a good base of profile for BDP-S370 player. MPEG-TS, MPEG-PS, AVI/divx, MKV with Profile <4.1
But some files could not PLAY, I'will look on log file later. BDAV/M2ts, mov, mp4.
Illico
Sony 2010 KDL-46EX501 | BDP-S373 | SMP-N100 | Windows 8-i7 | Network DD HD-CE1.5TLU2 | Livebox2-UHD86 | ServiiDroid | ServiiGo | BubbleUPnP
Serviio beta tester - Moderator
<<

Illico

User avatar

DLNA master

Posts: 4646

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Thu Jul 29, 2010 6:27 pm

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

I test the following profile :
  Code:
   <Profile id="10" name="Sony BDP-S370" extendsProfileId="1">
         <Detection>
            <X-AV-Client-Info>.*Blu-ray Disc Player.*</X-AV-Client-Info>
      </Detection>
      <MediaFormatProfiles>
         <MediaFormatProfile mime-type="video/divx">MATROSKA</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVI</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_TS_MP_SD_AAC_MULT5</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_TS_MP_SD_MPEG1_L3</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_TS_MP_SD_AC3</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_TS_MP_HD_AAC_MULT5</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_TS_MP_HD_MPEG1_L3</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_TS_MP_HD_AC3</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_TS_HD_50_LPCM_T</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_MP4_MP_SD_AAC_MULT5</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_MP4_MP_SD_MPEG1_L3</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_MP4_MP_SD_AC3</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_MP4_MP_HD_720p_AAC</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_MP4_MP_HD_1080i_AAC</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_MP4_HP_HD_AAC</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">AVC_MP4_LPCM</MediaFormatProfile>
         <MediaFormatProfile mime-type="video/divx">MPEG4_P2_MP4_ASP_AAC</MediaFormatProfile>
      </MediaFormatProfiles>
           <AutomaticImageRotation>true</AutomaticImageRotation>
   </Profile>


OK with
- AVI-MPEG4Divx5-MP3
- AVI-MEG4XviD-MP3
- BDAV - AVCL4.0 - AC3
- DIVX - MPEG4Divx5 - MP3
- MKV - AVCL4.0 - AAC
- MOV - MPEG4 - AAC
- MP4 - AVC - AAC
- MP4 - MPEG4V - AAC
- MPEGPS - MPEG1 - MP1L2
- MPEGTS - MPEG2 - AC3
- MPEGTS - MPEG2 - MP1L2

KO for some files
- AVI-VC1-AAC
- BDAV - AVCL4.0 - DTS -> DTS probacly not supported
- MKV - AVCL5.1 - AC3 -> AVC Profile Level > 4.0
- MKV - MPEG4DivX5 - AAC -> don't know
- MPEGTS - AVC - AC3 -> don't know
Illico
Sony 2010 KDL-46EX501 | BDP-S373 | SMP-N100 | Windows 8-i7 | Network DD HD-CE1.5TLU2 | Livebox2-UHD86 | ServiiDroid | ServiiGo | BubbleUPnP
Serviio beta tester - Moderator
<<

zip

User avatar

Serviio developer / Site Admin

Posts: 17154

Joined: Sat Oct 24, 2009 12:24 pm

Location: London, UK

Post Fri Jul 30, 2010 8:14 am

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

Does it really have to use video/divx for everything or just MKV and AVI?
The files it doesn't play will have to be transcoded then...
<<

jackal

Serviio newbie

Posts: 9

Joined: Sun Jul 25, 2010 11:48 am

Post Thu Aug 05, 2010 7:48 pm

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

So apparently the BDP-S370 (firmware version M03.R.623) does not support DLNA video. At least not in the US. Hence the reasons why people are complaining that they get no video icon for the Media Server, but get Photo, and Music/Audio. I talked to Sony Support who confirmed this and said that it will be support in a future firmware. The only date they could provide was within the next three months.

Cheers,
<<

insane822

User avatar

Serviio lover

Posts: 61

Joined: Sat Aug 07, 2010 5:32 am

Post Sat Aug 07, 2010 5:36 am

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

jackal wrote:So apparently the BDP-S370 (firmware version M03.R.623) does not support DLNA video. At least not in the US. Hence the reasons why people are complaining that they get no video icon for the Media Server, but get Photo, and Music/Audio. I talked to Sony Support who confirmed this and said that it will be support in a future firmware. The only date they could provide was within the next three months.

Cheers,


That sounds strange. I have a US BDP-S370 and Serviio shows up under video sometimes, but not other times.. almost totally random it seems. When using Windows media Player as a DLNA server, it shows up under video 100% of the time.

I'm not sure if it's a Sony problem or a Serviio problem.. but I have no issues with WMP showing up, but I want to use Serviio for mkv! :D
<<

Brammers

Serviio lover

Posts: 87

Joined: Sat Jul 24, 2010 7:58 am

Post Sat Aug 07, 2010 8:20 am

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

Could be related to the issue I reported.

It's already in bitbucket, with logs attached - http://bitbucket.org/xnejp03/serviio/is ... to-clients

But if you can add more debug log samples of when this happens, I'm sure it would help!

J
<<

Illico

User avatar

DLNA master

Posts: 4646

Joined: Fri Jul 23, 2010 8:08 am

Location: France

Post Sun Aug 08, 2010 9:12 am

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

zip wrote:Does it really have to use video/divx for everything or just MKV and AVI?

On Bravia, when you browse files, there were an icon with the name of the file.
When you start a movie and press "Display" button you could have information on file (codec,bitrate,etc...)

AVI appears with Divx icon on Bravia TV and when start the information is set to DivX
BDAV with AVC appears with Divx icon but when start the information is set to AVC
DivX appears with DivX icon and when start the information is set to DivX
MKV appears with DivX icon and when start information is set to AVC-AAC
MOV appears with DivX and when start information is set to DivX
MP4 appears with DivX and when start information is set to AVC or DivX depends of Vcodec used in the MP4 container
MPEGPS appears with MPEG icon also for inofrmation
MPEGTS appears with M2TS icon and information is set to MPEG

MP3 and JPEG work fine
Illico
Sony 2010 KDL-46EX501 | BDP-S373 | SMP-N100 | Windows 8-i7 | Network DD HD-CE1.5TLU2 | Livebox2-UHD86 | ServiiDroid | ServiiGo | BubbleUPnP
Serviio beta tester - Moderator
<<

KHendricks

Serviio newbie

Posts: 7

Joined: Mon Aug 09, 2010 6:16 pm

Post Mon Aug 09, 2010 6:37 pm

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

Brammers wrote:Could be related to the issue I reported.

It's already in bitbucket, with logs attached - http://bitbucket.org/xnejp03/serviio/is ... to-clients

But if you can add more debug log samples of when this happens, I'm sure it would help!

J


Hi,

I just bought a Sony BDP-S370 and updated it to the latest firmware. Using serviio on Mac OSX I was able to add the Sony profile that was posted here as item "9" and it is recognized and used. The problem is stuttering of high definition vide even though I am using a hardwired ethernet cable to the 100baseT netowrk adapter on the Sony. (My home network is gigabit ethernet).

I was trying to figure out why the stuttering and looked at your log files just in case it told me anything.

If you look at the end of your 5th log file, you will see that at some point serviio server tried to dump the entire 734 meg file in one socket all at the same time causing a content error:

2010-07-29 18:53:59,610 DEBUG [VideoDeliveryEngine] Delivering file 'so.you.think.you.can.dance.s07e18.hdtv.xvid-fqm.avi' in native format
2010-07-29 18:53:59,610 DEBUG [MediaItemDAOImpl] Getting file of media item 6277
2010-07-29 18:53:59,611 DEBUG [MediaItemDAOImpl] Marking MediaItem (id = 6277) as read
2010-07-29 18:53:59,611 DEBUG [LocalContentCacheDecorator] Cleared cache (local_resetafterplay)
2010-07-29 18:53:59,611 DEBUG [ResourceTransportRequestHandler] Creating stream entity with length: 734838986
2010-07-29 18:53:59,611 DEBUG [ResourceTransportRequestHandler] Sending file back
2010-07-29 18:53:59,611 DEBUG [ResourceTransportRequestHandler] HTTP/1.1 206 Partial Content, headers = [Content-Type: video/x-msvideo, Content-Range: bytes 0-734838985/734838986, Content-Length: 734838986, Cache-control: no-cache, Pragma: no-cache, Server: Windows 7 UPnP/1.0 Serviio 0.4.1, contentFeatures.dlna.org: DLNA.ORG_PN=AVI;DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=81100000000000000000000000000000, transferMode.dlna.org: Streaming, ]
2010-07-29 18:53:59,943 DEBUG [WebServer] I/O error: Connection reset by peer: socket write error


Throughout most of the session it is using a more modest content length that the internal socket buffers can actually handle:


2010-07-29 18:53:58,305 DEBUG [VideoDeliveryEngine] Delivering item '6277' for client 'IPAddress=/10.10.0.99, Profile=Sony BDP-S370'
2010-07-29 18:53:58,305 DEBUG [VideoDeliveryEngine] Delivering file 'so.you.think.you.can.dance.s07e18.hdtv.xvid-fqm.avi' in native format
2010-07-29 18:53:58,305 DEBUG [MediaItemDAOImpl] Getting file of media item 6277
2010-07-29 18:53:58,306 DEBUG [ResourceTransportRequestHandler] Creating stream entity with length: 127744
2010-07-29 18:53:58,306 DEBUG [ResourceTransportRequestHandler] Sending file back
2010-07-29 18:53:58,306 DEBUG [ResourceTransportRequestHandler] HTTP/1.1 206 Partial Content, headers = [Content-Type: video/x-msvideo, Content-Range: bytes 734535066-734662809/734838986, Content-Length: 127744, Cache-control: no-cache, Pragma: no-cache, Server: Windows 7 UPnP/1.0 Serviio 0.4.1, contentFeatures.dlna.org: DLNA.ORG_PN=AVI;DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=81100000000000000000000000000000, transferMode.dlna.org: Streaming, ]


So it appears that the serviio server is messing up the content length it tries to write to the socket.

This may be happening at other times and this may in fact be the cause of the stuttering.

I am new to the forum but I have not been able to see how to enable the DEBUG logging for my own system.

Also is the java source code available for download anyplace so that I can play around with it?

Thanks,

Kevin
<<

Brammers

Serviio lover

Posts: 87

Joined: Sat Jul 24, 2010 7:58 am

Post Mon Aug 09, 2010 6:43 pm

Re: Problems with MKV / H.264 on Sony BDP-S370 Bluray-Player

See the sticky thread for how to enable debug logging ("How to turn on detailed logging").

You'd have to ask "zip" about the source code.

J
PreviousNext

Return to Sony

Who is online

Users browsing this forum: No registered users and 7 guests

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.