FAQ  •  Register  •  Login

[mac][37LE5500] Subtitles not playing

<<

morphi

Serviio newbie

Posts: 2

Joined: Wed Aug 03, 2011 8:20 pm

Post Wed Aug 03, 2011 8:47 pm

[mac][37LE5500] Subtitles not playing

Hello,

I own a LG 37LE5500 and I using serviio on a mac 0sx 10.6.8. It is the best solution, I have found so far - thank for your effort in putting it together.
Only issue is that subtitles are not playing.
Looking into the forum, I found that it could help to change the default profile of the client to solve some problems but I couldn't find where the value is to be set in the mac console.
So I have edited the file manually and added the line related to tex/srt in the generic profile but it doesn't work (Sorry I know it written in big - DO NOT EDIT) :-)

I am playing file 12AngryMen.avi which is stored along 12AngryMen.srt.
It is playing just fine but without the subtiltes.

Would you be able to point me to the right direction, I enclose the log for your information. There is an error and no mention of retrieving a srt file.

Thanks,
francois

logs - Startup then playing 12AngryMen.avi:

  Code:
2011-08-03 22:41:27,902 INFO  [WebServer] WebServer starting on port 8895
2011-08-03 22:41:27,903 INFO  [EventSubscriptionExpirationChecker] Starting EventSubscriptionExpirationChecker
2011-08-03 22:41:27,903 INFO  [DiscoverySSDPMessageListener] Starting DiscoverySSDPMessageListener using interface en0 (en0) and address 10.0.0.141, timeout = 0
2011-08-03 22:41:27,903 INFO  [EventDispatcher] Starting EventDispatcher
2011-08-03 22:41:27,903 INFO  [RendererSearchSender] Searching for Renderer devices
2011-08-03 22:41:27,903 INFO  [DiscoveryAdvertisementNotifier] Starting DiscoveryAdvertisementNotifier
2011-08-03 22:42:01,696 WARN  [ContentDirectory] Browse for object id V_F#FOL_R1$F2/12AngryMen.avi failed with exception: null
java.lang.NullPointerException
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.getObjectValueForAttribute(GenericDLNAMessageBuilder.java:301)
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.getObjectValue(GenericDLNAMessageBuilder.java:284)
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.storeAttribute(GenericDLNAMessageBuilder.java:240)
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.storeAttribute(GenericDLNAMessageBuilder.java:257)
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.storeItemFields(GenericDLNAMessageBuilder.java:152)
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.storeObjectNode(GenericDLNAMessageBuilder.java:128)
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.buildXML(GenericDLNAMessageBuilder.java:102)
   at org.serviio.upnp.service.contentdirectory.ContentDirectory.setupSuccessfulResult(ContentDirectory.java:377)
   at org.serviio.upnp.service.contentdirectory.ContentDirectory.Browse(ContentDirectory.java:209)
   at sun.reflect.GeneratedMethodAccessor21.invoke(Unknown Source)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeOperation(ServiceInvoker.java:253)
   at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeService(ServiceInvoker.java:93)
   at org.serviio.upnp.webserver.ServiceControlRequestHandler.handleRequest(ServiceControlRequestHandler.java:73)
   at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:54)
   at org.apache.http.protocol.HttpService.doService(HttpService.java:293)
   at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:58)
   at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:212)
   at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:187)
2011-08-03 22:42:01,717 WARN  [ContentDirectory] Browse for object id V_F#FOL_R1$F2/12AngryMen.avi failed with exception: null
java.lang.NullPointerException
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.getObjectValueForAttribute(GenericDLNAMessageBuilder.java:301)
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.getObjectValue(GenericDLNAMessageBuilder.java:284)
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.storeAttribute(GenericDLNAMessageBuilder.java:240)
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.storeAttribute(GenericDLNAMessageBuilder.java:257)
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.storeItemFields(GenericDLNAMessageBuilder.java:152)
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.storeObjectNode(GenericDLNAMessageBuilder.java:128)
   at org.serviio.upnp.service.contentdirectory.GenericDLNAMessageBuilder.buildXML(GenericDLNAMessageBuilder.java:102)
   at org.serviio.upnp.service.contentdirectory.ContentDirectory.setupSuccessfulResult(ContentDirectory.java:377)
   at org.serviio.upnp.service.contentdirectory.ContentDirectory.Browse(ContentDirectory.java:209)
   at sun.reflect.GeneratedMethodAccessor21.invoke(Unknown Source)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeOperation(ServiceInvoker.java:253)
   at org.serviio.upnp.protocol.soap.ServiceInvoker.invokeService(ServiceInvoker.java:93)
   at org.serviio.upnp.webserver.ServiceControlRequestHandler.handleRequest(ServiceControlRequestHandler.java:73)
   at org.serviio.upnp.webserver.AbstractRequestHandler.handle(AbstractRequestHandler.java:54)
   at org.apache.http.protocol.HttpService.doService(HttpService.java:293)
   at org.serviio.upnp.webserver.ServiioHttpService.doService(ServiioHttpService.java:58)
   at org.apache.http.protocol.HttpService.handleRequest(HttpService.java:212)
   at org.serviio.upnp.webserver.WebServer$WorkerThread.run(WebServer.java:187)
<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Wed Aug 03, 2011 8:55 pm

Re: [mac][37LE5500] Subtitles not playing

next to your device is a drop down menu click on it and then you can set the correct profile.
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging
<<

morphi

Serviio newbie

Posts: 2

Joined: Wed Aug 03, 2011 8:20 pm

Post Thu Aug 04, 2011 4:50 pm

Re: [mac][37LE5500] Subtitles not playing

yes got it !!
thanks

With the LG profile given on this forum, the subtitles are now working just fine.

Cheers
<<

Cerberus

User avatar

DLNA master

Posts: 4116

Joined: Sun Jan 02, 2011 5:20 pm

Location: Reading, UK

Post Thu Aug 04, 2011 5:39 pm

Re: [mac][37LE5500] Subtitles not playing

morphi wrote:yes got it !!
thanks

With the LG profile given on this forum, the subtitles are now working just fine.

Cheers


your welcome..
Phil Bennett
Beta Tester Group
Wiki | FAQ

Samsung LE40C750 LCD | Samsung BD-C5900 | Sony PS3 | Windows 7 |
HowTo: Provide supported formats of a device HowTo: Record a new ticket on Bitbucket
HowTo: Provide details of a video file that doesn't play HowTo: Turn on detailed logging

Return to LG

Who is online

Users browsing this forum: No registered users and 1 guest

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.